Why is Telegram launching Firefox instead of Brave

I finally stopped using Firefox and switched over to Brave entirely. However, I didn’t uninstall Firefox. Anytime I click on an article url within a Telegram channel, the article will launch Firefox and load up there.

I’ve tried to delink the two from within Telegram and from within Firefox, but can’t find a way to do it. I’d like the Telegram links to articles to launch in Brave if possible.

Any ideas? It’s got to be easy, right?

I’ve had to remove Firefox when using Brave because Firefox wouldn’t relinquish its hold on default browser. I later installed Firefox and made sure it wasn’t the default browser. I was appalled that Firefox did that. Firefox’s bad behavior is one reason why I continued with Brave.

1 Like

I know I messed with this yesterday and day before on three linux computers.
I can tell you within the Brave browser in settings there is a place to mark it as primary or “default”
and it made it the default browser in all my Linux Mint systems. I had no issues as Bluehhost05 had.

Currently Brave browser is currently very noticeably popping up a message indicating it will be established as the default browser if you click the button shown with that message. Even though I’d previously made it default, a while back the only I could get it to be the default was to uninstall Firefox. I’ve noticed that change the last time I installed a different distro. That time Firefox gave way to Brave as its being the default browser. So I was glad to see Firefox give in about that.

I noticed this issue the other day, except Firefox is my default and TG opens links in Chromium, and I cannot figure out how to switch it.

1 Like

Thanks. I’m going to try to default Brave again to see if it changes anything. If not, I’ll just remove firefox permanently. Thanks, again.

It’s possible that if you have to uninstall Firefox, once that’s done and you’ve rebooted, Brave should be established as the default browser. Then, if you want Firefox back, as a backup browser, you could install it again. Perhaps it wouldn’t overstep its rights this time. If it does, give it the ax again. Also, be sure to check your preferred applications, to ensure that Brave is your default browser.

I had the same issue exactly.
I had to change in settings, under default applications -web- firefox change to brave

6 Likes

If you have 2 or more browsers installed and you want to chose among them: inside telegram - go to chat settings, scroll down to settings and turn off in-app browser.