VPN stopped working, Brave browser not working

I’ve been working with Shane to try to resolve connecting to my air printer but we haven’t come up with a solution (printer is shown on printer list, and I was able to print a test page, but nothing else prints from anywhere else). Yesterday while watching a show on Kodi, the sound went out. I backed out of the program and noticed my Proton vpn had stopped working. In addition to that, when I open my software, the list for “Installed” will not load; it just stays a blank screen. I have shut down and restarted multiple times, I have removed the Clmtk anti-virus, and removed Kodi just in case they were an issue (though everything was working fine for several hours the same day). I verified that the sound worked in a video on Telegram. The other strange thing that happened is I cannot open a search window in Brave; only if I open a private window with Tor. I just tried updating the system and received lots of “error” and “failure” language. No idea what happened or what I did to break it :woman_shrugging:t2: Please help :grimacing:

Something seems wrong with your network/internet connection. I am not sure what it is. Since ping -c 6 cloudflare.com returns “temporary failure in name resolution” there is definitely a networking issue. I just don’t understand why you can use Telegram and Tor.

Did you uninstall Proton VPN if not, try that. If that went wonkers for some reason it might be causing these issues.

What do you think @vasileios?

Yep, I uninstalled Proton VPN last night. It got me a little further in that it allowed me to get to a login screen. But, after putting in my sign in info, I got a window giving me several reasons why Proton would not work. I also tried switching to a different wifi network in our house (we have one through the router and another address through the router expander).

Just tried opening my FreeTube app and it will not load. “Insidious API error”.

Have you tried plunging directly into your router with an Ethernet cable? If not try that.

I can try that in a few hours when my husband is done working- he’s got his work computer set up at home and is using the cable.

Hey @Jules!

This is something I’ve encountered before. Here’s the solution:

sudo apt update
sudo apt install resolvconf

In case ResolvConf is not installed.
Note: To get temporary name resolution, open up:

sudo nano /etc/resolv.conf

Clear out all the nameservers and add in:


Then hit CTRL+O then Enter to save and then CTRL+X.

Then hit:

sudo systemctl restart NetworkManager.service

Then you will be able to do the apt command above.

sudo systemctl start resolvconf.service
sudo systemctl enable resolvconf.service
sudo systemctl status resolvconf.service

To make sure that it is up and running - and also enabled for the startup.

sudo nano /etc/resolvconf/resolv.conf.d/head

And add the following lines.

1 Like

Going to do this now-will let you know what happens! Thank you!

1 Like

Have a question: as soon as I enter sudo apt update and then my password, it starts with the “0% Working” and Err messages. How do I get to the next line? Wait for it to finish?

@Jules Start with the commands above first.

Ok, I did sudo nano /etc/resolv.conf and it’s on a window that is green writing, says GNU Nano 4.8 at the top.
There is nameserver under the green. But it will not let me delete it.

You’ll need to move the pointer manually via the arrow keys, as the mouse is only for selection.
Alternatively, you can hit CTRL+X to exit and process the file via:

sudo gedit /etc/resolv.conf

This will bring a graphic editor for it.

Ok, I used the arrows to remove the numbers and insert the info for the name servers, as well as the next steps and I’m back in the terminal again.

I did the sudo systemctl restart NetworkManager.service. Nothing happened so I did sudo apt update and all the same errors and failures appeared. Did I miss or skip something? I can’t see all the instructions on my phone while I’m typing a response.

For good measure I went ahead and did the rest of the steps, ended up back in the nameserver screen, entered the two nameservers, but get an error saying “Error writing /etc/resolvconf/resolv.conf.d/head: No such file or directory.

Did sudo apt update again and this time did not get all of the errors/failures. Holy cow I was able to sign into my proton vpn and now Brave browser is working! Hallelujah! :partying_face: Should I restart the system now?? Do you know what happened to cause that? I’m worried about reinstalling Kodi since it happened a few hours after that :woman_shrugging:t2:


When you alter the resolv.conf file, it temporarily allows you to resolve the issue - even though sometimes the DNS cache may take a while to kick in. However, you will need all the rest to ensure things are working after you reboot, starting from:

sudo apt install resolvconf

And then doing the rest from:

sudo systemctl start resolvconf.service

And adding the nameservers on the head file. Once that is done, then I believe you’ll be set!