Viber fails after App upgrade

I use Viber and am running Zorin on my MacbookAir. I also run Viber on my /e/ OS phone and the apps were synced and working as they should be. Everything was fine until the other day until I installed a Viber App update on my Zorin. Now Viber will not open. I tried a ‘remove’ and re-install from my App Manager. I tried deleting the Viber Downloads directory. I emptied trash and rebooted the laptop. Still nothing.
I then tried to do an install from terminal - $ flatpak install flathub com.viber.Viber
and it said it was already installed.
I then tried to run it from terminal with - flatpak run com.viber.Viber
And received the following detail. Any suggestions (it still runs just fine on my phone)? Thanks

Qt: Session management error: None of the authentication protocols specified are supported
QApplication: invalid style override ‘adwaita’ passed, ignoring it.
Available styles: Windows, Fusion
sh: line 1: xdg-mime: command not found

GLImplementation: desktop
Surface Type: OpenGL
Surface Profile: NoProfile
Surface Version: 3.1
Using Default SG Backend: yes
Using Software Dynamic GL: no
Using Angle: no

Init Parameters:

  • allow-loopback-in-peer-connection
  • application-name ViberPC
  • autoplay-policy no-user-gesture-required
  • browser-subprocess-path /app/extra/viber/libexec/QtWebEngineProcess
  • disable-features DnsOverHttpsUpgrade,ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture,AudioServiceOutOfProcess
  • disable-setuid-sandbox
  • disable-speech-api
  • enable-features NetworkServiceInProcess,TracingServiceInProcess,NetworkServiceInProcess
  • enable-threaded-compositing
  • enable-usermedia-screen-capture
  • in-process-gpu
  • use-gl desktop

[2:23:0813/] Could not bind NETLINK socket: Address already in use (98)
QQmlApplicationEngine failed to load component
qrc:/Resources/QML/MainWindow.qml: module “adwaita” is not installed
qt.core.qobject.connect: QObject::connect(QWindow, ApplicationEngine): invalid nullptr parameter