Updated Ubuntu and Wifi Adapter isn't working right

I upgraded to Ubuntu Jelly Fish. I’m using the TP-Link TL-WN725N. I can see available wifi but it won’t connect. Been researching for two days. I’m assuming I need to update drivers? I connected the ethernet cable to get internet but have not been able to figure out how to update to get it to work.

Any ideas? Thank you

There is a post regarding wifi issues after upgrading Ubuntu here:

Hopefully that helps

1 Like

Thank you! This is the fix that resolved the problem.

Because there is a bug in kernel 5.15 as mentioned by @lain haslam, you can use an older version of the kernel by holding the SHIFT button while booting to enter GRUB then go to Advanced options for ubuntu then you can use ubuntu with an older kernel

From My Experience I have downgraded the kernel [from ]5.15 [ to ]5.13 and it works

1 Like

It was only a temporary fix - wifi isn’t working again, and I am at a complete loss on what to do now. I can’t roll back to 5.13. I even installed 5.17 to see if that would fix it. Any ideas??

Hey @patpsalm4610!

I found an alternative that might work for you, but it will require a few steps in the terminal. It would appear that your WiFi adapter uses a Realtek chip, so once we install a module for it, chances are it will work better.

Open up a terminal and begin the execution, one line at a time (press enter at the end of each)

sudo apt update && sudo apt update -y

This will make sure that you have no underlying updates that might cause a version mismatch. If you see a linux in the update process, make sure you reboot first and then re-open the terminal to continue. If there’s no linux file update (kernel), then there’s no need to reboot.

sudo apt install linux-headers-$(uname -r)
sudo apt install bc git build-essential libelf-dev dkms
sudo rmmod r8188eu.ko
sudo echo 'blacklist r8188eu'|sudo tee -a '/etc/modprobe.d/realtek.conf'

This will install the necessary prerequisites to allow you to compile your module (AKA driver). It also removes and blacklists the current, old one.

Once you reboot, open up the terminal again so that we can move forward with the installation of the new one.

cd ~/Downloads
git clone https://github.com/aircrack-ng/rtl8188eus.git
cd rtl8188eus
sudo sh ./dkms-install.sh

Once the process is done, check to see if your WiFi is operational.

I ran the first command, updated all software, restarted the computer.

Ran successfuly:
sudo apt install linux-headers-$(uname -r)

Ran this one and got an error
sudo apt install bc git build-essential libelf-dev dkms

Restarted computer and tried each step again, and now I get this:
patti@patti-OptiPlex-390:~$ sudo rmmod r8188eu.ko
rmmod: ERROR: Module r8188eu is not currently loaded

Hey @patpsalm4610!
You can safely ignore the ones that do not install. The most essential to have are:

sudo apt install git build-essential dkms

The most likely reason is that those utilities and dependencies were either packaged in larger groups or they have evolved.
Thus, when you are running the sudo apt install command and you are getting errors, remove the parts that are causing those errors. Just make sure that git, build-essential, and dkms are installed. If there is another dependency that is needed, you will be informed of it during the compilation/build process. If you do get such a message, please let me know.

Last, but not least, the rmmod command not having the module loaded is a good thing.

Unfortunately, not seeing wifi. Still have to use ethernet cord.

Then it is likely the module is too new for the TP-Link model you are currently having. I also looked at the official website and they left their latest driver in beta back in 2018 (with up to a 4.xx kernel support).

Since it’s a USB, it’s easily replaceable. One of the following could prove useful:

Thank you!! Just ordered the adapter. I really appreciate all you do for this group, and the telegram group! I need to get back to the LMS and figure out how to set up the next cloud.

1 Like

Got the new Wifi Adapter yesterday, installed it and it is working! Thank you again :slight_smile: Will post a new question regarding the BIOS on my laptop soon.

1 Like

Congratulations @patpsalm4610 on a job well done! :slight_smile: