Update Telegram on Mint/Cinnamon

Onto a 2nd laptop, I just installed an old version (3.1.1) of Telegram. What is the Terminal syntax to update it? (The newer versions contain an update option from within the program. This one doesn’t have that.)

I tried

  • sudo apt update && sudo apt upgrade -y

with no success.

I also downloaded the .tar.xz file, but I read here on the Forum that the extracted program is only a script and won’t show up in the Menu list.

I prefer to avoid the Snap repositories.


Install Telegram from the PPA repository.
New updates will then be picked up by your update manager.
The link to install it can be found HERE
This will also add the repository to your PPA software sources.

Yes, thanks, that’s certainly easier and will provide a current version.

I’m wondering if there’s any other pathway to just update Telegram Desktop, outside of the PPA.

Can I ask you what version you have installed now?

Telegram: v3.1.1

Linux: Mint 20.3 Cinnamon.

version 4.2.4 is available in your Software manager.

Have you considered the browser version (direct login)? (that way is always the latest…)

I was using the FlatPak version and it was a bit funky (Ubuntu 22.04) so I switched to using Telegram in the browser (Brave), works much better.

Just an idea to keep in the the back of your mind in case you ever have trouble like I did…

Oooo, you had me all excited, there! I checked my Software Mgr and saw this:

Sigh… What am I missing???

Interesting, Ai. I’ll check it out. Definitely good to have a backup if we can’t figure out an easy update process.


Hey @Phobos and @Ai, look what I found at telegram DOT org:
TG update, flathub

Think I’d do well to uninstall the existing v3.1.1 then execute these Terminal commands?

Can’t mess it up any more than it already is, eh? :slight_smile:

1 Like

I installed telegram using the Flatpak package manager through Flathub.
That’s why my Software Manager was updated to the latest version.

I’m also running Mint 20.3 Cinnamon

Flatpak comes natively installed by default on your system.
Maybe you should consider using that method.

Right! Here’s what’s in flathub:
TG update, flathub2

By George, I think we’ve got it!

Thanks for your update. That provides me a nice comfort level for what to do next.

here is a link to the commands to install it. Its the 3rd option on that page

1 Like

It worked!

I uninstalled 3.1.1, then re-installed from Flathub.

Best regards,

Cool…All the best. :+1:

1 Like

Ok, here’s a new wrinkle.

I enabled 2 “hot corners”:

  1. “show desktop”
  2. “show all windows.”

Telegram (and all other open windows) on my primary laptop respond to both mouseovers.

Issue 1: Telegram on this 2nd laptop, does not respond to “show all windows.” The app just returns to its storage location on the panel…still active, just not open on the desktop. All other open windows respond to both corners.

Maybe I missed something, but I think that hot-corner settings are identical on both laptops.

Issue 2: TG on this 2nd laptop does not appear via CTRL+Tab (to cycle thru open windows).


  1. How can I get TG to reappear on the desktop when I mouse-over the “show all windows” hot corner?

  2. How can I get TG to appear via CTRL+Tab?

I have never used hot corners,
I simply toggle telegram and other apps running from my panel to bring it back to the desktop.

Yeah, I like, and use, the toggle process as well.
Unfortunately, TG also isn’t showing up there as an available app to which to toggle. It’s as if CTRL+Tab cannot see that the app is open.

Any guess as to why that might be??

It seems like you dont have your X App Status Applet enabled.
Set your mouse over your panel. right click and select applets.
Pan down the list in the Manage tab and enable your XApp Staus Applet.
If its not there click the Download tab and search down that list and download it.

You were right: the X App Status Applet was not enabled.

I enabled it, and just to be sure, rebooted. Then double-checked to be sure the X-Applet was still enabled. It is.

Result: The symptoms are the same. Neither Alt+Tab nor hot-corners/“Show all windows” recognize TG as being open.

Any other ideas?