Update error 403 in Linux Mint

When updating Linux Mint 20,2, I receive the updates Update Manager. I run those then check for any new updates with the Refresh button and receive the following error message:

Could not download all repository indexes

The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.

Failed to fetch http://ppa.launchpad.net/lutris-team/lutris/ubuntu/dists/focal/InRelease 403 Forbidden [IP: 185.125.190.52 80]The repository ‘http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal InRelease’ is not signed.

Looking for a fix, I went to the Lutris site and loaded the latest software to find it was already installed. Soooo. . . how do I resolve this issue?

I have the same issue…

Read the website linked below.
You will probably only need/want the first two commands mentioned in that website.
sudo apt-get update
and
sudo apt-get upgrade
The commands above are typed (or copy/paste) into a terminal window.
Compare the results of the first command to what is shown at the website. If all looks similar and well then proceed to the next command.
Post back here if you run into errors or if it works out for you that is nice to hear also.
If you get errors, screenshots or pictures posted here help in trouble shooting.

I had performed this task as described. I had read the article fully before. The process worked flawlessly and without issue. . . but it isn’t designed to fix the issue. I went into the Mint update manager once again and hit update. The same error code came up. Its not a software issue its a repository issue with lutris. There is a signature issue. If you hit that http website link above, you get a signature error to that website/IP address. Therefore it cannot get updates for that program. The program is used by Steam to operate games.

I was hoping to get an error in the terminal similar to the error in your original post. Sometimes the terminal gives more/better information.
I do not know my way around Linux Mint software manager.
Here is a link to possible solutions for your problem. Maybe one will work for you.

Found the way around this issue with Github as suggested in Freespoke thread. I know I have to manually run the updates on lutris until another ppa is created. I just want to get rid of this current one that goes to nowhere. Not sure the correct way to remove it.

About half way down the linked (below) page find:
Remove a PPA (GUI Method)
and hopefully those instructions will help you get rid of the broken ppa. It could also be done in a terminal if you wanted but I thought the GUI may make it easier for you to find the ‘correct’ ppa to delete.

Then you could continue to the
“Bonus Method: Use PPA Purge”
if you are comfortable in the terminal.

1 Like

OK, so this did work. The way I did it using the GUI method is efficient and quick in Mint 20. This is easy to perform, just follow the following steps.
Click on your Update Manager,
Find the Edit tab,
Select Software Sources,
enter passcode,
On left menu, select PPA
Find lutris PPA with the Enable tab checked,
highlight it and click on it,
buttons on the bottom will highlight,
click on REMOVE button,
It will want you to update the repository,
Click yes,
On left menu, select Maintenance,
Click, Fix Merge List Problems,
A message will appear: The problem was fixed. Please reload cache.
Click OK,
A new message will appear: Your configuration changed. Click OK to update your APT cache.
Click OK,
If no errors appear, you selected the right PPA and your issue is resolved. If not, you will have to select another Lutris PPA from your list. (this can be used for any PPA, just in this issue it was my Lutris update that was the issue.
If all is well continue with the next button on the maintenance tab: Purge residual configuration,
click OK when it is complete,
Click the next button on the maintenance tab: Remove duplicate entries,
click OK when it is complete.
These last three steps I do every time I do a update. This keeps the cache clean and neat without wasting your hard drive space and prevents any residual software issues when completing new updates further down the line. ( just good house keeping!)

Thanks Dennis for the help. I was searching for the correct way to remove and the last tutorial was just what I needed to be certain that I was correct in my assumptions.

I hope this works for you Ray, try it out.

Ray, problem solved, look on this thread to my last reply to dennis. follow the steps. should work fine.

Thank you Paul. All is fantastic now…