Uninstalling Plasma from Linux Mint 20

I’d like to uninstall the Plasma desktop manager from Linux Mint. It’s just way more than I need. What do I need to know? I’ve read that sometimes it’s hard to get rid of everything.


Hey @Gr82blanda!
You read correctly. At times it is indeed hard to clear up everything, as Desktop Environments come with loads of packages. Keep in mind that the following command might cause some thing to break if you have KDE-based apps that you may use. I’d recommend backing up any personal files you may have before you give this a shot.

To uninstall, make sure you’re logged into your Cinnamon desktop environment. If you’re using the original login manager as you had when you first installed Linux, the option to enter Cinnamon is on the top-right corner of your password window. If you’re using the KDE login, then the icon or list should be either on the top side or the bottom.

Once inside Cinnamon, open up a terminal window and type in:

sudo apt purge '^kde' '^kubuntu' '^plasma'

To make sure that you will still be able to login, once the above process completes, execute the following:

sudo apt purge sddm
sudo systemctl enable lightdm

If the first command (sddm) produces an error, ignore it as SDDM (KDE Login Manager) wasn’t installed. However, don’t ignore any error on the LIGHTDM command. If you see an error that there’s no such service, execute:

sudo apt install lightdm
sudo systemctl enable lightdm

Please let me know how it goes. :slight_smile:

1 Like

Hi Vasileios, I’m back with more questions. This one is on kwallet. I distro hopped to Kubuntu and love the plasma desktop with the exception of kwallet. That thing is bugging me and I can’t find a way to disable it on the forums. Seems all of the suggestions on the forums are out of date and none are working. Any suggestions?

Hey @Mike19!
You might want to install Sea Horse, which manages the wallets and password containers.

sudo apt install seahorse

Once you run it, you can select to delete or create new containers.

Alternatively - you can:
To disable the KDE wallet:

  1. Go to the KDE menu.
  2. Type wallet, this will show KWalletManager.
  3. Goto settings.
  4. Uncheck "kwallet system active".

This will disable the kwallet subsystem

Thanks Vasileios, I can’t find a KDE Menu on my system and it doesn’t show up when I search for it. That may be part of the problem. Also when I try to install seahorse, I get a grey page with two keys and a bunch of little numbers in squares.

I’ve seen that behavior before when I tried installing other apps.
Thanks for you help.

Hey, @Mike19!

The issue with the squares is because of the font your system uses for the GTK applications. This can be resolved by changing them in the configuration environment. In terminal, we can change it via:

gsettings set org.gnome.desktop.interface monospace-font-name 'Monospace 11'
gsettings set org.gnome.desktop.interface document-font-name 'Sans 11'
gsettings set org.gnome.desktop.interface font-name 'Sans 11'

Per the KDE Wallet, if you cannot find it in the settings, you can run it as an application. Below I’m including its screenshot from the Debian KDE.

In the Settings, you can search it as wallet and it will pop like the screenshot below:

If it still doesn’t exist in your system, you can install it via:

sudo apt install kwalletmanager

Thanks Vasileios, It wasn’t on my system for some reason. I had to install it and then disable it. Hopefully it’s gone for good now. I removed and reinstalled seahorse after making your suggested changes to the fonts and it still comes up with little blocks and numbers. I can’t find those fonts listed in my system so I’m suspicious of this kubuntu distro. It flagged an error right at the end of the process of making a bootable usb stick with balena etcher. I did it three times and got the same result. The md5sum check was good as was the sha256sum check, so I went ahead and installed it. I downloaded it from the official kubuntu website, but it could be that I’m missing pieces of the distro. If I understood you correctly in one of the LMS sessions, I can just save my home folder to an external drive and reinstall the distro without loosing my settings. Is that correct?
Thanks again.

Hey @Mike19!
Yes, you can copy all the contents of your /home/old_username/ contents (make sure you hit the CTRL+H keys to reveal the hidden folders that contain your settings) and then copy them back to your /home/new_username/ on your new Linux installation.

However, for those to go fully into effect, you’ll need to have the same desktop environment.

Before you do that, test the following:
Open up your settings and search for GTK on the top left and enter the option it will give you. It should look like the one below:

From there, you can change the GTK font and hopefully, this will solve your issue.

Thanks Vasileios, here’s what I get when I type gtk in system settings:

I’m using Kubuntu, so maybe that’s the difference. I think I did solve the problem by changing the fonts anyway. I was using Century Schoolbook before and believe that it is a true type font. When I switched to C059 the font started showing up in all of the gtk apps. So we’re good!! Thanks again.

1 Like

Hey @Mike19!
I’m glad you got to solve it!
By the way, the screenshots I posted were from my Ubuntu Studio 21.10, which runs under KDE and identifies itself as Kubuntu. So, I find it curious that you don’t have the GTK settings. Perhaps it is a new panel they implemented on the new KDE (21.10 uses a newer version than 20.04).

Perhaps this can be resolved further if you can find the kde-gtk-config via the apt command or the synaptic package manager. You can install the latter (to make your searches easier) via:

sudo apt install synaptic

And then look for kde-gtk-config. :slight_smile:

I’m sorry I’m a little slow with the learning curve. I had to take a few days off the LMS and try to learn more about the terminal command line and man pages. I still don’t understand it all, but I know I’m further down the road than I was. Now I’m stuck trying to figure out the difference between a server and a network; a switch and a router, and whether or not I need any of those things to set up a vps, vpn, and firewall. I like the idea of setting up a virtual box and putting windows in it, but unfortunately, it’s all kind of running together.
Back to the baby steps. I successfully installed synaptic, but don’t know where to look for the kde-gtk-config file. That must be one of the things I still need to learn for the terminal command; e.g. how to do searches. I know how to do cd and ls to look at the files in a directory, but not a recursive search to look everywhere for something I need like the gtk-config file. Thanks again for your help. Keep up the good work. Some of us may take longer, but we’ll get there sooner or later.

1 Like

Thanks Vasileios, I was one LMS session short of answering my question. Your video was just what I was looking for.

1 Like

Hey @Mike19!
No need to worry! Baby steps is the best way to go. Especially in environments where too much information gathers up. And it tends to gather indeed. You are doing great!

Per the router and the network switch, since I have a bit of time, I will explain them to you.

The router is what connects your home or your business to the Internet. Thankfully, the modern routers have extra ethernet ports (they connect to - what are known - UTP cables). When you connect a system via an ethernet cable, it acts like a super fast WiFi, without the wireless waves (and any airwave conflicts) and grants you access to the local network as well. The only inconvenience with an ethernet cable is… well, the cable. However, the response speed is phenomenal.

For example, when you copy a large file over WiFi, the average speed you will get is 11-12MB per second, with a maximum of 21-25MB per second in near ideal situations. An ethernet connection will give you between 45MB per second, all the way to 100MB per second. That’s for a 1Gbps ethernet network. In a 10Gbps ethernet network (which most routers don’t support), you can get up to 1,000MB per second.

Here is where the network switch comes in handy. At my place, I have two of them. One 16-port for my office and one 8-port for the dining room. Yes, I tend to bring a laptop or two to the dining room and work with big files while around the family, so that I don’t miss my daughter growing up. :slight_smile:

The network switch acts like a router, but it does not provide Internet access, only LAN (Local Access Network). Most switches have 1Gbps bandwidth, which is true for every ethernet port. In the long years past, there was also the network hub, which had a 1Gbps (or less, like 100Mbps) as a collective speed. This meant that the full bandwidth was the cummulative speed of all connections. So, if two computers would copy files at the same time over a 1Gbps hub, each would achieve up to 500Mbps bandwidth. On a switch, both computers can achieve up to 1Gbps per system.

The major difference with a network switch is when you have two systems connected to it, even when the switch itself is connected to the router. The switch will establish a connection between the two computers by completely bypassing the router. This means that if your switch is 10Gbps (and your computers have fast enough drives), you can copy files between them at up to 1,000MB per second, avoiding the 1Gbps limitation of the router.

Additionally, when you connect a network switch to the router directly, all computers that are connected to that switch gain Internet access as if directly connected to the router themselves. This means that it doesn’t matter if your router has 4 ethernet ports. If you connect one of those ports to a 16-port switch and then connect 15 computers to that switch, all of them will have Internet access via the router’s one port.

To set up a VPS that is on the Internet, all you need is the router to have access to the web and that’s it. The rest is for speed purposes in your local environment. Personally, I prefer having a network switch or more around, especially when I can hide the cables. Having a desktop hardwired to such a switch offers magnificent speeds. This is very handy if you work with large projects or files.

OK, got my new router ordered and have switched my desktop over to an ethernet cable. Speeds are great except my isp is Viasat and the latency is running around 650ms, so that still causes some lagging. Also got a VPS set up on Linode and got to the point in hardening the server with nano. I’m following you on LMS Session 24 and at around 14 minutes, you do a control O and control x to save and exit nano. When I do a control O, it switches me back to my home computer and tries to save the file there. Then I get a message on the nano editor that says "File Name to Write: sshd_config and it appears to be locked up at that point. When I close the editor, it kicks me out of the server and back to my home computer. I can log back in, but when I check the sshd_config file, no changes have been made. I’m kinda stuck there…
Any suggestions would be greatly appreciated.

Hey @Mike19!
This is odd. When you’re logged via SSH, it should keep you on your VPS. My guess is that something is happening to your router and the SSH connection drops. Otherwise, there shouldn’t be an issue of returning to your local system.
How about you login to your router and disable IPv6? That protocol is the usual suspect for dropped connections.

My router is scheduled for delivery next Monday. Right now, I have my ethernet cable plugged directly into the Viasat modem. I don’t have a clue how to get into that and disable IPv6. Could it be the excessive ping times that I’m experiencing on Viasat?
Here is a screen shot of my vps terminal; it seems to have locked up when I tried to save and exit. I’ve gone through this three times with the same result each time. Also logging back on the VPS requires me to enter my pass phrase three times before asking me for the password. Thanks for your help.

Hey @Mike19!
You don’t have to disable IPv6 on the VPS. You can only do that on your router. By default, your VPS does not get a public IPv6 address.

Normally, your router should have a label on it with the address, admin username, and password. All you need is to use a browser and input the router’s IP address. From there on, you can find IPv6 under the Internet connectivity. :slight_smile: