Unable to connect to internet

Thanks for replying @vasileios!

I see that I have it (running Ubuntu 20.04.3 LTS), but I don’t know how to find out if it is running. In prior work, I have done some unix/linux, but not administratively.

Anyway, I tried:
ps -ef | grep protonvpn

and it returned a couple lines that include “MM.Client.new(None)” and it also seems to have launched protonvpn but it is not connecting. Just in some endless loop.

Just to let you know, I need to be away from my computer for a bit and I won’t have internet access for much of tomorrow.

Thanks again!

1 Like

You’re welcome @o2b!
By the way, check your connecting devices to see if you have a persistent ipv6 link up.

ip link

If there is one, send it packing by adding sudo in the beginning of the above command and delete after it, including the actual name of the device you’re looking to delete.

1 Like

Finally able to return to some linux use.

Yes, the command returned the 4th and last line containing ipv6leakintrf0. So, I did:

$ sudo ip link delete ipv6leakintrf0

And I verified that it is indeed deleted.

Thanks, @vasileios!

When you have the time, looking forward to my next step.

1 Like

You’re very welcome, and good job @o2b!
Once you delete the ipv6leakinrf0 connection, your internet should be back to being fully operational.

In the future, I would recommend you disconnect from the ProtonVPN when you’re about to reboot or shutdown. if you encounter a loss of connectivity again, always look at the ip link to see if the ipv6leak has returned.

I usually run ProtonVPN via CLI, as it’s much faster than the GUI:

protonvpn-cli c -f

This connects me to the fastest server.

To disconnect, I execute:

protonvpn-cli d


1 Like

Thanks again!

While I see that I have ProtonVPN, I am unsure if it was ever running. I tend to think it was not.

Right after deleting the ipv6leakinrf0 connection, I tried pinging to a website and it returned “Temporary failure in name resolution.” So, I figured I still lacked internet connectivity.

After reading your latest and greatest post, I figured I’d go ahead and see about connecting with my web browser and it failed for the same reason:

This site can’t be reached
DNS address could not be found. Diagnosing the problem.

Then I redid ip link

It returned 4 lines, but there is no Line 4. Line 5 contains ipv6leakinrf0 so it got added back again.

1 Like

You’re very welcome!
In the scenario it pops up again, delete the ipv6leak again and then reboot. Once you log back in, run a test to see if you have internet back.

1 Like

Still have the problem. Also cannot ping to a site for the same reason.

Just thought to try ip link and that same connection is back.

Would love to understand better. Such as what is this connection for? What is it that keeps adding it back? Why does its presence cause connectivity to not work?

I am starting to think that this could be a probable ProtonVPN bug. It happened to me after their latest update on Mint. However, after deleting it, things got back to normal.

Here’s a thought, once you do the sudo ip link delete command, perform a:

protonvpn-cli d

And then reboot. Once you log back in, check to see if your connectivity is up again.

The ipv6leakintrf0 is a connection tunnel ProtonVPN creates to avoid your DNS leaking via the IPv6 protocol. I personally advise (and do it myself) people to disable their IPv6 on they connection, including the router. The protocol is meant to expand the number of addresses on the Internet, but it is still buggy on the connectivity aspect. And yes, it can unfortunately affect the IPv4 too.

1 Like

All set!

Thank you @vasileios!

1 Like

Bravo @o2b on a job well done! :smiley: