Unable to connect to internet

Using purchased CD with Mint latest version I installed on desktop computer as dual boot. And on other device (laptop) using purchased USB Ubuntu latest version and not installing on my other laptop in both instances I could not connect to internet. And even without installing Ubuntu and just working from USB, it altered wifi connection and disabled it even when I tried to go back to using windows. I was able to get wifi working on windows again by tuning off router and back on again. But no luck connecting to either Mint or Ubuntu. HELP!!!


Hello @jsuzanne!
My first thought is that your systems could use an update before we go into the deeper analysis. Do you happen to have an Ethernet cable to connect your computers directly to the router? Usually, that can solve the WiFi problem. If not, then we will need to do a few diagnostic steps to see what is missing. :blush:

1 Like

I can do that with my laptop. My desktop computer is too far from the router. But I will find an ethernet ord and start with the laptop. Thank you.

1 Like

Great! Please let me know of the outcome. :blush:

I have a similar problem. Installed Linux Mint Uma, I think Cinamon. The OS installed on the Dell laptop but the touchpad is all that works and won’t open anything. So, connected manually to router, still not able to access the internet. Even if I did, not sure where to go for any drivers.

Hello @Hal!

Can you go to your Network Settings and post a photo (from your phone) while in there?
Perhaps this is something we can resolve quickly. :blush:
However, even if it’s troublesome, we’ll get to the bottom of it.

Over the weekend I successfully installed Ubuntu Budgie on our 2012 MacBookPro. This machine was being used for photo storage because it stopped wanting to provide internet for us back in 2017. It recognizes our home wifi, gets a strong signal, but won’t connect to the internet. I’m using it to get familiar with Budgie, but I’m wondering how to revisit the internet problem now with Linux? Pardon my ignorance, but what would I do to explore/fix the issue? Is it even possible? Or maybe this will just be the machine I practice with distros on, haha! Thanks for any guidance…

Hello @JK and welcome to the forums!
The moment you’re able to see your home network, there could be a Domain Name resolution issue.
Can you open up a terminal and type in:

ping -c 3 google.com

That’s just to bug Google, but if your DNS works correctly, you’ll get a good result via the 3 attempts at contact. If not, you’ll get a short error.
Please let me know what pops up. :slight_smile:

Vasileios, you lost me at “open up a terminal,” haha! I plead ignorance, but I’m willing to learn. You can probably guess that by using a Mac, I’m used to the magic just happening, and when it doesn’t, I go talk to a “genius” at the Apple Store. I’m in new territory here, trying to be my own genius. So, looking at the yet-unfamiliar Budgie desktop (still exploring all the new labels and icons), I first need to find my wifi icon? I don’t even see that.

1 Like

I hear you there!
Just press your “Windows” or “Command” key to bring up the menu/search. Start typing “Terminal” and the icon should pop up. Make sure you add it to your favorites, as it will save you quite a few times!

On Budgie, your WiFi icon or properties should be on the top right. Sometimes, it can be hidden under a wider menu, much like your Mac’s Control Panel. :wink:

so…did a little search, figured it out. I entered the text you suggested and it now says: temporary failure in name resolution

I see my bluetooth icon, but no wifi icon hiding anywhere

aha…I see three little dots that take me to network settings. the wifi section tells me that no wifi adapter is found. Our home wifi is working for all other devices in the home.

There you go! Essentially, it doesn’t recognize your WiFi device. Or to phrase it better, it does, but it doesn’t have the correct firmware. I think I may know what your issue is.

However, I’ll need you to do one thing for me.
Use that tip about opening the terminal. Open it up, maximize the window and type:


Please take a picture for me and post it here. I’ll need to especially see your Broadcom model.

Just as I suspected. Please forgive my delay. I was up - again - late at night, and today I had to reset my own Surface Laptop 3 WiFi firmware!

Okay, I wrote down a script for you and extracted the initial Broadcom firmware files that worked - from the actual installation medium.

I’ll need you to do the following:

  1. Create a folder in your Documents area named broadcom_firmware
  2. Enter that folder, right click in the empty space and select “Open in Terminal”

If you don’t have that option through your file manager (you should), open up a terminal and type:

cd ~/Documents
mkdir broadcom_firmware
cd broadcom_firmware

Now, download the following two files inside that new folder:
restore_broadcom.sh (380 Bytes)
broadcom_firmware.tar.xz (4.5 MB)

Return to your terminal window that is inside the broadcom_firmware folder and type:

ls -l

If the file restore_broadcom.sh is colored green, then type:


Insert your password and the restoration process will take an instant. It will also backup the former files.

If the restore_broadcom.sh is white, then type:

sudo chmod +x ./restore_broadcom.sh

Reboot your system and check your WiFi. :slight_smile:

Vasileios, you have the patience of a saint! I’m also doing life in between learning Linux. I followed your instructions and all really seemed to go just fine along the way, but I still do not even have a wifi icon that recognizes any surrounding wifi for me to join. I opened the terminal in the new folder, downloaded (via USB) the two files, followed the prompts you gave, saw a white restore_broadcom.sh, entered the response, rebooted. No wifi. When I go to settings, and select wifi, it tells me “No WiFi Adapter Found” and to make sure I have a wifi adapter plugged and turned on. Our home wifi is humming along fine. Could it be that the laptop running my Budgie install just has an issue that is beyond this? It would be awesome to figure out, but I’m also okay with accepting that the flawed laptop will just be my practice machine. I’ve been playing with LibreOffice today for example.

It would appear that Broadcom is indeed worthy of its infamy!
Let’s try the following:

sudo apt install b43-fwcutter firmware-b43-installer
sudo dpkg-reconfigure firmware-b43-installer

Keep in mind that I don’t have a relevant system to try it on, so this is a guesswork from what I could detect. The second command above is to configure the firmware, so I am not familiar with the questions it will ask.
However, it’s supposed to support your BCM4331 Wireless adapter.

Please let me know if that is of any help. :slight_smile:

Hmmm, so after doing the above, it tells me that reconfigure must be run as root.

That can be easily solved by typing:

sudo su

That will give you full privileges. Though you might want to type:


Once you’re done - so that you don’t accidentally do something nasty!