Ubuntu upgrade on home server problems

To start, I know enough to probably be dangerous so bare with me.
My home Ubuntu server seems to be a little flaky ever since running the ‘jammy’ upgrade of Ubuntu. I just tried a terminal apt update and upgrade and it seems to not complete. I never saw this response before. Any feedback is appreciated.
Here is my terminal output:
61 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
ron@server:~$ sudo apt upgrade
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
bluedevil breeze breeze-cursor-theme drkonqi gjs gnome-remote-desktop
kde-config-sddm kde-config-updates kde-style-breeze kde-style-oxygen-qt5
kinfocenter kscreen ksystemstats kwin-common kwin-data kwin-style-breeze
kwin-x11 layer-shell-qt libapache2-mod-php7.4 libapache2-mod-php8.1
libcolorcorrect5 libgjs0g libkf5sysguard-data libkfontinst5 libkfontinstui5
libksgrd9 libksysguardformatter1 libksysguardsensorfaces1
libksysguardsensors1 libksysguardsystemstats1 libkwaylandserver5
libkwineffects13 libkwinglutils13 libkwinxrenderutils13 libkworkspace5-5
liblayershellqtinterface5 libnotificationmanager1 liboxygenstyle5-5
liboxygenstyleconfig5-5 libplasma-geolocation-interface5 libprocesscore9
libprocessui9 libtaskmanager6 libweather-ion7 milou oxygen-sounds php8.1-cli
php8.1-common php8.1-mysql php8.1-opcache php8.1-readline plasma-desktop
plasma-desktop-data plasma-discover plasma-discover-backend-fwupd
plasma-discover-backend-snap plasma-discover-common plasma-pa
plasma-workspace qml-module-org-kde-ksysguard systemsettings
0 upgraded, 0 newly installed, 0 to remove and 61 not upgraded.

First have you rebooted this system recently?
Sometimes system updates require restarts to complete certain package update, annoying yes, but this may just be holding all new updates back too.
Try the reboot and then try to update and go from there.

I rebooted and then I ran sudo apt-get install <packagename(s)> and more packages loaded. I then did it again with what was left and it loaded more. After running this about 4 times all packages loaded. Everything seems as it should now but I am still at a loss as to why.

1 Like

Maybe some system packages that required restart. Ubuntu used to tell you is a system restart was required.