Ubuntu Laptop Not Connecting to TV's


I have Ubuntu 20.04.3 LTE installed on a Dell Latitude E6420 laptop. I very much want to be able to connect it to my TV’s with an HDM1 to HDM1 cable which I have verified works. I have two TV’s, one a Roku smart TV, the other not a smart TV.

Neither TV recognizes my laptop. It says “No Signal.” I successfully have other devices connected to each TV.

Just wondering how to troubleshoot getting my Ubuntu to have its signal recognized by my TV’s.

Thanks in advance!

Your laptop should have a hard " FN + F#" key combo such as F7(on my Lenovo) that when connected will activate the secondary monitor, then it should be nothing more then opening up “Displays” under system settings and configuring it.

you can run something such as dmesg from a terminal prior to connecting it and then again after connecting it to see if there is any system messages notifying you it was connected and what was recognized. I used an Ubuntu 18/then 20 laptop for a media center for a little while unitl I got a few Pi’s.

1 Like

Thank you.

Still didn’t work but it also does not work with my Macbook and it used to work with it.

Trying to connect with the same cable? Same port on TV? Try another?

1 Like

I verified the cable is good. I also cannot get my Macbook to connect to either TV unless I use Apple AirPlay and then I can connect to the TV that is a SmartTV.

I used to be able to just plug the Mac into either TV and it connected fine. Now, just as with the Linux laptop, just doesn’t see a signal.

Sorry to say I have no experience with smart TV connections.

Possibly the TVs port has gone bad? Dirty or compacted dirt like a cell phone USB charge port?

Try a flashlight and toothpick to clean it out, maybe a lil rubbing alcohol after any excess gunk is removed, allow to dry and try again. The fact that both will not connect and a known good cable point to TV issue.

1 Like

Nah, it’s not that.

I’ve tried both my TV’s with both computers. Using connections and cables validated to work. One TV is a Roku smart TV, the other is an older TV (Samsung). I got the MacBook to connect to the Smart TV using something called Airplay.

This is the first time I tried my Linux laptop. But the Mac used to automatically be connected to both TV’s. Just plug it in and all set. Now, with both computers on both TV’s, the TV’s say no signal. But like I said, with Airplay the Mac connects.

Oh well…

Since i don’t have a Mac, I would guess air play uses your local lan to work with a smart tv.

But with both not working on a direct connecting is odd.

Check that both the Linux laptop and Mac(while plugged in) in their display decrying of setting are setup to use dual monitor, either mirrored or as an extended desktop.

1 Like

Unable to do so until Friday, but looking forward to trying - thanks!

1 Like