Ubuntu 20.04 on Raspberry Pi 400

Hi gang. I got a Raspberry Pi 400 a couple weeks ago to dip my toe in the Linux water and have had an interesting time with it. But a few nagging problems I couldn’t resolve by searching Linux forums prompted me to decide to reinstall the Raspberry o/s. In the process, I discovered I could install other versions of Linux instead, including Ubuntu, so I took the plunge and successfully installed Ubuntu 20.04 on the little Pi. At the same time, I successfully installed Mint Cinnamon onto a Dell Latitude laptop, so I now have a couple different Linux flavors to play with as I plan my full and final exodus from the Mac ecosystem.

My question is this: I successfully installed both Signal and Brave onto the laptop running Mint, along with other apps - no issues. On the Pi 400, Ubuntu has an extension software library I used to add various apps, all without issue, but couldn’t find either Signal or Brave. So I used the terminal to attempt to install both, using a couple different methods found on the internet (starting with the companies’ websites) to do so. Both returned the same error at the very end of the install process, after the terminal reported that every preceding step executed without error. The message I got for both was that the program in question could not be found.

On further investigation, I think the issue is that the Pi 400 - not having been intended as a main desktop-type system - has an ARM 64bit processor, and those 2 applications require an AMD 64bit processor to run under Ubuntu.

Can anyone confirm if this is indeed the case?


I ran into this same roadblock trying to install Brave on my Pi4 with Ubuntu. Doesn’t work with ARM.

1 Like

What I suspected. Thanks!

Hey @zudenon!
Yes, I can confirm it. Anything that has to do with Raspberry Pi, you will have to look for the ARM version. Just as your Ubuntu is ARM version, you’ll have to make sure that the applications are of the same too.

If you cannot find an app for your system, but you have access to the source code, then you can compile it directly. Just make sure you type - in terminal:

sudo apt install build-essential

So that you have the key compilers and components. If any other application (especially on GitHub) requires anything further, it will let you know in its README.md file. :slight_smile:

1 Like

@zudenon I would love to know how you are getting on with Ubuntu on your Pi 400? I have just switched from Raspbian to Ubuntu, but my Pi freezes a lot. Did you have any of those issues? Are you happy with Ubuntu on it and if so, what adjustments did you make to get it to work nicely?

I saw this happening to many people. The remedy for that was a system update:

sudo apt update && sudo apt upgrade -y

I hope this helps you out!

1 Like

Awesome! I will try that next :+1: Thank youuuu!

1 Like

My pleasure @Tinsche! :slight_smile:

I really like running Ubuntu on the Pi 400. While the Pi is noticeably slower loading webpages than my other Linux computers, it nonetheless does a great job with general use items, like email, Telegram etc. I haven’t had the freezing issue you mentioned, probably because I stumbled into the sudo apt update && sudo apt upgrade -y command Vasileios mentioned when I was first loading it onto the Pi, so I think I dodged a bullet.

I now have Ubuntu loaded onto a 2014 Macbook Pro in a partition, so I can continue running MacOs at the same time. Ubuntu is super fast on that system. I also have Mint Cinnamon installed on a 2017 Dell Latitude laptop, and it’s super fast too.

That about taps out my meager knowledge at this point. I just keep playing with options to see what seems to work the best. Anything short of frying the drive I consider a win :slight_smile:


@vasileios Thank you so much for your help so far! I have finally tried to put this command into my terminal, but then it shows me this:
[sudo] password for tina:
I assumed that I might have to type my password now, but it doesn’t let me type anything in the terminal. I feel stuck :woman_shrugging:t3:

Ah, yes! When it asks for your password, you can type it normally and press enter when done. This is a security measure so that nobody can see the length of your password. No worries, it’s not stuck. :wink:

Thank you @vasileios ! I finally manged to try again and this time it worked!! Yay!
All the updates and upgrades went through and it is definitely better. I like ubuntu 21.10 much better than Raspbian, but it still freezes quite often. I don’t do anything in particular or heavy, I just had a look at Applications at the bottom left and looked at one at a time, starting with utilities. I never had more than one open at a time. So, considering that others seem to be quite happily using ubuntu on their Raspberry, I don’t know what I m doing wrong, or what is different with my set up. If it is pointless to keep trying, just let me know, then I will go back to Raspbian.

I’m glad you went through @Tinsche!
Ubuntu by itself operates on a rather loaded Desktop Environment, known as Gnome. This can have quite a few processes running in the background, though nothing to actually force your system to freeze. Not by a long shot. This makes me think that there might be a few incompatibilities that are being ironed out.

You have several options from here. One would be to install Budgie, which is based on Gnome but is lighter - or jump to a different Desktop Environment flavor of Ubuntu.

First, give Budgie a test. You can open up a terminal and type in:

sudo apt install --install-recommends ubuntu-budgie-desktop

It will take a little bit. Once it asks you for the login greeter, choose lightdm (from the current gdm). When it finishes, reboot your system and you will be on your way to your new environment!

Thanks for this advice @vasileios :blush:
I have now done that and even though it seems somewhat better, it still freezes.
I just tried playing a video within the telegram app, but after a few second the image froze, the sound continued for a little but longer, then also stopped and my cursor disappeared. Frozen again :confused:
I have nothing else open in the background.

Are you using Telegram from the software manager (or the apt version)?

From the software manager

Ah, that’s an older version then, which tends to create a few problems - since the majority of Telegram users utilize the latest. This is common with apps on the software manager. The reason is that it takes some time for them to become fully vetted in terms of stability - mainly.

You might want to go to the Terminal and apply the following commands:

sudo apt purge telegram-desktop
sudo snap install telegram-desktop

This will install the SNAP version of Telegram, which is always the latest. :slight_smile:

Thank you @vasileios
I have done that. The good news is, that it hasn’t frozen completely… speaking of the devil… it now has… sorry :grimacing: Should I give up?

I would say “never give up!” And I do mean it. :slight_smile:
I had a quick search of the issue and it appears to be one of the following two:

  • Most likely is an issue with the poorly tested video drivers, which has been filed as a bug and is expected to be resolved - hopefully soon.
  • Less likely (though a possibility) could be an SD card issue - and I’ve known well that some storage issues can cause a freeze on the system (Telegram does a lot of downloading, especially for videos).

Since there’s not much you can do on the bug side, you could grab an additional, ultra-fast SD card and install Ubuntu on it (to use it as your main) and see how that goes. I’ve been thinking of getting out and grabbing a Raspberry Pi 4 myself, but it takes ages to come to my area. So, I end up losing my motivation! That’s also because I’m saving for some serious workstation level hardware. :smiley:

Thank you for your patience and encouragement @vasileios :+1:
Before getting a new SD card. Firstly, is it true that I shouldn‘t go higher than 32GB on the Pi? Secondly, any suggestions what would be a good one? The one I have is a Samsung Evo Plus 32GB.