Tutorial: Install POP!_OS in an external USB drive

Ladies and gentlemen,

Early this morning, after a rather long night and 2.5 hours of sleep, I gave one member of our chat (and hopefully our forum - if not our class) the promise that I would make a video explaining how to install POP!_OS on an external hard drive.

Granted, I used a desktop, but this is doable on a laptop as well. This method secures that the SSD does not receive the bad Windows 10 Boot mojo (whenever it decides to update), and the Linux boot loader remains intact. However, you will need to activate your BIOS boot manager whenever you want to enter the POP!_OS.

However, if your main drive is another Linux, like Ubuntu or Mint, etc., the next time you or an update engages a –

sudo update-grub

– command with the external USB connected, the dormant Linux will discover the POP_OS! and include it in its own boot loader.

Enjoy!

1 Like

BitChute blocked the video for “Other Platform Misuse”. Maybe put it on Rumble?

Seems we’re getting censored for simple stuff even there. I filed an appeal to know what it is they mean.
Meanwhile, I’m trying to place the videos on Odysee.

2 Likes

Good video. I’ve not been able to install PoP on anything yet. It seems the system goes to sleep just as it finishes the file loading. Nothing I’ve found yet will wake it up. Tried several computers with the same result. Tried downloading another iso and different methods to setup on the usb drives. Even tried different drives. I’ll try your “remove all drives” method. Thanks for all the awesome input.

1 Like

You’re very welcome!
I find it funny as I mentioned “as you fall asleep” inside the video. I didn’t mean for the computer to fall asleep!
Also, moving your mouse/pointer around will keep your computer awake. :wink:

Thanks for the response. I think I’ve figured it out. My screen is to advanced for my computer. Will be confirming with an older monitor and update.

1 Like

I did get the “headless” MacBook to boot again but could never get PoP to install on it. However, I have been able to get a version to run on the Raspberry, I have not had an option to install on a hard drive so it installs on the flash media. Not sure why that is. The drive I want to install to is a usb 480Gb formatted with fat32 and the Pi is booting from the flash media in it’s built in slot. I’ve tried twice but it never gives me the option to install on another device.
I’ve been using the Pi as my daily driver for a few days just to get more familiar with it. I cut my teeth on Windows starting with 3.1 through 7, NT Server and later server 2000. All too briefly then on to Mac from classic to 10.15 including x-serve and later server installations. And now trying to blow out the cobwebs and pick up Linux. So far it’s been a blast for an old tech retiree.

1 Like

That is awesome to hear @GrillerMiller!
And I do find it amazing how fast people here learn. Plus, you are not afraid to experiment, which is the certain path to success!
If you have any questions regarding the Raspberry Pi, @Will is the guy to talk to. He has all the knowledge when it comes to those little things. I’m more of a… heavy-duty workstation kind of guy! :wink: