Trouble with OpevVPN in Manjaro KDE Plasma

I have an OpenVPN set up on my on VPS with Linode, set up with the directions from the class in the LMS. I have successfully connected several devices, but recently wanted to try Manjaro KDE Plasma. Using my previous experiences and an online guide has not worked and I can’t seem to get the VPN connection configured properly. Can someone help?

I’m replying to my own post because I solved it! I followed the instructions at this web page: https://computingforgeeks.com/how-to-use-nmcli-to-connect-to-openvpn-server-on-linux/
Setting it up with nmcli worked! Here are the commands to start it up. Be sure to change the directory to the correct directory where the file is located on your computer, and change client1 to whatever you have named the .ovpn file:

cd /home/flex/OpenWrt

nmcli connection delete client1

sudo nmcli connection import type openvpn file client1.ovpn

nmcli connection up client1

nmcli connection show

1 Like

LOL I was about to recommend the terminal option. You are quick! Bravo! :clap:

1 Like

Too funny with the name of your VPN. I have my WiFi and VPN named similar. You would not believe how many people have made comments in the neighborhood about the name of the WiFi. They know it is mine!

image

2 Likes

That’s awesome. Great conversation starter, or enemy-maker! :grinning_face_with_smiling_eyes:

1 Like

I was able to use your instructions to add my open.vpn to my new Manjaro
Thanks for the info.

2 Likes