Trouble installing a program

Hi, I’m trying to install Bibisco, which is for novel writing. I followed these instructions:

"If your operating system is Linux :

    1. download the latest version:
  • bibisco-linux-amd64-2.4.0-SE.deb (Supporters Edition, Debian Package)
  • bibisco-linux-amd64-2.4.0-CE.deb (Community Edition, Debian Package)
  • bibisco-linux-x86_64-2.4.0-SE.rpm (Supporters Edition, RPM Package)
  • bibisco-linux-x86_64-2.4.0-CE.rpm (Community Edition, RPM Package)
  • bibisco-linux-x64-2.4.0-SE.zip (Supporters Edition, Zipped Directory)
  • bibisco-linux-x64-2.4.0-CE.zip (Community Edition, Zipped Directory)

if you downloaded:

  • Debian or RPM package:
    • install the package
  • Zipped Directory:
    • unzip downloaded file
    • open terminal
    • navigate into unzipped directory
    • launch ./bibisco
      "

Mine was zipped and it failed for me at the very last step. My terminal output looks like this:
jen@Lenny:~/Downloads/Bibisco$ launch bibisco

Command ‘launch’ not found, did you mean:

command ‘launchn’ from deb csmith (2.3.0-6build1)
command ‘0launch’ from deb 0install-core (2.15.1-1)

Any thoughts? I searched for other commands in place of launch but that didn’t help. I get the same error if I ask from within the folder or not in any folder.

Thank you!
Jen

Hi Jen,

  1. What version of Linux is on your computer?

To be certain, in the Terminal, type
uname -a

Please post an image of the results.

  1. What make/model of computer are you using/

Hi @nwarren,
thank you!!

My computer is a Dell Latitude E7450

Which version of Bibisco did you try to install?

Which Ubuntu version are you using? Mint (Ubuntu or Debian)? Ubuntu?

This file:
bibisco-win32-x64-2.4.0-CE-install.exe

and Ubuntu.

Hmm, I don’t see the “win32” version in your Linux list. Maybe what you were trying to install was for Windows, not for Linux??

Try installing one of the other, Linux zipped files.

What happened when you typed one of the other, suggested terminal commands?

launch

Oh my goodness :woman_facepalming:
I didn’t try the other commands as they looked so strange, but I have no clue how I ended up with a win file. Let me double check and get that right.

Ok, I downloaded this:
bibisco-linux-x64-2.4.0-CE.zip
and in the folder is the following:
bibisco-linux-x64-2.4.0-CE

I’m not sure where that win file is.

Either of off the ****.deb files should have worked for dpkg -i filename.deb

Should you use the .deb and dpkg if it complains our lack of a dependency you would simply install the missing dependencies with sudo apt install dependency1 dependency2 etc. using spaces to separate each listed dependency.

With the correct Linux zip, unzip it and then in a terminal switch to the new directory created during the unzip(if in a file manager you can right click and select open terminal here) in the new directory you would simply type ./bibisco
“Launch” was just telling you were going to run it with ./bibisco in the terminal.

@MrDeplorableUSA that worked! All I had to do was download a deb file and double click it! This is wonderful! I thought that was a for a different distribution.

THANK YOU!!!

2 Likes