Trezor download trouble

Hi - I am new to Linux. I am using the Ubuntu distro and am having issues downloading the Trezor suit? can anyone help?

Hey @analyst1776 and welcome to the forums!
The AppImage is a self-contained executable file. This means that you’ll need to run it directly from your file manager. One way to do it is to download the Linux app from the website:
https://suite.trezor.io

Then go to your file manager, which defaults to your home folder and create a folder/directory named AppImages. Once done, go to your Downloads folder (or where you saved it) and move it to the AppImages folder you created earlier. Once you do that, right-click on it, select properties and on the Permissions tab, select “Allow execution”.

Select OK and then double-click it. If it doesn’t run, then go back to the AppImages folder, right-click on the empty space and select Open in Terminal (or “Open Terminal here”) and type:

ls -l

You will see the name of the AppImage. With the file name I just checked, if you type:

chmod +x ./Trezor-Suite-22.2.3-linux-x86_64.AppImage

Press Enter and then type:

./Trezor-Suite-22.2.3-linux-x86_64.AppImage

It should work properly. If not, then please let me know of any error message that may have popped on your terminal window.

I hope this works for you!

thanks for the help Vasileious, you are the man! I’ll give it a try when I have some time this weekend.

1 Like

worked beautifully! Thank you very much!

1 Like

I am so happy it worked for you! Congratulations on getting it done! :smiley: