ToonTown Rewritten not showing screen

Hey all, just getting settled into Mint and started to add games to the list of things I want. One of my old time favorites is ToonTown. I loaded the launcher from TTR website, started it and it went through its updates. I logged in and the screen went blank, then disappeared. I could see my desktop but couldn’t touch it. I discovered that the pointer was in game and the sound of the game was present. I started to click the mouse and it was as if the game was running but all I can see in my desktop! Sooo. . . is there something I need to adjust to actually see the game?? Is it the game or the computer settings?

Hey @Paul!
I take it you couldn’t find it on Steam? If not, there was a discussion about it on Reddit.

You can follow the link for the unofficial installer that works here:
https://software.opensuse.org/download.html?project=home%3Amadsciencecoder%3Ashticker-book-rewritten&package=shticker-book-rewritten

You can essentially use the Ubuntu version of it.

Or…

You can check the Lutris version here:

:wink:

loaded the shticker-book-rewritten. It says it loads and has authenticated my login then. . . nothing.
Nothing on steam.
I did the latest version of Ubuntu, not sure what works best with mint 20.2

Then you might want to take the Lutris direction.

Lutris repairs are out of date and read me only. Cannot extract the fix. Tried reloading the launcher from the site and find the same issue. The loader updates like it should, then when done, allows you to log in. I log in and press GO button. It launches, then the screen appears to be going into the game, I hear the music, and my curser turns to the toon hand pointer as in the game. I can hear the background sounds of the game but the screen, in the beginning immediately disappears. So I am in game but cannot see it.
I had also tried shticker-book-rewritten again and this time clicked the nvidia option to see if my video program is messing with it. That launcher never gets out of logging in. It says I am logged in but I get completely nothing.
Not sure what to do at this point.