Toggling Wifi on and off in Linux Mint

I have downloaded Linux Mint on a laptop and Ubuntu on a desktop. It was easy to see how to toggle on/off wifi on Ubuntu. However, I cannot find a way to disconnect easily from wifi using Linux Mint. It’s not intuitive as it is on other OS’s. I often need to work offline, but this problem is forcing me off the laptop to another computer in order to stay offline. I’m sure this can’t be difficult, but I’d appreciate some instructions on where to look on the taskbar or elsewhere in order to turn on/off wifi easily and temporarily on Linux Mint. Any info appreciated! Thx.

My Mint laptop has both a physical button where I can turn off the wifi and a network/wifi connection icon in the bottom right tray (I may have put that there myself, I can’t remember right now) which I can click on and then there is a toggle switch to turn the connection on and off.

Edited to add: I did a quick search and came up with this link:
https://forums.linuxmint.com/viewtopic.php?t=293024

I don’t have that situation, but you did prompt me to go looking elsewhere! I found a toggle switch under “system settings” in the main LM apps menu. Fascinating. It’s a long way around, but it works! Thanks for giving me a nudge to look further afield. Appreciate it. Problem solved.

Hey @famcoll !

It actually has an option down on the right side. I currently run Mint on a Virtual Machine, so it’s directly “wired” onto the host OS WiFi. However, you will see that your WiFi on the bottom right side has the knob you can shift to turn it off.

Screen Shot 2021-10-01 at 16.52.13

Here’s the bottom right of my screen.

None of these functions as a toggle. I’ve tried right clicking on the wifi button, but it doesn’t function as an on/off toggle. I’ve tried left clicking on it, as well, but it doesn’t provide any on/off function.

Sandy helped me look elsewhere and I did find a place to toggle it off in the apps area. Not perfect, but it works.

Thanks!

It’s a left-click right on your WiFi icon, not a right one. :wink:
If it doesn’t provide you with the option, I find that strange.

In a worst-case scenario, you can also “demolish” the entire network and re-enable it any time you wish.
Simply type - in terminal - the following:

sudo systemctl stop NetworkManager

This disables all networks.

To re-enable it, type - in terminal again:

sudo systemctl start NetworkManager

OMG! It was right there! I had looked right at it several times and it didn’t even register. You were right. Thanks, again and as always. Life just got soooooo much easier.

2 Likes

As always, my pleasure to be of help! :blush:

1 Like

Hi @vasileios. I’m having a similar problem but with my computer, I’m not seeing the wireless toggle for me to activate. Is it possible that I don’t have the right driver?

I took the ethernet cable out of the router and connected it to the computer directly from the modem and got the notification below which doesn’t change.

How can I connect to the internet if the wifi isn’t activated and I can’t connect the ethernet directly? I’m sure I’m probably missing something. Thanks!

Hey @elglenn!
From what I’m seeing, your WiFi is not active as of yet. Also, the little update icon is lit - which means you have a few updates!
If your Wired Connection is going through, please run a full update. You can do that either through the small shield to the left of your Network, or by typing in the terminal:

sudo apt update && sudo apt upgrade -y

Once done, perform a reboot and check for your WiFi. If it’s not there, then I’d suggest starting a new topic in #questions with a photo of the output of (terminal):

lspci

Though I do hope the update helps! :wink:

Thanks for the response. The wired connection is not going though. It says “connecting” and doesn’t change from saying that. I have taken the ethernet and connected it directly from the modem to the computer, bypassing the router but it is not working. Am I doing something wrong?

You’re doing it right. Can you open up a terminal and type in the following command?

uname -r

And please let me know the result. I remember Mint comes with the 5.4 Kernel, so I want to be certain that it’s still on that number. :slight_smile:

This is what happened

As I thought! Your issue could be the older kernel not having all the drivers. I have two recommendations, if you don’t mind testing them out. :slight_smile:
They would include testing another distro in their Live environment and see if they recognize your Network (wired or WiFi). The first one I’ll recommend is the Zorin OS Core (free version), which you can find here:

The reason I’m suggesting this is because you can shift the outlook to appear with the Windows style of Cinnamon - out of the box. It also has the same Kernel as Ubuntu, which would be 5.11.

If that doesn’t work out, try Manjaro KDE. This has an even newer Kernel - and I think they are either on 5.13 or 5.14.
https://manjaro.org/download/

Simply test their Live Version and see if they put your network to use out of the box. If they do, then it’s Kernel-related. :slight_smile:

Thanks. I am testing Zorin right now and getting this message when I search the settings for wifi. I take it as this meaning that it’s not working out of the box as you say. I’ll test manjaro now.

When I tried Manjaro, I got this message when trying to boot from flash. My system is however 64bit and not 32.


I would say select the proprietary ones. It might have a repository (AUR) that could quickly solve the WiFi issue. :slight_smile:

Also, you can download - of course - the 64-bit of KDE on the top. Manjaro - KDE Plasma

Actually that is the one that I downloaded and I tried the proprietary install but got the same message as the top photo that said “you need to load the kernel first”.

I didn’t see anything about an AUR. Maybe I didn’t get that far.

I’ve watched some youtube videos but they all seem to start out from a place where the wifi is already installed. For myself, it does not yet show up in the tray menu below.

I actually find it interesting how Manjaro starts with the options screen that you’re getting. Perhaps there is a setting in the BIOS that produces some form of conflict?

The actual Manjaro boot (for installation/preview) looks like this;