Timeshift disappeared after an update

In the last two days, I did two things: 1. installed snap and 2. accepted updates

My entire set of restoration points in timeshift has disappeared and my browsers have become unstable.

I tried to remove the snap function, but linux is telling me it isn’t there. I keep getting pop up instructions for controlling snap. Also, my cursor is jumping all over.

Is there anyway to retrieve my previous restoration points? If not, I’m going to have to reinstall Linux mint to clear this mess up.

Thanks for any suggestions.

1 Like

That is an unfortunate dilemma!

Try opening a Terminal and entering the following:

sudo timeshift --restore

If the snapshots are still on your system, they should show up in a list after this command is run. If they are, you can use this process to restore your system to before installing snap.

If not, I would recommend reinstalling your OS.

As another option, you could try running a purge command to try and remove everything related to the snap installation:

sudo apt purge snapd
1 Like

Thanks, so much for this advice. I was able to determine that there were still previous restore points on the computer using terminal commands. Not believing I could be so lucky, I decided to blink and restart the computer a couple times. Voila! Timeshift showed back up on the desktop with pre-snap restore points in place. I backed up all my data files just in case the shtf again and then restored. So far so good. I’m not sure what snap is, but I will never, ever, ever let it near this laptop again. It’s like a little demon! Appreciate your taking time to help.


Hey @famcoll!
First of all, than you @SBHX for helping her out!
That’s the first time I hear of Snap doing that. However, Timeshift’s backups do not disappear as they are well “sealed” in a different folder.
As it comes to Snap, it’s a type of package management that confines its applications in a form of “Sandbox” - which means it keeps them separate from the rest of your system - and includes all the necessary dependencies confined in a folder reachable only by the app you install. This helps avoid version conflicts. Perhaps a Snap that demanded the - -classic flag as an installation could have done it. I know a couple of those and one happens to be Skype.

1 Like

Thanks. Timeshift is my new best friend. Lately, any update seems to be creating instability in my Linux Mint. Everything is fine when I don’t update brave browser and sticky notes. But, when I decide to try, again, I get zombie world. Everything slows down and my cursor takes on a life of its own. Any ideas?


Hello again, @famcoll!
Have you tried to update them separately to see which one is actually causing the trouble? I’m suspecting Sticky Notes, as I have been constantly updating Brave without an issue. Narrowing things down will definitely help out.
Which app are you using as Sticky Notes?

1 Like

I don’t even know what sticky notes is or with which app it may be associated. Its very name sounds troublesome. I’ll update just Brave to see if that’s the problem. If not, then we have the culprit. I’ll let you know.


Updated Brave browser. No adverse reactions. Am avoiding the sticky notes update like the plague!


Do a little search and let’s look which kind of sticky notes you have.

apt search sticky

If it portrays it as installed, then that’s it. Otherwise, please try to find the icon for the sticky notes, right click on it and look at what command it calls for execution in its properties window. :slight_smile:

We might as well purge it from your system so that you can update normally.

1 Like

This is what I saw:

famcoll@Inspiron-5566:~$ apt search sticky
v node-babel-plugin-transform-es2 -
i sticky - Sticky Notes app
p wmstickynotes - Window Maker dockapp to create sticky note

seems to be there. how to purge it?

1 Like

See which one has the [Installed] value next to it. If there’s one, then type:

sudo apt purge name_of_package

Replace the name_of_package with the actual package that appears to be installed.

1 Like

I found the icon, used the right click and uninstalled from there. I soooooooooo wanted to command line disappear it, but … ah … next time! I’m pretty sure it’s gone. Time will tell. Thanks, again, as always.


Yep, it’s gone because the annoying update notice went away as well! Success is a beautiful thing.


Excellent. For those looking to be more “intimate” with Linux, learn how to peruse the log files. If you can break through the learning curve of reading log files, you’ll be way ahead of the game.

1 Like