Timeshift Changed Partition Mount Point

When I installed Ubuntu on my PC I was following the advice to set up a separate partition for “Home” to allow installing/reinstalling the OS without wiping all my data files, etc. I messed up somewhere and I ended up with a “Home” created by the install in the “File System” partition and another “Home” (the one I wanted for all my stuff) that showed up under /media.

I planned on one day trying to find out what I did wrong and if possible fix it.

In the meantime I just installed “Timeshift” about a week ago and was letting it do its thing. I chose to have it back up all my data and was going to store the backups on an external drive. BUT the only available drive had a mixed file format and I discovered Timeshift will only backup to a Linux file system.

So until I could rectify that issue I chose the back up destination to be on the same drive that I was backing up.

I shutdown my PC this morning and rebooted, for the first time in over a week, only to find my “Home” had “disappeared”!

I disabled “Timeshift” and I’ve spent half a day on research to try and figure out how to get my system back to the way it was… looking at articles on /etc/fstab is making my head hurt…


I’m not real sure on what happened here and I’m not real certain of timeshift as I haven’t played with it much.

First a little file system hierarchy information:

Can you start by giving a few screens of terminal commands. I suggest copy and paste the commands, you will have to supply the admin password.

sudo blkid
sudo fdisk -l
sudo mount -l

We’ll see if we can resolve this.

Give me some time too look through this and see what we can figure out.

Thanks Deplorable,

I still have all my files, but of course none of my links/shortcuts work and my default locations such as where I download files, etc no longer work.

This is a real pain. Really hoping you or anyone here can help. I’m going to keep searching the web, but I cannot find anything specific to my issue and as yet have not found anything that can be adapted to this.

I suspect the solution is through fstab but not seeing it as yet…

Really appreciate your time.

I think I found a workaround for your problem as detailed in here:


The first reply:

TimeShift will mount the storage location to /run/timeshift/backup whenever it runs. It doesn’t unmount when it’s finished. That shouldn’t be a problem because the same thing can be mounted more than once at different places in the filesystem. Does the data storage get unmounted every time TimeShift is run? I suggest you explicitly exclude /media from the backup. My guess is TimeShift recognises that without unmounting the data storage you would be asking it to make a backup of the backup location.

– [PonJar]

basically, what it’s saying that when you run timeshift it mounts it but when you quit it it does not unmount, that you need to manually unmount and mount again for it to work right.

Not sure if this a timeshift bug but seems quite relevant to your situation.

hope this helps!

Yes I came across this same post in my search.

I can unmount, no problem… but according to my research I need to create a Mount Point/Directory. Originally it was under /media/ummd/Home.

Whenever I booted I would find my “Home” Directory/Partition under “+ Other Locations” “On This Computer” (see my first screen shot) and then all I did was click “Home” and voila it was mounted and available for use. If I did not click “Home” in Nautilus after rebooting then my other file manager “Nemo” cannot see those files.

Since I Installed Timeshift it has run twice 22nd and 29th at 1800, so unless Timeshift runs at startup I see no reason for the mount point to change. Also, I am pretty sure (not 100%) that I have booted my system once or twice in that time with no problem. AND if I am reading the above post correctly would not this issue have raised it ugly head the FIRST time Timeshift did its thing?

Now that I have disabled Timeshift I am going to unmount my “Home”… reboot… and see what happens…

Fingers crossed I don’t mess things up even more…

I’m back…

So I shut everything down used “Disks” to unmount my “Home” partition. Just for sheds and giggles I mounted that partition to see what would happen and bugger me… it is now mounted in its normal place!

There is a whole Sunday I will not get back. :rage: :cry:

Will not be using Timeshift again anytime soon!!!

1 Like