Telegram - Help Needed

I’m now working from my laptop with LinuxMint! Woo-hoo! I just downloaded the Telegram App for Linux and tried to open it without success. I clicked to extract and my home folder opened up. Telegram wasn’t in Downloads. Now I have no idea where the file is located. I’d appreciate any help to locate and open the file.

Hey Wizard!

When I first booted up my initial test run of Mint, I immediately went to Telegram’s website and downloaded the file from there. I would double click the gear file from the extracted file and Telegram would open, but I wouldn’t be able to pin it to the panel at all. Come to find out, it is essentially running a script that mimics the Telegram app. And you can’t pin scripts to the panel.

I then discovered that it’s better to install it through the command line, or Terminal. But first, we should remove any trace of the other one you downloaded.

Step 1:
Open the Terminal and enter:

sudo apt remove --purge telegram-desktop

If this comes back with an error saying that it can’t be found, try just “telegram” (without quotes). If that also says it can’t be found, then we are good and we can move on. If it did remove it, then we can also proceed.

Step 2:
Back in the Terminal, enter the following:

sudo apt install telegram-desktop

Doing it this way will actually install the app on your computer and not be just a script that you run whenever you want to use it.

Let me know if you have any issues beyond this, and I will see what I can do.

1 Like

That worked beautifully, thank you!!

No problem! Enjoy fighting for your freedom!

1 Like

I just realized that I’m unable to see the comment section on some of the Telegram groups. It’s there when I view it on my phone but not there when viewing on my laptop. Do I need to delete and re-load?

That’s a new one on me. You can try removing it and reinstalling, don’t know if that will fix the problem, but worth a shot.

1 Like

Thanks, I’ll try that.

That didn’t change anything. I’ll just continue to view it on my phone. I appreciate your suggestions. Thank you.

1 Like

Thanks for the help with the install. I did that, but after a while, during the use of the app, it just shuts down. Could it be a memory thing? My feeling is there is a setting that needs to be adjusted so this does not happen during a session. Thanks for any help.

Make sure you run a system wide update first.

sudo apt update
sudo apt-get upgrade -y

As a rule of thumb, always do “sudo apt update” after you install something to make sure you have the latest version of everything on your computer.

If that does not work, my only other suggestion would be to uninstall and reinstall using the procedure from my previous post.

There are ways to customize memory allocation for certain apps, but I have not gotten that far in my Linux journey quite yet.

1 Like

RT
I’ll go ahead and run the system wide update. Thanks.

I’m familiar with this issue. The basic reason is that the APT repository version of Telegram is older than the one used by the majority by several versions.

This is easily resolved via the SNAP version of Telegram. However, you’ll need to enable snap installs on Linux Mint. This can be done by opening a terminal and typing:

sudo rm /etc/apt/preferences.d/nosnap.pref

Then the process is simple:

sudo apt update
sudo apt install snapd

For snapd to function you will either need to reboot your machine or log out and then log back in. I’d recommend the former, just to be 100% certain.

Once you reboot and login, purge the currently installed Telegram, if you have it installed by typing in terminal:

sudo apt purge telegram-desktop

Once that one is done, go ahead and type:

sudo snap install telegram-desktop

This will take a bit longer as SNAPs create a self-contained version of an application with all its dependencies and libraries in one place. Most of them also function in sandbox mode which means they run in an isolated part of the system’s memory.

Once done, run Telegram and please let us know if your issue was resolved. :slight_smile:

4 Likes

Success!! That worked! Now I can see comments and make comments. I really appreciate the time you devote to helping those of us who are new and learning. Many thanks!

2 Likes

Honestly, there’s nothing that makes my day better than to be the reason for someone smiling.

Thus, as always, it’s my pleasure! Enjoy! :smiley:

1 Like

How to generate Emojis is my next question but I’ll save that for another day.

Easy. If you keep your window large enough and tap the little emoji button to the right side of your chat box, it will open the entire emoji and sticker collection on your right side. :slight_smile:

1 Like

@SBHX @vasileios Thanks for these instructions. Easy to follow and got my telegram up and running. I really like the terminal now that I am not afraid of it… :laughing: :sweat_smile:

2 Likes

I was successful in flashing CalyxOS to a Pixel 4a (5g). Hooray! Now I’d like to install Telegram, and I remember somewhere there was a recommendation as to which install is preferred.

I have “Telegram FOSS” offered in the F-Droid store, or “Telegram” in the Aurora Store. When I select the installation on the Aurora Store I get a message “your phone is not allowed to install unknown apps from this source.” Is it ok/safe to allow installations from the Aurora Store?

On the F-droid store, I get an alert that “this app promotes non-free network services” and “the upstream source code is not entirely free”.

Which source is better? I appreciate any input you all may have.
Thanks!
Denise

Hello Denise,
I do not have a de-Googled phone to offer you an option with 100% certainty. What I do know from other sources is that Telegram has its official client and a few unofficial ones. I believe the FOSS one is the unofficial one.

There should be options for your phone that allows you to select the sources for your app installations. In my opinion, going with the official client would be best. This means going for the “Telegram” one. However, make sure that it reads “official client” in the app description. :slight_smile:

1 Like

The Aurora Store app provides a developer link back to the telegram.org website. I’ve gone ahead and downloaded the app and it seems to be working as expected. Thank you Vasileios. Your time spent answering is greatly appreciated! :slight_smile:

1 Like