Suddenly having problems with Proton VPN on Ubuntu 20.04

I don’t think the Mullvad browser comes with a VPN. And yes, the Mullvad VPN is not free. IMHO it is a fair price. I have not had any problems, except for a very few websites eg “Truth Social” that will not work with it. If those websites don’t respect my privacy and my desire to keep my traffic hidden from my ISP, I don’t need THEM! Subscription to Mullvad VPN is a flat rate one rate irrespective of time frame for up to 5 devices and no auto reload. Exactly what I want.

1 Like

Right, from reading some things I thought it did, but I installed it a few hours ago and no VPN there. :face_with_diagonal_mouth: But I assume the VPN integration is seamless when you sign up for that. As you say, it IS a paid service. I looked at those options a bit. You can get an Account Number by clicking a button, and they say they collect no info on you - email address, etc - but to pay for the service you kinda do have to give some personal info! There are multiple payment methods, and maybe some are fairly anonymous, but if I go for it I’d probably use PayPal or something easy.

I saw the flat rate, and it looked like a monthly deal - pay as you go. I guess you have to remember to pay up every month. I didn’t see the 5 devices part, so thanks for that info! But right now I’m probably only going to be using one Linux install at a time, unless I can put it on my phone too.

I’ve noticed a lot of ‘throttling’ and glitches on websites while using a VPN. Particularly sites like YouTube and even Rumble, but many others too. They can tell when traffic is coming from a VPN server many times, and I think there’s an orchestrated effort to quell or quash the use of them. To be fair, VPN’s might also be used for DDoS attacks and dark web stuff (to conceal identity), so there may be some security concerns for the website admins that accounts for part of that.

1 Like

Thanks for your reply, yes I am indeed using Ubuntu 20.04. What you say does make sense indeed, so I am going to attempt an ‘uninstall’ today in the hope it will rectify all the many issues that have appeared on my desktop & various software progs since the original ‘install’ . What is really annoying is that the actual Protonvpn package isn’t actually installed , its just a .exe package in my download folder. Oh well here goes.

1 Like

Numerous ways to pay… even cash… unfortunately no Carrier Pigeon service?!

Screenshot from 2024-03-17 09-37-48

Subscription expiration displayed at top of app window.

1 Like

Have not had those problems with YT and Rumble or others that I can tell.

Then again I’m old and slow, just like my pc (much, much faster on Linux than it was on Windoze) so I probably haven’t noticed.

I understand the interweb is both good and evil, just like people. Good people have guns for protection from bad people. Bad people use guns for crime. So we should “quell or quash the use of them”… knives, hammers, cars, ice picks, baseball bats? Good people use VPNs because of bad people.

1 Like

I assume you’re using the Windows lingo with “.exe”? The Linux Ubuntu download I have for Proton VPN is this: “protonvpn-stable-release_1.0.3-2_all.deb”. If you attempted to install an .exe file on Linux that could likely cause some problems! If it would even let you try at all, that is.

Please let us know how your progress goes.

1 Like

Yeah, I was in that screen I think when I researched earlier, but couldn’t find it again. I’m sure it will show up if I put in the account code to sign up. Thanks for the screenshots, very helpful! I did search the “Voucher” option when I saw the ‘reseller’ page, and found out that Amazon sells 6 month and 12 month vouchers. That might be a way to be more anonymous, excepting Amazon. :upside_down_face: I am a little leery of sharing info with PayPal as they pulled that stunt 1-2 years ago of threatening to “fine” their users for buying “the wrong things”. There was a big deal about that and they rescinded it AFAIK.

So once you have the Mullvad VPN paid “time”, and the app installed, does something show up in Mullvad browser to manage the VPN? Like a plugin or extension? Or are they totally separate? I guess they might have to be separate so that the VPN isn’t just managing your browser traffic, but all internet functions?

They show that they still support Ubuntu 20.04, so that’s nice. I’m still thinking of upgrading, but am happy to have an option not to also.

1 Like

YouTube is really bad, it ‘hangs’ for half a minute at least before loading a video. Once the video starts playing it works fairly well. Part of that could be ad-blocker related, but I only noticed the issue the last few months. The Rumble issue started around the time of them being “hacked” end of last year. The videos load okay, but will will not start playing properly, or randomly stop playing in the middle. Very strange. I haven’t done a proper A/B test without VPN, but have noticed that without Proton VPN the last week or two, both video platforms seem to work a lot better. So far I haven’t had issues like that with the Opera browser with built-in VPN, though I just started using that maybe 2 days ago.

Yep, it’s a world of duality we live in, the light and the dark. While I use VPN to keep things private from ISP etc, it’s also some security (I hope) from scammers collecting login info, passwords, etc. Jeff says Linux is very secure in that regard, but I don’t know how well the browsers handle that, and once info leaves your system to the interwebs … who knows!

2 Likes

I use Mullvad for all my internet traffic. In my Mullvad settings my internet connection is blocked if for some reason the VPN quits. I’m using Firefox. Have not tried the Mullvad browser, so cannot answer your question. Started looking into it yesterday but have to research the install before trying.

1 Like

Just figured out something new:

Using the “Quote” function in this forum.

Thank you

:grinning: :upside_down_face: :blush:

It’s the little things…

1 Like

That’s called a “Kill Switch” in some VPN apps, where it will block internet if the VPN quits working. I just tried the Mullvad browser briefly, but liked it okay. It’s supposed to have a lot of security and privacy elements built in, so may be pretty good (TBD). I’m still using Brave browser mostly, as it’s supposed to be quite good for security/privacy and has a non-tracking search engine (Brave search).

Ha, you’re welcome! Learning is good!

UPDATE: Okay, so I think I made some great progress! Software Update popped up with that reminder to upgrade to Ubuntu 22.04, and I had been considering it seriously now. So I decided to go for it. It took less than 30 minutes, a reboot, and done. Most things are the same as far as I can tell. The Show Applications function is different, icons are smaller and not in alphabetical order like they were before, but maybe I can adjust those things in Settings. Wallpapers were replaced with new ones also. I might have saved my favorite one if I knew that.

It actually updated to Ubuntu 22.04.4 LTS (rather than 22.04.3 LTS). So then I tried the Proton VPN install. Similar issue at first, with install error messages in Terminal. So I did “cd Downloads” (where the package is located) and then tried the script again and … success! Installed and using the VPN right now. It’s possible that directory change would have done the trick without the distro version upgrade, but say-lah-vee. :neutral_face: It probably was a good idea anyway. Progress, y’know.

Note: When I first connected Proton VPN, I got the list of servers, clicked on one, and it briefly did that “empty window with the chosen server” trick, but then reverted back to the full server list and connected quickly. Similar behavior as when I had the problem connecting in 20.04, but now it actually works! So maybe I did need the 22.04 upgrade after all.

I’ll keep Mullvad VPN in mind though. Seems like maybe it’s the best around, and the price is pretty reasonable.

1 Like

Oh dear, must be brain fog :frowning: yes indeed a left over from ‘that’ other system. The package that was downloaded is protonvpn-stable-release_1.03-2_all.deb which at the moment I’ve just ignored. Still trying to sort out the original problem; I did an ‘uninstall’ this morning but it didn’t work, the laptop hasn’t restored to ‘original’ condition of before. So, having wracked my brains for what to do - I’m sitting back for now till I find someone locally to me that works on Linux… I have a vague suspicion I know what I did wrong, but will have to investigate that possibilty further before I make any further changes. Its certainly a good brain workout! :face_with_open_eyes_and_hand_over_mouth: :crazy_face:

1 Like

Right Click on the desktop:

vlcsnap-2024-03-17-13h52m36s508

1 Like

Thanks, I tried that, but I think that’s for the Desktop icons. I only have the default “Home” folder on the Desktop. What I’m talking about is the ‘button’ at the lower left of my screen (9 dots in a square) at the bottom of the Dock. It says “Show Applications” with a mouse hover (might also be called a “launcher”?). Clicking it brings up a list of installed apps, overlaying the Desktop. I see no way to sort those, though I can drag and drop the icons as I wish. In the old version of Ubuntu, these were sorted alphabetically. I guess the upgrade updated some apps and moved their icons? It was only some icons, maybe 75% were still alphabetical. Inside the Utilities app folder they’re also out of order though. Just weird and a little frustrating, but there is the Search feature there that can help.

A quick search found this:

gsettings reset org.gnome.shell app-picker-layout

from: How to Reset the Apps Grid in GNOME 3.38 - OMG! Ubuntu

Looks Like it worked except for the first six icons??? My GNOME Version is 42.9

A more recent “fix” which I did not try because of the extra steps involved, but is probably exactly what you are looking for, is here:

1 Like

My GNOME version is the same. I tried this and it worked, thank you! The first few icons were off, as you say. But I like the bigger icon size like I used to have in 20.04, though it looks like Favorites went away. I didn’t use that much though.

I actually tried this first, but got confused. I clicked “Install” on the GitHub site for the extension, but then couldn’t figure out what to do from there. It didn’t seem to download anything.

Proton has been making significant changes to all of their software in recent months. Technology forums, not just this one, are full of messages from people posting about configuration and compatibility issues with Proton’s software.

1 Like

Thanks for the confirmation! Which gives rise to another question for me:
I have Proton VPN also installed on my Windows 7 desktop PC. I use another VPN than Proton on Windows typically, but have it as a backup. Do you have any idea when Proton VPN might end Windows 7 support? I tried using Proton VPN on my Windows 7 the other day and it was fine, but am wondering if this is just another ball waiting to drop?

My Ubuntu install is on another computer, a fairly new Mini-PC (NUC), and I’m trying to move away from Windows to use Linux exclusively, hopefully. Once I start using Virtual Machines (for Windows-only apps), I should be pretty close to that goal.