Suddenly having problems with Proton VPN on Ubuntu 20.04

I use Mullvad for all my internet traffic. In my Mullvad settings my internet connection is blocked if for some reason the VPN quits. I’m using Firefox. Have not tried the Mullvad browser, so cannot answer your question. Started looking into it yesterday but have to research the install before trying.

1 Like

Just figured out something new:

Using the “Quote” function in this forum.

Thank you

:grinning: :upside_down_face: :blush:

It’s the little things…

1 Like

That’s called a “Kill Switch” in some VPN apps, where it will block internet if the VPN quits working. I just tried the Mullvad browser briefly, but liked it okay. It’s supposed to have a lot of security and privacy elements built in, so may be pretty good (TBD). I’m still using Brave browser mostly, as it’s supposed to be quite good for security/privacy and has a non-tracking search engine (Brave search).

Ha, you’re welcome! Learning is good!

UPDATE: Okay, so I think I made some great progress! Software Update popped up with that reminder to upgrade to Ubuntu 22.04, and I had been considering it seriously now. So I decided to go for it. It took less than 30 minutes, a reboot, and done. Most things are the same as far as I can tell. The Show Applications function is different, icons are smaller and not in alphabetical order like they were before, but maybe I can adjust those things in Settings. Wallpapers were replaced with new ones also. I might have saved my favorite one if I knew that.

It actually updated to Ubuntu 22.04.4 LTS (rather than 22.04.3 LTS). So then I tried the Proton VPN install. Similar issue at first, with install error messages in Terminal. So I did “cd Downloads” (where the package is located) and then tried the script again and … success! Installed and using the VPN right now. It’s possible that directory change would have done the trick without the distro version upgrade, but say-lah-vee. :neutral_face: It probably was a good idea anyway. Progress, y’know.

Note: When I first connected Proton VPN, I got the list of servers, clicked on one, and it briefly did that “empty window with the chosen server” trick, but then reverted back to the full server list and connected quickly. Similar behavior as when I had the problem connecting in 20.04, but now it actually works! So maybe I did need the 22.04 upgrade after all.

I’ll keep Mullvad VPN in mind though. Seems like maybe it’s the best around, and the price is pretty reasonable.

1 Like

Oh dear, must be brain fog :frowning: yes indeed a left over from ‘that’ other system. The package that was downloaded is protonvpn-stable-release_1.03-2_all.deb which at the moment I’ve just ignored. Still trying to sort out the original problem; I did an ‘uninstall’ this morning but it didn’t work, the laptop hasn’t restored to ‘original’ condition of before. So, having wracked my brains for what to do - I’m sitting back for now till I find someone locally to me that works on Linux… I have a vague suspicion I know what I did wrong, but will have to investigate that possibilty further before I make any further changes. Its certainly a good brain workout! :face_with_open_eyes_and_hand_over_mouth: :crazy_face:

1 Like

Right Click on the desktop:


1 Like

Thanks, I tried that, but I think that’s for the Desktop icons. I only have the default “Home” folder on the Desktop. What I’m talking about is the ‘button’ at the lower left of my screen (9 dots in a square) at the bottom of the Dock. It says “Show Applications” with a mouse hover (might also be called a “launcher”?). Clicking it brings up a list of installed apps, overlaying the Desktop. I see no way to sort those, though I can drag and drop the icons as I wish. In the old version of Ubuntu, these were sorted alphabetically. I guess the upgrade updated some apps and moved their icons? It was only some icons, maybe 75% were still alphabetical. Inside the Utilities app folder they’re also out of order though. Just weird and a little frustrating, but there is the Search feature there that can help.

A quick search found this:

gsettings reset app-picker-layout

from: How to Reset the Apps Grid in GNOME 3.38 - OMG! Ubuntu

Looks Like it worked except for the first six icons??? My GNOME Version is 42.9

A more recent “fix” which I did not try because of the extra steps involved, but is probably exactly what you are looking for, is here:

1 Like

My GNOME version is the same. I tried this and it worked, thank you! The first few icons were off, as you say. But I like the bigger icon size like I used to have in 20.04, though it looks like Favorites went away. I didn’t use that much though.

I actually tried this first, but got confused. I clicked “Install” on the GitHub site for the extension, but then couldn’t figure out what to do from there. It didn’t seem to download anything.

Proton has been making significant changes to all of their software in recent months. Technology forums, not just this one, are full of messages from people posting about configuration and compatibility issues with Proton’s software.

1 Like

Thanks for the confirmation! Which gives rise to another question for me:
I have Proton VPN also installed on my Windows 7 desktop PC. I use another VPN than Proton on Windows typically, but have it as a backup. Do you have any idea when Proton VPN might end Windows 7 support? I tried using Proton VPN on my Windows 7 the other day and it was fine, but am wondering if this is just another ball waiting to drop?

My Ubuntu install is on another computer, a fairly new Mini-PC (NUC), and I’m trying to move away from Windows to use Linux exclusively, hopefully. Once I start using Virtual Machines (for Windows-only apps), I should be pretty close to that goal.