Stuck after bash command installing VPN

Hi all,
I’m following along with the VPN instructions and got stuck right at 10 minutes into Workshop 17 that @vasileios made :). After the bash command, it asks for a password and then says no such file or directory. I’ll add a screenshot of mine and of the workshop right at that moment.

Thanks for any help!

if you haven’t looked at it again. I think you may have misspelled the line…

I should add that using the “Tab” key in the middle of a command or filename will usually provide the next most likely completion up to match segments of mutlipes having the same start.

typing open(tab twIce) Would likley show openssh, openvpn and openvt. This process can be used with completing filenames as well.

@MrDeplorableUSA :woman_facepalming:t4: :woman_facepalming:t4: :woman_facepalming:t4: :woman_facepalming:t4: :rofl: :rofl:
What a great lesson. Thank you! I’m out the door at the moment, but now I’m excited to get back to this!

1 Like

And very cool on the tab information! This is ALL new to me!

1 Like

@vasileios @MrDeplorableUSA I got a lot further and am trying to find where the openvpn is now (I think that’s what we’re doing) (around minute 15 in the workshop). After the following command:
sudo curl
The terminal says sudo: curl: command not found
I tried installing curl in another window and it says it’s already there, so I’m not sure what to try next.

I’m sorry I don’t have the workshop info available, I opted to not to take it so newer users would have seats, so I cannot really comment on the way @vasileios is having you do it through the workshop.

Definitely give it a second look. Remember, spacing and syntax/spelling are the most common issues aside from not having the proper libraries installed of which you checked and made sure it was installed already.

@MrDeplorableUSA no worries at all! I hope you get in soon :).

This was another DOH! moment. There is a file with the video and in the doc, Vasileios says what to do if one encounters this problem (sudo apt install curl net-tools). And it worked!!


Hey @Jen!
Just as @MrDeplorableUSA mentioned, I see you typed in “stall” instead of “install”. :slight_smile:
Also, yes, when you start typing the name of a file, you can hit TAB and bash will auto-complete it for you. At the very least, if there are two files with a similar name, it will stop at the last common letter and then wait for you to input the next. However, if you hit TAB again, it will show you the different - somewhat similar - files so that you can choose. :slight_smile: