SSL error when setting up VPS

When I created the WP site I am getting an error at the point of setting up the SSL. I am using Namecheap for the VPS and I do have a SSL certificate as part of my Domain. Not sure what to do to finish the setup.Command Line text below.

Successfully created site
Certificate type : domain

Use the flag --force to bypass this check.
You have to set the proper DNS record for your domain
Aborting SSL certificate issuance

I figured it out. Had to go into Advanced DNS setup and add a text line linking the site and IP.

1 Like

Hello @Circuitriders!
The DNS records can be quite the pain when setting up a VPS. I’ve been battling with them and the SSL and all the 400+ tests that my VPS domain has to go through (which is managed from within the installation, not the VPS provider). Congratulations on solving it! :smiley:


Thanks for this post. Could you tell me how you got to the Advanced DNS setup?

I got the same error message.

I use Namecheap and under Manage VPS went to Advanced DNS. Add a record, Type (A Record), Host (@), IP Address. Then did a Refresh of the server. This points the Domain to the IP. Hope this helps.

1 Like