Sound Issues since installing Linux Mint

Hi! Since I installed Linux Mint, the sound on my HP laptop has been really bad. It makes terrible static noises upon startup and when I open a browser. I’ve even headed over to the LM message boards, and no one’s found a solution yet. If anyone has a suggestion, I’m all ears!

Hey @susanesmith,
I’ll need some more info from you in order to research this further. I’m running Linux on three different HP laptops and the sound works like a charm. The HP I’m writing from, currently, runs Linux Mint Debial Edition and it’s a 2008 model (Pavilion dv4).

What I will need from you is the exact model of your HP laptop. Then, I’ll also need a screenshot (or a copy/paste) from the following terminal command:

lspci

So that I can identify the exact hardware your system is using for audio.

Last, if you can, please install the inxi application, if you don’t already have it, by executing in terminal:

sudo apt install inxi

And then copy and paste the outputs of the following command here:

inxi --full

Let’s see if we can solve this. :slight_smile:

Thank you! I can’t believe I’m getting a response back from one of the stars of the training video! :grinning:
This is a 2016 HP Envy. I followed your instructions, and here is the output of your request:
Reading package lists… Done
Building dependency tree
Reading state information… Done
inxi is already the newest version (3.0.38-1-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
susan@susan-HP-ENVY-Notebook:~$ inxi --full
System:
Host: susan-HP-ENVY-Notebook Kernel: 5.15.0-41-generic x86_64 bits: 64
Desktop: Cinnamon 5.2.7 Distro: Linux Mint 20.3 Una
Machine:
Type: Laptop System: HP product: HP ENVY Notebook v: Type1ProductConfigId
serial: <superuser/root required>
Mobo: HP model: 80EE v: 87.51 serial: <superuser/root required>
UEFI: Insyde v: F.35 date: 03/04/2016
Battery:
ID-1: BAT1 charge: 21.7 Wh condition: 46.9/62.2 Wh (76%)
CPU:
Topology: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP
L2 cache: 6144 KiB
Speed: 1000 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1000 2: 1035
3: 1000 4: 1000 5: 1000 6: 1000 7: 1001 8: 1004
Graphics:
Device-1: Intel HD Graphics 530 driver: i915 v: kernel
Device-2: NVIDIA GM107M [GeForce GTX 950M] driver: nvidia v: 515.48.07
Display: x11 server: X.Org 1.20.13 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.2.6
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.15.0-41-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp7s0 state: down mac: a0:8c:fd:82:b4:ad
Device-2: Intel Wireless 3165 driver: iwlwifi
IF: wlp8s0 state: up mac: ac:2b:6e:e3:2e:93
Drives:
Local Storage: total: 1.03 TiB used: 61.62 GiB (5.9%)
ID-1: /dev/sda vendor: SanDisk model: SD8SNAT128G1122 size: 119.24 GiB
ID-2: /dev/sdb vendor: Western Digital model: WD10JPVX-60JC3T0
size: 931.51 GiB
Partition:
ID-1: / size: 116.32 GiB used: 61.61 GiB (53.0%) fs: ext4 dev: /dev/sda2
Sensors:
System Temperatures: cpu: 40.0 C mobo: 29.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 275 Uptime: 13m Memory: 15.47 GiB used: 2.74 GiB (17.7%)
Shell: bash inxi: 3.0.38

Hey @susanesmith!
Thank you for providing the info!
It is not the first time that I encountered issues with an HP Envy system. For some reason, they are the naughty ones of the line. I suppose I have been very lucky, as I have 2 desktops and 3 laptops that are HPs - and they have been behaving for the most part. Only two of the laptops need some intervention for their WiFi - and one of them needs a change of firmware to be able to receive signals from devices that are further than 10 inches!

As I was studying the HPs, there have been issues with the Envy ones, especially the sound. In some cases, people have to completely remove their drivers and replace them with others. In your scenario, I am suspecting your audio is receiving a feedback from another source, which is causing the distorted sound.

Note: A new Linux Mint - with an upgraded Kernel (which hosts the modules/drivers) is at the beta stage, so, the final version, which is a big upgrade will be coming out soon (your current 5.4 Kernel will be upgraded to 5.15).

Meanwhile, let’s see if we can work around this. Keep in mind that this is a tricky one and we will need to take it via trial and error. However, there’s no need for alarm, as we’ll perform non-destructive steps.

Let’s start with a simple feedback test.

Open your Software Center and look for an application called QASMixer. Hopefully, I spelled it correctly (it definitely has the “Mixer” part in it). That’s the ALSA (audio driver) mixer, which - at times - may hide channels that are not visible on the normal sound sliders, which are connected to the Pulse audio system.

Once you install it, play a piece of music in the background and open the QASMixer from your start menu. Hopefully, you will see more than one sliders - and look for the Input tab. If there isn’t any, go to your actual sound settings and see if the mic (input) is activated. If it is, it could have a “monitoring” feedback, which tends to cause havoc to the speakers.

Since you’re on the Cinnamon Desktop Environment, we can’t try to forge a new audio tunnel. That’s for the KDE, but that’s something I don’t want to put you through at this stage.

If the above doesn’t work, let’s dive in a bit deeper. First, turn off the background music to give your ears a break!

Then…

Open up a terminal. We’ll need to check if there’s a specific configuration file that we can… mutilate (non-destructively, as we’ll back the original file up) in order to redirect some audio channels.

In the terminal, let’s see if a specific directory and file are there:

cd /usr/share/pulseaudio/alsa-mixer/paths/

If you don’t receive an error, then this means that the configuration file is there. For the record, Pulse Audio essentially sits on top of ALSA, so those two are connected.

Next, execute the following command:

ls -l

And check to see if you find a file called analog-output-speaker.conf.
If the answer is yes, then let’s back it up first - by creating a copy:

sudo cp analog-output-speaker.conf analog-output-speaker.backup

Now, we’ll need to jump in and edit that file:

sudo xed analog-output-speaker.conf

Input your password and prepare to navigate down to look for the section that reads:

[Element Headphone]
switch = off
volume = off

It should be around line number 100 or so. Change it to read:

[Element Headphone]
switch = off
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

Then, look further into the file for the section that reads:

[Element Speaker]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

Change that section so that it reads:

[Element Speaker]
required-any = any
switch = mute
volume = off

Save and exit.

Now, reboot your system. Once you log back in, go to your audio settings and raise the output volume.

Play some audio and see if that has helped.

If the issue still persists, please take a screenshot of the sound settings panel, so that I can see if there’s anything else that might be interfering. You can upload the photo by simply dragging and dropping it in the response window. You can take a screenshot with the Print Screen key on the top right of your keyboard. Usually, that key uses an abbreviation, like PRTSCR or similar.

Please let me know how it goes!

grimacing:I followed the instructions you gave until I hit a wall. Internal audio is activated. Here’s where I had to stop

In the terminal, let’s see if a specific directory and file are there:

cd /usr/share/pulseaudio/alsa-mixer/paths/

If you don’t receive an error, then this means that the configuration file is there. For the record, Pulse Audio essentially sits on top of ALSA, so those two are connected.

Next, execute the following command:

ls -l
**This is the result:**
susan@susan-HP-ENVY-Notebook:~$ ls -l
total 32
drwxr-xr-x 2 susan susan 4096 Jul 22 20:11 Desktop
drwxr-xr-x 2 susan susan 4096 Jul 21 10:12 Documents
drwxr-xr-x 2 susan susan 4096 Jul 20 19:22 Downloads
drwxr-xr-x 2 susan susan 4096 Jul 20 19:22 Music
drwxr-xr-x 2 susan susan 4096 Jul 20 20:56 Pictures
drwxr-xr-x 2 susan susan 4096 Jul 20 19:22 Public
drwxr-xr-x 2 susan susan 4096 Jul 20 19:22 Templates
drwxr-xr-x 2 susan susan 4096 Jul 20 19:22 Videos

And check to see if you find a file called analog-output-speaker.conf

Did not find. :frowning:

Thank you for your help. I’m thinking you must be a night owl!
This is an extra laptop, and I’m trying to learn linux, so if all goes wrong I’ll just use the bootable usb and re-install the OS. Correct? Of course I’d be back at square one trying to figure out the sound issue… My family has been supportive of me trying out Linux, but since this issue has been plaguing me they’ve all been saying I need to just allow Microsoft to be my OS. (I don’t give up that easily.) I’ve got MS machines and a Mac in my home. I’m retired, but I’ve always tried to stay abreast of different technologies. I’m staying on this. :slight_smile:

1 Like

Hi there! Don’t waste anymore time on my sound issue. I got help from a moderator on the Linux Mint forum and she solved the problem. If you’re interested, or find someone else with the problem, I’ll post the solution below. Linux world is all good now. :grinning:

To access the pin and see its settings, one needs to install alsa-tools-gui (which has hdajackretask in it).

CODE: SELECT ALL

sudo apt-get install alsa-tools-gui

Then run hdajackretask.

CODE: SELECT ALL

hdajackretask
  • A window pops up. On the upper right side click the box to “Show unconnected pins”.
  • Scroll down on the right side until you see Pin ID:0x17. Let us know if you do not see it. (I do not have it on my laptop.)
  • If you have it, select the box to Override and select “Internal Speaker (LFE)” from the drop-down.
  • Click the “Install boot override” button in the lower right.
1 Like

Hey @susanesmith!
This is great! It would appear that indeed the issue was on the ALSA side. Thank you for letting me know!

And my apologies for not reaching out sooner - as I just settled down from the Workshop to begin the edit for the LMS.

Interesting that Jack is involved in this. Not Jack the name :laughing:, but the protocol - which is generally used for low latency music production and I’ve been using it on Ubuntu Studio. Jack can be very picky and I can’t wait until this whole mess is sorted out with the new PipeWire protocols that are arriving. They are currently up and running on the Arch distros and they are really great!

Also for the file not found above, it’s because you needed to run the cd command first. The directory displayed is from your home folder. :wink:

Eek, should I do that now?

Once I get this all squared away, I can start installing my printer. Yay! Linux is awesome!

Since you resolved the sound issue (the ALSA not directing its output correctly), you don’t need to do anything. The above settings were about a similar internal “re-wiring” - but you got that through GUI (Graphics User Interface). So, you’re good!

I believe it’s time to tackle your printer! For most, there are - thankfully - official Linux drivers. :slight_smile:

1 Like