Securing new vps caused a problem

I was setting up ssh keys on my new vps server and everything seemed to be going great. I was able to log in without using the password so I followed the directions to disable the root and password and apparently that worked too because I couldn’t log in as root anymore but I also can’t log in at all. Is there any way I can get logged in to the vps again, and what do I need to do to disable the root password without locking me out of the vps server? I was following the directions at the end of lesson 015. and I guess I did something wrong.
Thanks, Rich

I’ve got this problem too. I think the problem is the system is asking for a password to access the key. But I can’t figure out how to change that. So I am waiting for replies to this thread!!!

With regards to accessing the server…I just deleted my first linode (I’ve tried this twice with same error).

Hi Emily65, I had to enter a password to access the ssh key in order to put it on the vps and that went good I was able to log in without the password several times. My problem started when I disabled the root and password so the vps couldn’t be accessed with the password and the ssh key had to be used.

Same here. After I disabled root and password that is when I couldn’t get in. I’m sure it’s a ‘1’ that should be a ‘0’ or something like that.

Yes, it sounds like we have the same problem. I thought about deleting the linode and starting again (it would be good practice), but I am hoping that someone can help solve the problem otherwise I will probably make the same mistake and be back here again.

I saw a post by Will Welker that made SO MUCH SENSE, but its been awhile since I was wrestling with my VPS (for my VPN). He said when he sets up a VPS he always makes sure he has 3 different computers set up to access it via SSH keys. That way if one computer gets hosed and has to have ISO reinstalled (or you’re new and decided to try a new distro, not thinking about your secure keys being wiped out in the process), you can go to one of the other machines and still access your VPS. I know this doesn’t solve the “locked out” problem, but for the FUTURE we may not face it again!! I too have a currently locked-out-VPS, and I am loathe to just reinstall the ISO because it has CentOS on it (from a Vasileios multi-hour troubleshooting session) and I really want to keep it with that OS and ultimately learn how to use it! I’ll be watching for a “locked out” solution here, if there is one. I am guessing there may be no such solution, other than starting from scratch with a new ISO install on the VPS. (PS When I was wrestling with VPN installs I probably reinstalled the ISO for Ubuntu on my VPS 10 times!!)