Secure Boot option in Linux Mint

When I first got into this whole Linux-of-awesome stuff I put it on a MacbookPro and a Dell Inspiron. As I was installing Mint on the Dell I checked “yes” for turning on the Secure Boot option. I didn’t know what it was, but “secure” is a great word–it’s why we’re all doing this after all, heehee!

Then when I installed Mint on my Macbook the process was a bit different so I don’t remember if there was an option to choose Secure Boot or not. Now my Macbook never asks for the Secure Boot password when installing updates, but the Dell (understandably) does.

All that to say, my question is, do you all use Secure Boot? Is it another good layer of security? Or is it something else that’s for the really smart geeks?

1 Like

Hey @hannahgirl!
Secure Boot, despite what its words say, is a big no-no for all Linux users. What it does is it basically locks the boot sector and requires a decryption file to allow any kernel to load. Ubuntu, Fedora, and Mint support it, but if you are to make any module installation, chances are your system will get messed up.

The Secure Boot is a Microsoft invention to try and protect itself from a set of viruses that land at the very first block of the drive, known as rootkits. Linux doesn’t have virus or rootkit issues, so it’s not needed at all.

By the way, the secure is just “secure” a lot of Linux coders were able to crack it in minutes. It only offers trouble, not protection. That’s my personal experience (which has caused a lot of trouble for many other uses).

6 Likes

@vasileios ohhh wow! :grimacing: That is so interesting and so helpful. When I read your post I immediately researched how to turn it off and did so within minutes. :sweat_smile: Thank you so much! For some of us, this whole thing of being free using Linux wouldn’t really be possible without you, JP, and the rest of the admins–I certainly would have gotten confused or even nervous by now, haha :pray:

4 Likes

Hey @hannahgirl!
This is why we are here! To try and help as many people as we can so that this bad status quo does not reach the point where it fully controls our lives. :slight_smile:

Just wondering how do you turn it off on a Dell Inspiron??

Perhaps this guy’s video can help. :slight_smile:

1 Like

@Docoshea That video @vasileios posted is basically what I did on my Dell Inspiron. It looks a little different (as in the design looks a little fancier), but it’s still the same words and steps–in case that’s nice to know. :smiley: :+1:

1 Like

Unfortunately my laptop doesn’t have those options under Boot; the whole setup is a Dell “Phoenix SecureCore Tiano Setup” and an option to disable secure boot is nowhere to be found ; I’ve searched YouTube but can’t find anything

Hmm, I found it by restarting, pressing F12, then clicking on Bios Set Up, then Secure Boot, and toggling it off. I have no idea if that will work for you or not, but maybe you could try that or try looking in every tab after the F12 step to see if it’s in there somewhere?

Can’t find anything resembling secure boot anywhere; I’ve tried and tried to do a side by side install about 15 times; Ubunto always fails at “executing ‘grub-install/dev/sda’ failed. I’ve searched and tried YouTube solutions and all have failed. I’m super bummed out as I really want to free myself from big tech and thought this group would help me but I’m ready to cancel my subscription:(

1 Like

That was quick. One thing that is needed, when breaking free from Big Tech, is patience and willingness to learn. Yes, there are some systems that are more troublesome than others.

First, Ubuntu would normally install - even with Secure Boot on. Does your BIOS have a Boot Write Protect mode? This could be the case for older systems, speaking of which, it would be helpful to know which model you have exactly.

1 Like

Well, I rarely give up! After giving this whole situation much thought I got to thinking the problem has got to be the partitions so I decided to wipe the side by side setup and install just Unbunto……it completed install, restarted and now I get “ operation system not found”!!! Omg hopes dashed…. I’ve been at this for 3 weeks!!!

1 Like

Vas…… I sent you the laptop specks before thanksgiving by message.

1 Like

I just looked at my messages and I don’t see your username in it. At least not here in the forum.

Hold on… I had to look at your registration email and then find you on the LMS and go through our thread. You were having trouble because Ubuntu was not detecting a hard drive - which resulted in the assumption that the drive itself was damaged - and therefore not recognizable.

There were no specs in there, other than “Windows 7 laptop” as far as I can see.

Here is what you can do at this point. First, make sure you have Internet (if you cannot connect to WiFi, then via Ethernet cable, connected to your router).

Open up a terminal on the live version. You can do that by booting via your USB flash drive and selecting “Try Ubuntu.” Then, press the Windows key (bottom left on your keyboard) to open up the dashboard and search bar. Inside the search bar type in:

sudo apt update

Press enter and type in your password (it will not show, but that’s OK). When you finish typing, press Enter for it to update its databases. Then type:

sudo apt install boot-repair

Press Enter and then select Y if it asks you.

Once finished, hit the Windows key again and type in the search bar:

Boot Repair

Click on it and when it opens, select the first option - to run a repair for the most common problems.

If it fails to fix it, at least it will tell you what is going on. Please take a photo of it and upload it here. You can do so by simply dragging and dropping the image file in your response box. :slight_smile:

This is a different laptop from the first; Inspiron N7110. Unfortunately Windows is now gone so the windows function key opens search at the top of the Ubuntu screen, no results come up when command is typed in. I’m so not a computer nerd, I tried reinstalling, the screen just goes blank after install, I have to hard boot and then get no operating system found. I have the try version open but am at a loss of what else to do.

When you open up the search bar and type “Terminal” the following icon should appear:

Then you can select it and type the following commands, as I included above (I am attaching them below this text):

Once the above completes, hit your Windows key again for the search bar, and type in Boot Repair the following icon should appear:

Select the Boot Repair and once it loads, select the first option as shown below:

image

Please let me know (and take some photos, so that I get an idea of what is going on) how that goes.

2 Likes

I get an error……

Oh. You are going for the 21.10 Ubuntu. That’s a short-term release, which can be quite unstable. That’s the reason you’re getting this error. Do you happen to have the 20.04 Ubuntu?

1 Like

Well…. After you telling me this Vasileios, I downloaded Mint…… it installed perfectly!!! YAY!!!


Onward now!!! Thank you!

Perfect! I’m so glad to hear it!
You’re most welcome and now you can finally enjoy your digital freedom! :smiley:

1 Like