Rhythmbox error installing additional software

Hey folks! :wave:

Has anyone had this issue before? Rhythmbox won’t play audio files from Audible.com, but it seems to be offering a solution in the form of “Install Additional Software” in the bottom right corner (see screenshot below). Which seems great, except no matter how many times I click the button to install said additional software, nothing happens. The button looks like it’s clicking, but doesn’t do anything.

I tried restarting and it still doesn’t work. I also searched “Rhythmbox” in the Software Manager (on Linux Mint) and found some plugins that I thought might helped. I tried 3 of them, but nothing changed–the Audible.com files still won’t play. So, I wondered if anyone has any ideas or has had this issue too? Here’s a screenshot of what it looks like:

Thank you SO much :sweat_smile:

Helo @hannahgirl!
It would appear that this may be a DRM (Digital Rights Management) issue.
Since Rhythmbox refuses to do the installation (it happens from time to time), you can do so manually by opening up a terminal and typing the following:

sudo apt install ubuntu-restricted-extras

These originate from the multiverse repository. If the above command goes through, then you’re good! If you get an error where it says it can’t find them, then simply type in the terminal:

sudo add-apt-repository multiverse

And then re-type the first command above.

I hope this helps! :slight_smile:

1 Like

Thank you for your help! :raised_hands: The first command didn’t say I can’t find them, which is good, but it got stuck on 35% progress, which is confusing. I “deleted the locks” to get it to stop, then tried your steps again from the beginning. It got stuck on the same progress but at 6%, so I tried one more time and it got stuck on 6% progress again. Any ideas? Here’s a screenshot of the last time:

Hello again @hannahgirl!
I apologize for my delay. I’ve been armwrestling VPS and domain variables to bypass network safety measures lately!
When you see windows like that pop up, use your trusted TAB key (above Caps Lock) until the or other option is highlighted. Then, hit the Enter key and it will proceed. :slight_smile:

1 Like

Hi @vasileios! No worries at all, that sounds like an intense project, whew. :sweat_smile: For us here though, we’re just incredibly grateful to have your help whenever you have time, so take care :pray:


I make sure I am around the forum daily, 7 days a week! That’s because I believe in every single one of you, so I try hard to make time! :slight_smile:


Wow @vasileios thank you from all of us! :relaxed::pray: