ProtonVPN CPU usage

When starting ProtonVPN, my CPU temperature soars, almost to the critical level.

Then, periodically during the time I’m working, the CPU temp again spikes. I haven’t yet figured out the pattern regarding when that occurs.

The CPU temp never spikes like that when P.VPN is not running.


  • What might P.VPN be doing that’s so periodically CPU intensive?
  • Is that behavior acceptable?? (As if I have any choice in the matter. :smirk: )


I have not personally noticed this, with Debian 11 and Xfce DE on multiple hardware configurations(all have 8 GB Ram and vary from 1.8GHz to 3.2GHz[DE with 16GB]).
The only thing I noticed is network usage when it’s loading up, obviously logging into account, pulling server information etc.

Assuming this is only with the GUI version as well or both CLI and GUI?
If it’s just GUI it could be low memory.

Lets start with some system specifics and distro and see if we can find something.

Hi D,


Using both CLI and GUI.
I load GUI first, then use CLI to connect to server (in order to easily see which P.VPN server shows the least percentage of usage).

Using this Applet in the System Panel to monitor the temp:

temp app

You’ve obviously got plenty of memory.
CPU is in the mid range, could be part of it but I wouldn’t lean to hard that way being the cause as it doesn’t seem to hit much above 50% CPU when Iload it on a 1.8GHz an 8GB ram.

Try running just the CLI version instead of loading both.

Also, guessing you got the proton packages directly from their repos, checked for an update lately? I think there was one about a week ago.

Yeah, I wondered if using both CLI and GUI versions would add to the heat load, so I just loaded from only the CLI. Not so much heat this time. I’ll continue to experiment with one/both to look for a pattern.

The up-side of using the GUI is that the app minimizes to the panel, so I know for sure that it’s active. No need to open a terminal screen, then run protonvpn-cli s to find out.

RE version, yes, installed only from repos, and it’s current.

Thanks for your thoughts.

So I looked at the GUI(between 80-90%) versus CLI(>1%) an the GUI is certainly showing significantly more CPU usage during its load up but I did not notice any real temp fluctuation. I checked on 2 different systems(1 laptop 3GHz/8GB and 1 desktop(3.2GHz/16GB).

Now with my previous Ubuntu 20 on the desktop when I used the CLI it would change the network indicator to a version with the lock as well as Xfce on this Debian stable.

Not sure what you are using.

As for my terminal I like Tilda or Guake drop down terminals, bind to a key, say f10 and walah, lighten the opacity so you can read what’s behind it, you can even make it stay on top when it looses focus so you can scroll the web page at the bottom of screen and behind the terminal like to follow a step by step.

1 Like

OHHH! The network icon in the System Panel! Nice catch!

The only piece of data missing from the network indicator is the VPN server’s percentage of load. Not a big loss in order to avoid the GUI’s CPU churn.

I didn’t start the GUI this morning and have noticed a distinct difference/drop in CPU temp. Will only be using the CLI from here on.

Well done, D! Thanks.

1 Like

Good news.

Since only loading P.VPN via CLI (completely avoiding the GUI), my system has remained blissfully cool. Absolutely zero high-heat occurrences.

Such a simple fix. Whoda thought!

P.S. As an added bonus, I’m able to disconnect from the VPN prior to powering off the computer, by left-clicking on the Panel’s network icon, then de-selecting the VPN-connection slider. Nice.


Update 2:

Add’l added bonus: Thru that same Panel-Network icon, I can also REconnect to the same VPN server I had previously used.

What a huuuge time saver at startup. There’s no need to even re-invoke the CLI interface via the Terminal. Just move a slider in the Network panel.


The only trade-off is not knowing the VPN server’s percentage of load when reconnecting…

1 Like

Yeah. Server loaf info would require interaction with their cli or gui. Downside.

So then the questions become, how can I both

  1. quickly connect to the VPN after powering on the computer, and
  2. choose the VPN server with the lightest load?

Here’s what I’ve decided to do (sometimes) so far: connect to P.VPN in two steps.

  1. connect to my most recently used server via the Panel Network icon, then
  2. connect to the general, P.VPN system via Terminal command protonvpn-cli c, etc.


  1. connecting to P.VPN is instantaneous (step 1),
  2. when I prefer to skip taking the extra time to connect via Terminal, it’s ok. My system is protected.
  3. when I prefer to allow the extra time to be sure I’m connected to a lightly-loaded server, I can (step 2).

So far, I don’t see any…

In any case, I’ve decided that it isn’t worth using the GUI.

Yes, annoying I know.

Without launching the terminal interface and selecting server you have no clue what their load is etc.

if you run the protonvpn-cli --help it shows few options:

Proton VPN CLI v3.13.0

For bugs and errors, please use the form Proton VPN - Support Form | Proton VPN
or send a report to

usage: protonvpn-cli [–version | --help]

login Login with Proton VPN credentials.
logout Disconnect, remove Proton VPN connection and logout.
c, connect Connect to Proton VPN.
d, disconnect Disconnect from Proton VPN.
s, status Show connection status.
r, reconnect Reconnect to previously connected server.
config Configure user settings.
ks, killswitch Configure Kill Switch settings.
ns, netshield Configure NetShield settings.

optional arguments:
-h, --help Display help message.
-v, --version Display versions.
–get-logs Get Proton VPN logs.

protonvpn-cli login
protonvpn-cli login --help
protonvpn-cli logout
protonvpn-cli (c | connect)
protonvpn-cli (c | connect) --help
protonvpn-cli (d | disconnect)
protonvpn-cli (s | status)
protonvpn-cli (r | reconnect)
protonvpn-cli config
protonvpn-cli config --help
protonvpn-cli (-h | --help)
protonvpn-cli (-v | --version)
protonvpn-cli --get-logs

Obviously “c” takes you through the connect dialog, Maybe “reconnect” would be a suitable on after a boot since you stay logged in until you actually issue the logout command.

Yeah, that also works to reconnect.

My internet connection is pretty slow, so the quickest I’ve seen so far is to

  1. click on the Panel-Network icon, then
  2. click/activate the “VPN Connections” slider.

Recap from prior post:

1 Like