Preference Panel is not opening in Linux Mint Cinnamon

Preference panel is not opening. I click on it and nothing happens. When I go into the menu I cannot access anything in it. This is happening on my laptop and desktop.

Hi @TemLyl98! Welcome!

When was the last time you updated your systems? I would recommend doing so if it has been a while.

sudo apt update && sudo apt upgrade -y

Additionally, have you installed anything else recently?

I update as soon as I see the notification. No, I haven’t installed anything else.

Just to be clear, you are speaking of your system preferences? And not preferences for a program or app, correct?

Correct, system preferences.

Try opening a terminal and entering:


See if that brings it up. If it doesn’t, copy paste the result here so I can see it.

-PC:~$ cinnamon-settings
No module named ‘PIL’

Okay, I think i may have narrowed it down. I found this post on reddit that is about your same issue.

They suggest installing

apt install python3-pil


apt install python-pil

After doing that, I would recommend restarting your machines.

I did both and it still did not work.

Shared your issue with the other admins, and Jeff is saying that you should try installing MATE. Follow this guide: How to install MATE in Linux Mint Cinnamon Edition

Or type this command in the terminal:

apt-get update && apt-get install mint-meta-mate

I first tried using the terminal with no results. Then I followed the guide which worked! Thank you so much!!!

1 Like

Oh okay! Awesome! So glad that worked for you!

1 Like