Pixel 4XL more questions on a slow start

I have had my factory unlocked, phone for almost a month and a half…been doing a lot of research on the process. The first thing I notice is that I the 4XL has fewer “how to’s” and what I do find is dated to the Android 10 time frame. My copy has been refurbished from 64Gb (as per the “Imel” site) to 128Gb and Android 12 has been installed… 1st question: does “12” make for extra steps?.. First let me say, I am very out dated when it comes to “smart fones”… I do still have my cell phone (Motorola DynaTAC) down in the file cabinet…been there for 25+ years… old enough to purchase adult beverages it is…anyway after playing with the new pixel I have managed to gain “developer rights” and have a password instead of facial recognition… decided to try Graphene OS and have been reading CLI install guide | Install | GrapheneOS they recommend Ubuntu 20.04 LTS as one of the Officially supported operating systems for the CLI install method… so I have spent the last couple weeks doing that … another learning curve cycle and after using Mint for the last year I find that Ubuntu throws me a lot of curves… I’m now in the process of setting up fast boot and ask if some one could this looks right?

I’m not sure if the terminal matches what I got on the desktop… also I find that terminal gives me almost as mush trouble as little tiny touchscreens… so many mistakes…

Okay, so a little bad/good news depending on how you look at it…Linux Mint (20.2 cinnamon) IS based in Ubuntu 20.04, so you did’t have to change anything there.

Secondly - this was one of the guide steps for Graphene install that threw me bigtime, as they tell you to install fastboot using PLATFORM TOOLS - then mention doing a version check on FASTBOOT - yet give the requirement of the VERSION OF PLATFORM TOOLS (NOT fastboot) so for about an hour I was trying to figure out why I was NOT getting a later version when I ran the version check for FASTBOOT and it wasn’t 31.0.3 or later…so to me that is a misprint and should be fixed.

So to be clear…it is PLATFORM TOOLS that needs to be at version 31.0.3 or later…and your version of fastboot should be fine

Thank you for the reply, as I have been at this off and on for while, I did down load and unzip to desk top This:
Screenshot from 2022-03-19 17-10-54
And inside it has all this:

So I am thinking that after all the down time from setting up a duel boot mint/ubuntu where I lost all my links… that I have been chasing my tail…

And this was the zip file where it came from:
Screenshot from 2022-03-19 17-22-00

so r33,0,0 should be Good to Go?

yup, should be good as long as you have installed 33.0.0 fully

I do have to agree that the Guide steps are confusing… I went ahead and down loaded the the factory images and put them in a new folder in the down loads file, hoping that having them on hand is better than downloading on the run… I have not yet tried to connect the phone to the computer yet because of this line, “Connect the phone to the computer. On Linux, you’ll need to do this again if you didn’t have the udev rules set up when you connected it.” Should I “boot your phone into the bootloader interface” first then conect the phone… Or connect the phone first, then “boot your phone into the bootloader interface”… which comes first the chicken or the egg… And “udev rules set up” is maybe a thing for tomorrow …
Once Again Thank You

Oh I forgot the graphics…
Screenshot from 2022-03-19 19-48-34

Completely agree, that the UDEV comment also sent me in another UN-NEEDED rabbithole as it says - you MAY need to update Udev without saying HOW or to find out IF you actually DO!! It was very frustrating to me - I again was working with Mint 20.2 and ignored that part.

I will attach a good step by step vid in the morning that I followed with my pix3 even tho the vid was for 3A - it worked and it should work but Vasileios will know if he pops in

Ok Ok I got to ask, Muh Wife is calling gotta go… but did you get it done, did you complete the mission?

yes completed and very happy

1 Like

Thanks Again!! I see Light coming ant the end of the tunnel !!!

1 Like

Here is the guy I followed, he is nice & slow, & pretty precise…it was the best i found anyway.

Hope this helps

1 Like

Hay QP…
Glorious Update… I Did It!!!
I got sidetracked and the phone went back in the box with all my notes til yesterday…
got some “Me Time” and started at it again. At about 10 pm my Wife asked if we were gonna have supper…
anyway, I had watched the video so many times yesterday, I dreamed about it last nite…
So after bout 3 hrs and a lotto coffee…Success!!!


I’ve started researching the after install set up and found this vidio

GrapheneOS - Full Post Install Setup Guide - Maximize Security and Privacy On Your Android Phone - YouTube
But this will be for later…
I do have a question though, one the Graphene download page,
Screenshot from 2022-04-06 11-28-32
what is the coral-ota_update? does this need to be installed also?
any way I downloaded it also for a wait and see…
Thank you again for your help!
Iberius :disguised_face:

1 Like

Well I found my answer… Usage guide | GrapheneOS “If all else fails… Read the Instructions”

Now I have to get off this slide and get back to working on setting the phone up…

1 Like