OpenVPN times out trying to connect first time with Linode

Dear Fellow Linux Enthusiasts,

Has anyone had the issue of getting a client timeout trying to connect to a newly installed OpenVPN on a linode Ubuntu Server?

I have followed Vasileios’s detailed video and step by step instructions and all has gone well until trying to connect for the first time. Getting a timeout from two separate client computers.

My first guess is that a port is being being blocked somewhere, but I have no firewall established yet. Netstat shows port 443 and 1194 open.

I already have Cyberpanel running my new email server on this linode and all is working fine with that from last week (decided to do the harder email task first as VPN looked easier :wink:

I’m scratching my head on this and cant seem to find any help via the web.

Any help would be certainly appreciated.

==== On a hunch, I tried using the OpenVPN key in a linux distro that uses Gnome and the VPN works!

So, the question now is why does this .ovpn file not work for Manjaro KDE or MX-Linux KDE but yes on POP OS?

Does it make sense that the distro is relevant for this?


Hey @mva AKA Michael and welcome to the forums!

If you installed CyberPanel, then know that it shuts down a great number of ports, other than the ones it’s using. So, there’s a good chance that it’s blocking the one you set up as the VPN.

If you followed the video for the OpenVPN, you can open up the firewalld port by executing:

sudo firewall-cmd --permanent --add-port=XXXX/tcp
sudo firewall-cmd --permanent --add-port=XXXX/udp

Where the XXXX stands for the default (or your chosen) port you installed OpenVPN with.,

Please let me know if that helps. :slight_smile:


Thank you for the quick response and for the port suggestion tip, but before I do that let me make sure of something before I try this on my server.

It is my belief that If I can connect one client computer to the VPN linode server successfully, that would mean that the VPN linode server’s ports are not being blocked and that OpenVPN is set up correctly for all further clients. (with all physical clients having separately generated valid .ovpn files)

I’m assuming this statement is true, and if any further client can’t connect, it would then be a problem with that client only. Do I have this correct?

If it is correct then I have my test desktop dual partitioned with MX-Linux KDE and Pop OS Gnome, where the Pop Gnome partition connects fine to my VPN and the MX-Linux KDE times out using the same .ovpn file import. (I have both firewalls turned off as well as on the server, so I think its not a port issue at the moment)

I have also tested a few things on my laptop where MX-Linux Xfce works fine but Manjaro KDE does not work and times out as well. So, my problem seems to be with the KDE desktop only and am personally fine with not using it but I want to get to the bottom of this for others in the group. It can’t just be something wrong with KDE

I’m curious to know your thoughts are about my thinking but in the meantime, let me try installing multiple desktops in the same distro and see if that change anything from the iso desktop default.

P.S. I’m not going to brag, but my grandmother’s Kourambiethes recipe may just be the best one on the West Coast :wink:


Sorry, this one got my attention and it has been a long while since I had some! LOL - How about Melomakarona? I hope you don’t mind sharing the recipe on a private message. :wink:

Per your previous statement, yes, an OVPN file is for a single client and it locks onto that client after first connection. I haven’t tried the KDE option, since all of my current systems run mainly on Gnome. I have a couple more I could give KDE a shot - if only I had a bit more time.

You’re doing great work and thank you!


I would be more than happy to share it with you, let me know how I can get it to you as I’m sure we don’t want to clutter this board with non technical stuff. I have not yet heard of Melomakarona but I just love anything with Honey! Going to give them a try this weekend! Thank you.

I have performed a few tests in my spare time, and have found out that something is amiss with the KDE desktop when it is loaded as the default with the distro. So if I install the Manjaro iso with KDE as the desktop, my OpenVPN will not work and times out. Same with MX-Linux But if I install Manjaro with Gnome or Xfce, the OpenVPN will work as it should.

My debugging skills kicked in, so I thought what if I load Ubuntu (Gnome default), then install KDE manually and see what that does. Funny thing was when I first log into KDE and set up the OpenVPN connection, it times out and fails too. But if I log into Gnome first and set it up there the connection works perfectly. Then when I log out then back in using KDE, the connection WORKS!

Not sure why the KDE OpenVPN only works when it has been set up using a different desktop first but it may just be a bug of some kind. I will see if I can contact the KDE team with my findings.

I have found that I am preferring the minimalist gnome desktop these days as I move further away from the windows mindset. I guess I’m becoming more “Linuxified” each day :wink:

1 Like

Thank you so much for your input @mva!
I have noticed that with KDE lately. I also ran it via a VM and noticed that it couldn’t recognize the connected network via its graphic interface. However, the network itself was working fine on terminal. Therefore you could engage OpenVPN from there.

Today I found a valid workaround in case anyone still wants to use KDE with OpenVPN. Apparently there is a bug upon importing .ovpn files directly using the KDE connection manager. If you manually import it using the command line with the following command it will work fine:

sudo nmcli connection import type openvpn file MyVPNname.ovpn

1 Like

Awesome! Thank you so much for this workaround @mva!

Wanted to let you know that I was pulling my hair out. I had imported my .ovpn file in the past. I have a new install and it would not import. I used this method, and it worked wonderfully.

Thank you