No wifi - 32-bit Xfce 19.3

First of all - background - I had TWO old laptops. One was struggling to run 32-bit Windows Vista, and I have put 32-bit Linux Mint Xfce 19.3 on it. The other was struggling to run Windows 10 (up-to-date; fully patched) and I’ve put 64-bit Linux Mint Cinnamon 20.2 on it. The newer one is fine. It’s the older one (32-bit) that I’m having issues with…

So, the one running 32-bit Linux Mint Xfce 19.3 - I cannot get the wireless connection working. Before I did this, the laptop had windows Vista and the wireless adapter was working, so known good. I have plugged in an ethernet cable and used the Update Manager to install all available updates. Note I initially had this issue on the newer laptop also, but on THAT one, it has an actual button on the keyboard that will toggle the wifi on and off and it was off…so that was the fix. The old laptop does not have a button on the keyboard. I can’t figure out what to do next.

Hello @JJHatesComputers!
I guess the old laptop saw your username and decided to punish you! :laughing:

Anyhow, we’ll figure out what is going on with it. Most likely, there’s a kernel module missing. So, please open up a terminal and type in the following command:


Once you execute it, please copy-paste or take a picture of its output and post it here. This way I’ll know the hardware model of your WiFi and look up as to what it needs to go fully functional. :slight_smile:

I can’t connect, or find, wifi on my new ubuntu install on my 2010 macbook. Seems to be working fine, but need wifi, and have looked all over it.

Hello @mcclainra and welcome to the forums!
Can you open up a Terminal and send me the output of the following command?


In order to find the terminal, tap your Command key and type “Terminal” in the search bar. The above command will analyze the models of your hardware so that I know which exact model of BroadCom’s WiFi chip your MacBook has. :slight_smile:

So sorry for the delay. Things have been crazy. This laptop is the oldest one I had sitting around. It is more than 10 years old, but I can tell you it already seems to run better than when it still had Vista on it.

Just noticed should have replied here rather than via email. I tried several times earlier, and still can’t get past trying to put in password immediately after 1 command you told me to enter, sudo apt update. Little block where typing supposed to start does nothing, and can’t enter pw. I even changed pw, and still doens’t work. Here’s last screen shot which I also emailed to you:

1 Like

Hey @JJHatesComputers!
You happen to have a BroadCom (they’re quite infamous) model that’s slips through the cracks of the official support package for Mac WiFi modules!

I’ll shoot you all the commands, so that you’re hopefully fully covered. However, first connect your system to a router via an Ethernet cable. This process will need Internet access to work.

sudo apt update && sudo apt upgrade -y
sudo apt install dkms
sudo apt install firmware-b43-installer broadcom-sta-dkms

Then reboot and see if that helps. Hopefully, we won’t be needing any additional steps.

1 Like

Hey there, @mcclainra!
All WiFi options for Macs will need Internet access, which means you’ll need to temporarily hook your system to your router via an Ethernet Cable.
Then, I’ll need you to send me the output of the following command:


So that I know which model your WiFi chip is. Though I am beginning to suspect that the commands I gave at the post above could help you as well.

Here’s another try w/ethernet connected to router. I went on and tried all 3 commands, but terminal still not accepting pw.

Can you open up your System Settings and take a picture of the Network Tab? I’ll need to see if it’s indeed wired and connected. I had an issue with a friend who suffered the same, and it turned out that his Ethernet cable was busted.

That was the problem. Even after ethernet plugged in, was not connected, so got different ethernet cable, restarted computer, and finally wired. I have now placed all of the commands in the terminal successfully. What next? Where do I find where the wireless shows?

1 Like

Do I restart again now? At the end of the 3 commands.

1 Like

Well, I now have wife. The 1st restart got the wired to show up, so then did again, and wireless showed up, so now hooked up to the network here. Now that I’ve done it, it all makes sense, and obviously could not download the packets if not online…

1 Like

Hey @mcclainra!
I’m so glad everything worked out! I apologize for the delayed response. Family obligations took me away for several hours. It’s funny how some faulty hardware (as simple as a wire) has us questioning everything. :slight_smile:

Hi! Sorry. My machine is not a MAC. I have a very old Acer Aspire. The other commenter in this thread has the MAC. Are the same 3 commands still correct for me to use, though? Thank you! :grin:

Hey @JJHatesComputers!
Yes, your system still uses the same BroadCom WiFi module, so the commands are essentially the same. :slight_smile:

I know it’s been a minute or two…
but I got back to this today and my ancient laptop has wifi now!!

:laughing: Your definition makes me not feel so bad when I skip a day or two (due to LMS production) and come back to a storm! :laughing: Thank you for this!

Also, congratulations! Well done!