No sound after Zorin 16 update

The internal speakers and mic were working on my Acer Chromebook 14 from the initial Zorin 16 install until the updates last night via the Software Update.

When I test the internal speakers in the setting, I can see the volume indicator below changing but no sound at all.

Is there a chance that the sound is somehow stuck at mute (though I tried changing it from the settings)?

Or is there a way to revert to the last update or if there a way to reinstall Zorin (I kept the installation usb) without it effecting all the other things I did after the initial installation?

Hey @Ai,
Sometimes, when there are updates or new devices connected, the audio settings shift. Do a quick check on your Audio Settings and look which device it’s using as its output & cycle around as you play some audio in the background.

I tried that before… the entire computer is working strangely… YouTube video won’t even play… it just keep telling me to reboot.

I am going to try to see if I can revert to the working kernel version… Thank you for answering! :slight_smile:

Okay, I found out I can press Left Shift key at boot time and get into the Advance option menu to run from the last version of kernel (and it’s working like before)

How do I remove the newer kernel so it won’t be the default at boot up?

I found the way to remove newer kernel here

And to hold the working kernel from being updated by
sudo apt-mark hold linux-image-generic linux-headers-generic

Phew, I can breath again!

There’s a much easier option to control Kernels.

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install mainline

That’s the utility with the graphic user interface that allows you to install or uninstall every kernel that is available in the Ubuntu repositories (Zorin is Ubuntu-based).

1 Like

Cool, will do that on my laptop asap! Thank you!!!

1 Like