No New Volume Partition

I am attempting to create a dual boot on an old Dell Inspiron 1720 that is currently running Windows 10, in order to install Manjaro on the 2nd boot. It is a Legacy Bios. I was following a YT video on how to do this, but when I got into Disk Management, I found that I do not have a New Volume “D” partition. I only have System Reserved (500 MB), “C” (231.9 GB), and Health Recovery partition (510MB). The “D” drive is my CD Rom drive.

What should I do?



In order to perform a successful dual boot computer, you will need to first create a separate partition for the Linux OS to run on. Your comment states that you have the 3 typical windows partitions, one as the boot loader, one for your C drive and the last as a recovery. Let me pause here and make the following two suggestions:

  1. Have you performed a backup yet for any data that you don’t want to lose in case something goes wrong? You probably don’t require it as you state that its an old computer, but I never like to assume so make sure you backup if you haven’t already.

  2. Have you created a Manjaro install USB yet and tested that Manjaro works on this old computer? Booting up using the Manjaro installer will start a live session where you can verify things like making sure wifi and blue tooth will work before you install the distro. Some distros work better on older hardware than others.

So, if you are then ready to proceed we need to shrink your NTFS “C” disk to create a blank partition for your Linux.

Launch the Windows Disk Management program and right click on the “C” drive partition. A menu should come up and the option to “Shrink Volume…” should be available.

Clicking on that, should start a pop up notification to query for free space. In a few seconds a dialog will come up asking how much do you want to shrink your windows drive in MB. Each GB is 1000 MB, so you have 231 GB to start, so splitting the drive in half for each OS seems like a good choice. In the box labeled: Enter the amount of space to shrink in MB, enter 115000 and hit enter. This should free up 115 GBs for our Linux partition. (Remember you can always extend the volume back, to undo the shrink)

When the shrink finishes you should see a new unallocated partition next to your old C drive partition. This will be where the installer will place your new Linux OS.

If you want to double check to make sure the partition settings are set, do a reboot to windows and you should still see the unallocated partition in the Disk Management program. (Its nice also to know we didn’t break windows :wink:

Your PC in now ready to install Manjaro and will automatically detect this free space and give you the option to install it as a dual boot.

I hope this helps and let me know if you have any further questions.


1 Like

I don’t need to back anything up since this computer is just an old one that doesn’t have anything of value stored on it. I bought it for this purpose. I have not tried booting from the flash drive to see how Manjaro runs. I will do that before I begin the instructions you have outlined.


Ok, so I was able to boot up Manjaro from the USB and connect to the internet, but nothing else will run. I think the old USB ports are too slow to actually run it. If I wanted it to run the OS, I think would probably have to save it to a disc and try to run it from the disk drive. I had to do that on another computer that I put an OS on. However the OS should still install from the USB once I set up the partition, though, right?

Hey @Gr82blanda,
You can also try to boot Manjaro directly from USB, select Install (if you are able to reach that far) and select it to install alongside Windows 10.

Hey Vasileios,

I installed the OS from the USB but it is behaving in the same manner as it did when I ran it from the USB. It will load the OS, it connects to the internet, but nothing else works. It freezes and won’t open any applications or it partially opens and freezes.

The installation itself appeared to run as normal up until I got the very end when it said that it was finished and to restart. I couldn’t restart from the screen because it was frozen. I had to shut the computer and and back on again.

Since it’s acting the same as it did before I installed it, would this indicate that it may not have been the install, but perhaps there was something wrong with the ISO file? I downloaded the latest XFCE from the Manjaro site. Here is the YT video that I followed for the installation:

What are your thoughts? I assume I will have to delete this and start over, which I may need some assistance on.

Thanks very much!


I agree with @vasileios that you can try just installing Manjaro alongside Windows to see how it runs natively. The good news is that you already verified that you can connect to wifi so you have nothing to lose by installing it.

If you find that Manjaro runs too slow, there are other distros that probably will. I have had a lot of luck using MX-Linux, just as an example.


See my response to @vasileios about what happened when I installed it.

Hey @Gr82blanda,
Out of curiosity, how much RAM does your system have?
From my experience, app freezing appears in one of the two following situations:

  1. There is very little available memory (RAM) on the system, and the OS resorts to SWAP file. If the HD is slow, it results in long delayes which appear as freezes.
  2. There are bad blocks on the HD, which freeze the system as it tries to read a file that’s trapped in the bad sectors.

Since you experience those freezes via the live USB, I’m suspecting the first option is the one that kicks in.


The computer has 4 gigs of ram and it runs Windows 10 on the other boot with no problems. It’s not fast, but it runs fine. I just tried to run Manjaro from the USB on my newer computer that has 8 gigs of ram, on which I have Linux Mint, and it ran fine, so I would agree that your first option is the issue.

However, I’m confused as to why this system will not run on this old computer while the Windows 10 hog will? I purposely picked the XFCE version, not the light one but the regular one, assuming that it was still a fairly streamline system. I thought of all of the Linux systems could run on less than 4 gigs of ram that’s why you could run them on almost any old computer?


Hey @Gr82blanda!
4GB is more than enough for even the Gnome Desktop Environment to run on, which is the heaviest one. Therefore, I’m starting to lean that something must be happening with your HDD. Out of curiosity, can you unplug your internal drive and try to boot from the Live USB? I’m interested to see how your system will react. No need to install the OS. Just play around with the live version first and see how it behaves.

I disconnected the hard drive and ran Manjaro from the USB. It did the same thing as before…extremely slow as if frozen, tried to start Firefox browser but it wouldn’t load.

While on the Live USB, can you open up a terminal and execute the following commands?

sudo pacman -S inxi

Once it installs, can you take a screenshot of the output of:

inxi --full

It will give me a decent overview of your system to try and see what’s going on, hopefully. :slight_smile:

Houston we have a problem. I tried using the -Sy which also did not work. :pensive:

The reason for this is that your system doesn’t have network access (no WiFi) via Live USB. Do you happen to have an Ethernet cable to connect your system to the router?

Oops, sorry, the second time I ran the command, I forgot to connect to wifi. I ran the inxi --full , and I got this. Unfortunately, I cannot expand the terminal size without it freezing up so it’s in two photos.

Could something be wrong in the partitions?

Thank you for posting the screenshots, @Gr82blanda!

I looked up the model of your Hard Disk Drive and found it to be from the 2008 production line.

Do you have the Manjaro installed on that drive? If no, then you don’t need to be concerned about the partition table on Inxi. If yes, then - due to the age of the drive - I fear there may be bad blocks that sit right on the partition table or the filesystem’s file allocation table.

However, if you disconnected your drive completely (via cable) and you still have slow issues, that’s something entirely different. Let’s test it out:

If you happen to have another USB thumb drive, I’d suggest utilizing it to flash Zorin OS Lite, which you can download directly from the link below:

It’s the 64-bit XFCE version of the Core edition and it’s designed to run on systems as old as 15 years.

Once you flash the USB, disconnect your hard disk’s cable and boot from the Zorin live disk (select try) and check to see if it behaves the same way.

Although there is a space for another hard drive, there is only one installed. You asked me before to try unplugging the hard drive and running Manjaro from the USB, which I did. The same thing happened as when it ran from the hard drive. The OS would load and I could connect to the internet, but I couldn’t run applications like the the web browser or the office programs. The only thing that I could do was to open the terminal and run that inxi command. I also ran the USB from my newer computer and it worked fine there. I only have one available USB for ISO files at the moment. I will have to buy another one to try Zorin.

Since your Windows appears to be working correctly, chances were your old HDD has some faulty sectors where Linux accidentally lands on when it installs. The fact however, that you had the same issue when booting from USB, makes me think that there could be a hardware incompatibility from the thumb drive itself (or a deeper hardware issue, like RAM). The reason I suggested the USB is because it’s much cheaper to test and it never goes to waste.

I had a few issues with USB thumb drives. I’d flash a Linux OS on a couple of them (same brand) and my desktop computer would get stuck on a black screen. When I installed the same OS on a different USB, it worked on the desktop. Before I went forward to throw that USB thumb drive into the garbage, I attached it to a different laptop. Voila, it worked there.

So, this type of behavior from your system needs a step-by-step process of termination. The reason is that it appears to not be a software issue (such as drivers), but a hardware one.