No Internet - Highly bizzarre, help needed

Here is the story…

1.) On vacation last week at a hotel wifi (with laptop running linux mint) that worked fine on day one, came back into the hotel after being out and received DNS probe_possible error on Brave. Firefox didn’t load anything at all. The connection was completely dead even though it said connected. I tried hot spot from my phone, it connected fine but no browser worked or any deliberate traffic. Meanwhile, my Ipad continued to work fine on the hotel connection. This laptop shows this error still to this day on my home network where there has never been an issue before.

2.) Yesterday, after being home for 4-5 days and using home network completely fine on my Pop_OS main cpu, the same issue occurred. No internet at all with any browser despite it showing connected. I seem to be able to even ping other cpus on the network, all of which have no internet issues at all. Here’s the kicker, I rebooted the same cpu into windows and internet is 100% fine.

Given the circumstances, its hard not to rule out the ISP, router/network config, and blame anything other than something linux related. No significant changes/updates were made on any computer and both just stopped working seemingly at random on different networks in different parts of the country, while iOS_Windows continued to work fine in the same circumstances. A reinstall is highly undesirable but I can’t think of anything else at this point. It’s strange enough to be suspicious at this point. Much of what I’ve found on the DNS probe possible refers people to their firewall and dns numbers. I have no firewall active on these machines and have already tried openDNS numbers which changed nothing. I doubt its a DNS issue when the same DNS numbers work with Windows.

The result of “ping -c 3 google.com” is
name or service not known
Anyone have any ideas here?

Give “ping -c 3 8.8.8.8” a try and see if it returns results

Are you running a VPN? If it didn’t close down normally, sometimes that will cause these symptons.

I had similar issues when traveling at some locations. I ended up going into the Brave settings and reseting everything on Brave to factory settings and then it worked. Might want to try that though I never had an issue at home. I run Zorin Pro OS.

Hi. Welcome to the forum. Regretfully I have no idea what is happening on Linux. You’ve done what I would. Try different browsers, restart, hotspot and different OS. I hope someone here can help. Until then, try a general web search for that error message. And also go to the forums for those browsers and search also. You can also ask questions there. I’ve gotten responses from Brave on issues. Never tried on Firefox but I suspect they will help.