No devices detected with adb or fastboot installing Calyx on Pixel 3a

[SOLVED] - On my Pixel 3a, I had to go to System > Connected Devices > USB and switch from No file (or was it data?) transfer to File Transfer.

My phone immediately showed up on my Linux machine’s file manager. I started the flash process in the terminal, and everything worked like a charm after that.


I’m trying to install CalyxOS on a Pixel 3a I got from Swappa that is supposedly unlocked.

I’m pretty sure I followed all the directions at I’ve tried installing from Linux and from Mac. I’ve tried 3 different USB cable setups. I’ve used version 2.0 of the Flasher (based on a suggestion online).

Each time I get to the point where my laptop doesn’t want to recognize I have a phone connected. I get the error message in the subject line: No devices detected with adb or fastboot.

From what I read, you can connect with one or the other. I don’t understand why, if this is something needed, it’s not addressed anywhere in the directions for installing the OS.

Suggestions for what to try next?


I haven’t tried installing CalyxOS, but I have tried eOS with my Samsung Galaxy S9+. I had to enable fastboot on the phone itself. Is that something that the instructions you’re following had you do?

1 Like

No, it’s not. These are the directions…

Interesting. They don’t instruct you to put the phone in fastboot or any kind of download mode. This is very different from what I am familiar with.

Have you tried pursuing their chat or reddit page for solutions?

1 Like

No, I haven’t. This JPro forum is my first reach out.

I would suggest checking those, and even contacting their support if necessary.

1 Like

Yeah, I posted the problem on their Reddit now. (I had already joined earlier for a different problem.)

1 Like

UPDATE: I just noticed a warning message that comes before the script stops. It says…

WARN adb skipping device 98DAY148VD as getting code name failed: exit status 1

Sounds directly related, but no idea what it means.

(Already added this to my Reddit post.)