No Bluetooth adapters have been found

I’m wondering if anyone knows why I lost my bluetooth capability after loading kde plasma 5.18.8 + ubuntu 20.04? The error reads “No Bluetooth adapters have been found”. I have an Asus bluetooth adapter which worked fine when running Ubuntu on it’s own. My system is a Dell Latitude laptop. I’ve tried installing Bluez and Blueman and neither seemed to do the trick. I think I need expert advice :grin:

I have no real experience with Ubuntu or Asus, but I’ll throw in.

  1. I had a KERNEL that didn’t play well with my updated video drivers on an NVidia (go figure) card, so you may look at trying a different Kernel

  2. Mint (what i use) has a DRIVER MANAGER which i would think straight Ubuntu would have something similar, and it does a great job at telling you if any drivers need update…maybe your bluetooth drivers need updated to play with the Plasma.

Not sure just things to try that can’t hurt

1 Like

Hey @DPFisher!
Can you open up a terminal and execute the following command?


Once you do, please send me the output by responding to this message (so that I get tagged). :slight_smile:

1 Like

Hi Vasileios! Apologies for my late response to your request… Here is the output;

Hey @DPFisher!
Apologies for my delay also. From the LSPCI I see that you do have a network adapter, (the Centrino one), which is only for the WiFi. The Asus, if you still have it connected, does not appear here.
Can you also run the following commands and post the results here?

inxi --full

If Inxi doesn’t exist, you can install it via:

sudo apt install inxi


1 Like

Hi @vasileios!
Here is the first one:

…and here is the second:

Thank you for posting this, @DPFisher!
The process needs a few steps, but once done, it should work normally. First, the Asus USB utilizes a Realtek chip, so, we’ll need drivers for that, not the actual Asus.

The steps will include pulling the firmware and material from the Windows driver and you can find those in the link below:

Hi @vasileios , I downloaded the driver and completed the installation guide, but I think I used the wrong file name. I just used the one on the guide, but I suspect I need to use one on the output of the dmesg command.

So here’s part of the output below. Maybe you can help me figure out the correct filename?

I think it’s at ce = 2.00
So, maybe device id is 0a5c:5800?
Place driver here?:
/lib/firmware/Realtek/ASUS USB-BT500- 0a5c:5800

Okay, I had to search a little as your USB is a bit of a… rare commodity!
You’ll need a specific firmware driver for it, which is the same used by another dongle. I looked for it in several places, including the official site, but its search function doesn’t work and a direct file-pull gave me an access denied. However, I was able to detect it via a different vendor.

Before we move to the deep areas, try the following:

sudo apt install firmware-realtek

And then reboot. If it works, then great! If not, continue on reading.

Below is the driver I found online:

The link to download it is the one below. Select the Linux one.

However, it mentions that it will support up to Kernel 5.7. Ubuntu 20.04 started off with Kernel 5.4, but throughout the past couple of years, it upgraded (or surpassed) Kernel 5.12.

Let’s give it a shot through.

Download the above driver and decompress it in your Downloads folder. Then, open up a terminal and type in ( assuming you decompressed the ZIP file into the 20201202_LINUX_BT_DRIVER folder):

cd ~/Downloads/20200102_LINUX_BT_DRIVER

First, make sure you have the necessary tools to compile it.

sudo apt install build-essential

Then execute:

sudo make install

One line at a time.

If it produces an error (which is possible), then you can resolve that by executing the following two commands (assuming you decompressed the ZIP file into the 20201202_LINUX_BT_DRIVER folder):

cd ~/Downloads/20201202_LINUX_BT_DRIVER/rtkbt-firmware/lib/firmware/rtlbt/
sudo cp ./rtl8761b_fw  /usr/lib/firmware/rtl_bt/rtl8761b_fw.bin
sudo cp ./rtl8761b_config  /usr/lib/firmware/rtl_bt/rtl8761b_config.bin

Then reboot and test it out. :slight_smile:

1 Like

Woo Hoo! I had to go deep into the second route using the terminal commands. And… it worked! Thank you, thank you, thank you! Vasileios you are the BEST. I feel so empowered. Can’t believe I was able to muddle through to success. Amazing. I am grinning ear to ear, lol. :grin:

Have a wonderful day,


1 Like

I am truly happy to hear that! Great work on getting through this! Bravo! :smiley:

1 Like