No Audio - New Installation Ubuntu v20.04

Installed Ubuntu v20.04. Audio output and input not working.
Source shows as Dummy
Input shows nothing
Audio works if connected to a bluetooth device, but no audio on device speakers
New Teclast F7 laptop device

@Linux-Laptop:~$ inxi -SMA
System: Host: Linux-Laptop Kernel: 5.13.0-25-generic x86_64 bits: 64 Desktop: Gnome 3.36.9
Distro: Ubuntu 20.04.3 LTS (Focal Fossa)
Machine: Type: Laptop Mobo: N/A model: N/A serial: <superuser/root required> UEFI: American Megatrends v: Tpad3.02
date: 06/08/2021
Audio: Device-1: Intel driver: snd_hda_intel
Sound Server: ALSA v: k5.13.0-25-generic

Hey @LinuxUser and welcome to the forums!
Can you open up a terminal and execute the command:


and then screenshot the output?
You can upload it here by dragging and dropping the file in your response window.
Thank you!

Thanks for your response, see attached requested info

Hey @LinuxUser!
Thank you for posting the output!
It appears that the module for the snd_hda_intel is missing, so we’ll need to check if we’re hitting a bug or if the files are not actually present. Thus, we’ll need to try a few approaches and see which one is the case.
First, let’s try to see if the modules are somewhere in your system. Open up a terminal and execute:

sudo modprobe --show-depends snd_hda_intel

Please let me know of its output.

Thanks, please see attached.

Thank you! Next, we’ll need to see if we’re getting any output from the following commands:

lsmod | grep snd_hda_intel

And this one:

lspci -nnk | grep -A2 Audio

I ran both commands. Attached is the out for the lsmod command. there was No out for the second (lspci -nnk…)

Thank you! You might be dealing with a kernel regression bug which is bound to be fixed at some point. Let’s see if the following process helps. Open up a terminal and execute the following commands:

echo "options snd-hda-intel dmic_detect=0" | sudo tee -a /etc/modprobe.d/alsa-base.conf
echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/blacklist.conf

Then reboot and see if that solves your issue. If it doesn’t, execute the following command:

echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

And try a reboot again.

As a last resort, some of the firmware might be missing from the kernel, which can be installed via:

sudo apt install linux-modules-extra-$(uname -r)

Ran the 3 commands above. The first 2 did not resolve. I ran the 3rd (echo “options snd-hda-intel model=generic” | sudo tee -a /etc/modprobe.d/alsa-base.conf) and rebooted and now the sound card is showing in the Sound section, but still no sound when i did the Audio test.
Audio Device now shows

Should I still continue with the last note you sent to run: sudo apt install linux-modules-extra-$(uname -r) ?

Note there is still no Input device option :confused:

I did some additional research on your model. This one appears to be more prevalent in the Asia markets alone, hence the Linux developers haven’t worked with it too much.

However, I was able to find some patched Kernels that were built for the F5 and are compatible with the F7 and work with Ubuntu 20.04.

Download all the DEB files into a folder (create a new directory, just for them). Then enter that folder and right-click on empty space and select “Open in Terminal” or “Open Terminal Here”. Then execute:

sudo apt install ./*.deb

Once done, execute:

sudo gedit /etc/default/grub

Look for GRUB_TIMEOUT and make it look like:


Also, there should be a line that has =hidden on it. Go to the beginning of that line and insert the # symbol (it will make your boot menu visible). Save and exit.

Then, return to terminal and execute:

sudo update-grub

Then reboot and when the menu appears, select the 5.10 Teclass kernel and press Enter.

Please let me know if that helps.

Hi thanks for your response again - i followed all the steps including the reboot - where should i see/find this: “…Then reboot and when the menu appears, select the 5.10 Teclass kernel and press Enter…” — I did not see anything for this?.

I figured out what you meant and selected 5.10, although no luck. :frowning: Still no sound and still no Input audio options. I doubt that it matters but wanted to point out that the Audio does work if i have Bluetooth turned on and connect to an external speaker. Is there any way to determine if the last steps above you requested show if there any errors etc?

Hey @LinuxUser,
All issues would have come up under the /var/logs folder - or you can find them under the:


Command. However, this is a very long log file (errors are in red) and it might be unlikely you’d encounter the audio specific ones if the card is not fully recognized.

Can you execute the following commands and please let me know of their output?

pacmd list-cards
pacmd list-sinks

Thank you!

both requested files are attached…

Thank you!
Does this command help?

pacmd set-card-profile alsa_card.pci-0000_00_0e.0 output:hdmi-stereo

Also, after the above command, try:

sudo apt update && sudo apt upgrade -y
sudo apt install pulseaudio
sudo apt install --install-recommends qasmixer

If Pulse Audio is already installed, then open up the QasMixer and check if any of the output channels is muted or otherwise set to zero volume.
If Pulse Audio wasn’t already installed, try a reboot and check with the QasMixer.

Please let me know if the above helps.

tried all the commands requested but dang, no go :confused: