Network card install on Debian Bullseye

Hey, I’ve installed Debian Bullseye on an old Dell Vostro. This is my third install of a linux OS (all different distros) and this is the first one where the network card hasn’t automatically worked.

When the computer is starting up, I see this message on the screen before it goes in to the desktop:

firmware: failed to load rtl_nic/rtl8168e-2.fw (-2)

The network card in the machine is an Intel Centrino Wireless -N 1030 (Rainbow Peak) (Rev. 34).

I’m not sure how to go about installing the drivers/firmware on linux - could somebody help? :slight_smile:

Hi @jolee!

Info from Linux* Support for Intel® Wireless Adapters shows the driver packages.

There is also a iwlwifi-modules package that you could try to install in the terminal:

sudo apt install iwlwifi-modules

Restart your machine after the install. Let me know if that helps.

Thank you for helping! I typed that command in terminal and got this:

I also downloaded a driver, but it won’t let me copy and paste it into the lib/firmware folder.

What distro are you using?

Also, that will happen if you don’t give yourself admin permissions when you initially install the OS.

Debian GNU/Linux 11 (bullseye)

Thats right! :man_facepalming: Apologies, kind of chaos in my house this evening.

Follow this guide to add yourself as an admin and then try the install again.

That’s ok. Chaotic houses are excellent :joy:

I managed to add the user as an admin. I ran the install iwlwifi-modules command again and it said unable to locate package iwlwifi-modules.

Let’s try this just to make sure:

Do an update, and then do an apt search for it to verify the name

sudo apt update && apt search iwlwifi

Let me know what the search results are.

Here’s the results:

Okay, your system is trying to get software from a cdrom, which is not correct. We need to update your repository mirrors.

Go to Applications > Settings > Software and Updates. From there you should see something like “Mirrors”. Click on that and update it to the one that that has the highest download rate. You may have to wait a bit for your system to determine how fast they are.

There will be a main mirror, and a secondary mirror. Update both of them and then try the install again.

If you have any issues, take a screenshot and post it here.

Thanks, I really appreciate your help!

Software and updates just won’t open. It’s a bit broken isn’t it. Maybe I should just try a fresh install and see if it works better, or is that just wishful thinking?

You might try that, but it may also put you in the same boat again. I am not completely familiar with Debian, but I do know that I attempted to test it out myself a couple times and had issues. I have heard that Debian can be a little tricky to set up and install. Have you considered Ubuntu or Mint at all?

This is a 32bit system so I’m trying to find the best distro to run on 32bit? I tried Xubuntu but that was a bit clunky for this machine, it’s for my young daughter. Which one would you suggest?

openSUSE has a 32-bit version with their Tumbleweed release. Bare in mind though, that openSUSE uses the RPM package manager, as opposed to Debian’s APT package manager.

Linux Mint Debian Edition also has a 32-bit version available. It uses the APT package manager, which is the most common.

Excellent, thanks. I’m not sure what the difference is between RPM and APT but there’s something else for me to learn :slightly_smiling_face: I’m new at Linux. So far it’s awesome though.

I will try the Mint Debian version. We need something that will instal apps in a user friendly way. I didn’t find that one the other day when I was searching for 32bit options!

Once again, thanks for all your help!!

1 Like

Hey, @jolee!
Sorry to bust in last moment. I’ve happened to use Debian in the past and I know it can be a pain with simple tasks. However, once you get it up and running, it’s rock solid.

Does your system have any internet at all? What I mean is - do you have the option to connect it via Ethernet directly to the router?

Hey - Linux Mint is now up and running! Everything just worked. I love how quick and easy it is to install!

Yesterday I did plug in an Ethernet cable and that didn’t work either.

I did like the look of Debian Bullseye…Installing Mint was a quicker option to get up and running right now though, and 10yo daughter is super happy :slightly_smiling_face::raised_hands: