Need help with terminal commands. I'm getting "no such file or directory"

Hi everyone. My wife has been very active on the Telegram chat, and I just joined! I’m the “tech guy” with our stuff and I’d like to ask for some help as we’re in the process of switching her laptop to Linux. Jeff asked me to post my question here.

Mint is installed on a half partition, and we have some things moved over (her old Windows setup is the other half). I’m looking to install iDrive for backups and I need to run scripts to do that. First I need to run a permission command of (their example) “chmod a+x .pl" to give permissions to all the scripts. I ran exactly that and I’m getting “no such file or directory” errors. I tried "chmod a+x /IDriveForLinux/scripts/.pl” and got the same error of “no such file or directory”. The folder is at home/sallie/IDriveForLinux/scripts.

Calling iDrive for support has me talking to foreigners who apparently don’t know anything about Linux and are typing like crazy in the background. I need “real” help and I think it might be my early level of use of terminal that might be the issue. You can see that I’m trying to figure this out. I would appreciate some advice. My wife says this group has been great to follow, so here I am. Thanks!

Follow up: I just had a remote control session with an iDrive tech. He worked in the terminal and could verify that directories exist, and tried to chmod the permissions per their directions but it wasn’t working. He also looked for the script files by the terminal but they were saying they weren’t there. Odd. They are there. You can see the window with the path to the files in the attached screen shots. This can give you an idea of what’s being tried.




You can see that when he tried to verify the folders in the tree that he got “Is a Directory” replies. But when I tried to locate a file in the “scripts” folder, there was “no such file or directory”.

Being new to the terminal in Linux, does anyone see a problem here with this? Yesterday I had a couple other situations where I was trying to run a command and got “no such file or directory” (can’t remember at the moment what the files were I was trying to accomplish, so no specific examples). Is this an error with Linux that is remedied or is there something that I should look into?

I’ve had no problem running some other commands, so this is not a “terminal is broke” thing or something.

Hey @DavidBorrink!
Thank you for a good night’s laugh! Obviously the guys at iDrive are clueless about Linux Bash Shell!

The thing with Bash is that it may have some similarities with the Windows Command Prompt, but when you get a bit deeper, it changes quite a bit. First of all, when you type in the / symbol in the beginning, it drops your shell down to the root level. As I see from your screenshot, you did not download the iDrive on the root level. Actually your folder is:

~/Downloads/iDriveForLinux

The ~ symbol is an alias for the current user’s home folder. Though I have to admit it’s the first time I hear of executable scripts with the .pl extension (all I’ve seen are the .sh ones). If the folder scripts only has scripts in it, then you can simply open up a terminal anywhere and type in:

chmod -R +x ~/Downloads/iDriveForLinux/scripts/

This will recursively turn all files in there into executables.

Once that is done, then you can dive in:

cd ~/Downloads/iDriveForLinux

And execute the scripts you want, by starting with the ./ definition. For example (I’ll use an imaginary script name):

./iDrive_techs_are_ignorant.pl

And it should execute the file. :slight_smile:

3 Likes

Well that would explain why things looked odd when I watched him take over the computer and try to do it. I’m glad I shared those screen shots.

Thank YOU for your explanation. That is exactly what I need to know. It’s a good explanation of what the structure is and what symbols get me where I need to go. And having the permissions example is key to getting this going. I really appreciate your help and I’m glad I gave you a laugh because it means the truth is going to be shared. I’ll give this a go.

Here is a screen shot of my process.

I first tried to chmod the path I saw in the File manager, with “sallie” in the path. This had an error, so I tried just the iDrive folder and scripts and that didn’t take. Then I moved the folder into Downloads and tried the path you suggested. I didn’t get a bash message with no such file or directory. I assumed this was good.

Then I did the cd ~/Downloads/iDriveForLinux which you gave. I got a blue response that I assume was “you’re in now”. Next was to run the account_setting.pl file which is iDrive’s first script to run. It said no such file. Well you can see in the screen shot that the file is the first one in the window.

So I need your advice again. Thanks!

No worries! I was looking up the script types and I suspect they aren’t executing because you’ll need to install the Perl command set. You can do so by executing - in terminal:

sudo apt update & sudo apt upgrade -y

I placed that in case there are any updates left (so that you don’t have any dependency version mismatches). It will ask you for a password. Go ahead and type it in, even if it’s not visible and press Enter. Then install Perl by typing:

sudo apt install perl

Since you entered your password earlier, it has a timer before it expires, so you won’t get a password request again.
Then you can try to run the scripts. If that fails, then you can simply run (for example the account one) by executing:

perl ./account_setting.pl

While you’re inside the scripts folder. :slight_smile:

Thanks again. I really appreciate you taking the time to help this somewhat Linux newb. What do you mean by “while you’re inside the scripts folder”. Do I need to run a command that says “focus on stuff in the scripts folder”?

It’s when navigating via Terminal. When you type in:

pwd

The result should be the folder where the scripts are.
And you’re very welcome!

I did find a reference for an overview of the most important Linux commands so I was able to learn what cd, pwd do to get around a bit and navigate.

Okay, I got it to work! I was able to execute the first script “account_setting.pl”, where they are asking me to “Enter your service path [This location will be used to maintain the temporary data used by your scripts]”. Okay, so I created a folder at ~/iDriveForLinux/temp-data-folder. Sounds good. So a few tries with ~ at the front, and with home/sallie/iDriveForLinux/temp_data_folder/ have me nowhere. I’m wondering how I can tell them where the folder is. (And you’ll notice on the screen shot that they say this is 'optional". No, when I tried to go optional and go to the next script, it said I had to do the account_setting script. I’m starting to wonder…)

The next script is the login.pl script which establishes my user name and password to them, and at that point they say I will be able to log into their site and go to my dashboard where my other computers are already there and then I should be able to configure the backup of the Linux machine. I just need to get over these couple of hoops!

This seems like an awful lot of work!
Mind you, I used iDrive - I think for a month? I went online to check and my backups were off-line for 10 days. I had to contact them to “wake up”. Eventually I cancelled their services and got a refund.

I have heard great words for IceDrive, which also has a native Linux app. This definitely doesn’t appear to have all the hoops iDrive does.

https://icedrive.net/apps/desktop-laptop

Just a thought!

Thanks for the tip. I might consider that in case iDrive winds up being a problem.

I did find a help image that showed the proper path setup as a filled out example script. it was /home/NAME/FOLDER/ and not ~/. It’s all these details to learn, but it’s good. Thanks for making my first foray into your forum a positive one. I’m looking forward to learning and then giving back eventually.

1 Like

Yes, some scripts go with the /home/username approach in the case they are executed by another user (such as root). The ~ symbol directs to the home folder of the actual user running the script. :slight_smile:

And you are very welcome!