Monitor selection problem

I have a faulty laptop screen #1. My only screen is the plug in monitor #2. Everything has been fine for years this way. I reinstalled the OS and now I can’t see the main screen #1 on screen #2 so I can’t do anything…
How can I fix this??
Are there some magic sudo words…???

1 Like

Not knowing what your laptop or distro are.

My first suggestion would be to investigate which keyboard combo would switch the output, i.e., on my older Lenovo Fn + F7 would mirror everything from onboard screen to a connected Monitor/Projector via my onboard HDMI port.

A function like this would be independent of the OS so long as the onboard external video drivers were supported during the OS install.


1 Like

I am stupid, sorry…
ASUS X200MA lap and Mate 22.04.1 64bit
I tried the keyboard thing but it does nothing to help it. It just turns off the screen. If I close the lid it won’t switch over either…
When I did the install everything was fine until the restart to complete the install. I thought I must have done something wrong so I did the install again… Same problem…

No, not stupid, just lacking some pertinent details that we may be able to use to help.

So, what I’d like you to do is boot from your installation media but not start an install, just run the “LiveCD”. Open a terminal and run lspci so we can get some hardware info.

Some laptops have different GPU for onboard and external.

1 Like

Thank you Mr D… Is this the list you wanted…?

Yes, you’re card is obviously recognized by the installer.

We could mount your installed system drive and attempt to “sudo” cp your LiveCD xorg.conf to the actual install partition, shutdown and reboot and see if that makes a difference.

I can’t tell you were exactly to look for it as I don’t have and Ubuntu Mate anymore or even a VM to test in.

I think you are the “root” user under the LiveCD. I ahve not tried this so I cannot vouch for it but since you can’t get a monitor up this may be a cure for the problem.

I would locate the LiveCD xorg.conf, we’ll refer to this as /path/to/livecd/xorg.conf

Possible locations:

Then mount the actual install partition, locate the installed one and we’ll refer to it as /path/to/installed/xorg.conf

Then mv /path/to/installed/xorg.conf /path/to/installed/xorg.conf.orig so we have the orig still.

Then cp /path/to/livecd/xorg.cong /path/to/installed/xorg.conf

Let me know how you decide to attempt it.

WoW, this looks complicated for me but I will try it…
ok, I found it sort of… the one I found has a “d” after it.

how do I mount the folder?

*.d denotes a directory, we need xorg.conf

To mount a drive, first we need to know the device name. We can use lsblk (note those are lowercase L)

Post a pic if you’re uncertain.

Second issue the command mount /dev/sdc6 /mnt

The installed drive would now be /mnt/path/to/installed/xorg.conf where /path/to/installed/ is replace with the location on the installed drive directory tree.

Ok, thanks… I will have to sleep now because it’s late here and my 70 yo brain hurts… lol
I’ll be back in 9ish hours…

1 Like

Hello Mr D,
I had a thought. will I try a different Ubuntu that won’t have this problem or will it be the same with them all? This lap will just be used for streaming movies and surfing, nothing else. I use it just for entertainment…

A different version couldn’t hurt.
Possibly Xubuntu, Lubuntu or even Kubuntu.
There are a lot of Debian/Ubuntu based distros out there.

I downloaded Xubuntu and it installed perfectly, no screen problem at all…
Thank you so much for your help Mr D :slight_smile:

On my other pc I am wondering if this is normal because there are 10 pages of it…

it’s on my…
Operating System: Ubuntu Studio 22.04
KDE Plasma Version: 5.24.7
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.19.0-1018-lowlatency (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i3-7100T CPU @ 3.40GHz
Memory: 3.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 630
it’s made by Dell…

Glad to hear it, after seeing your specs at bottom, I’m glad you chose Xubuntu over Kubuntu too.

I think this is Ubuntu based specific /dev/loop’s.

Open a terminal and run sudo df -ah and drop a screenshot of that if you would.

Also run snap list anddrop a screenshot of it as well.

Thanks Mr D…

That’s what i thought, /dev/loop’ s were Ubuntu snap stuff.

You can “block” snaps an redo it all from beginning, or run Linux Mint, Ubuntu Mate and drop snaps, or use what you got.

Up to you.

Is snaps the thing that slows down vlc opening fast?
If i reinstall Studio it will it fix it or will I just install Mint and be done with it

Yes, snaps is more then likely whats slowing your whole system down.

Its your gnome desktop, brave and vlc… With Ubuntu you will be defaulted to snap installs.

With Mint you would not. Mint does not add snap support by default.

I will add, that under the hood, Mint is Ubuntu based, which in turn is Debian based.

OK, thanks Mr D. I will install Mint on this machine. I’ll do it during the week when I am not distracted. If Snaps slows things down then why is it used…seems silly to me…
Thank you so much for all your support with my problems,you have really helped my confidence in working with computers.

1 Like

As far as I’m concerned Ubuntu is compromised as in collusion with BigTech, etc.
This to include hardware manufacturers.
Snaps require more resources then non-snap distros.
The fact that they closed the source even on FOSS applications under snaps should be a huge red flag for any Linux user.

1 Like

I was wondering how long it would take for the system to be compromised because it threatens them… I stopped using Firefox because it’s compromised in my opinion, and I am surprised it’s still within all the Ubuntu distros. I moved from MS about 8 years ago into Ubuntu. The last Windows OS for me was Win7… I had lots of failures but I kept persevering because back then it was hard without any non tech talk help. I just like Ubuntu because in my experience, once it’s installed it doesn’t have problems unlike Windows…
I do wish I could understand it much better. I bought my first computer in 1975ish… It was made by Exidy with a Z80 processor… lol… and 1M of ram I think… It was a fun toy…