Mint 21.1 Cinnamon/Ubuntu errored on kernel update 5.15.0-72-generic removal

It appears on my Linux Mint 21.1 Cinnamon PCs that the Grub Customizer app I had installed prior to upgrading to the new version OS, trashed that install and it’s relating folders and files, and therefore my custom boot menus still worked in this present installed kernel version but errored on the next two versions with a “broken pipe” error. I don’t know how to edit this error path out of the grub config. files to restore the ability to clean up this error. Therefore my kernel version remains in version 5.15.0-71-generic and any further updates will not install properly due to the failing removal of the 5.15.0-72-generic version that tried to install. Here is the error issue after trying to upgrade to version 5.15.0-73-generic kernel:

Setting up linux-image-5.15.0-73-generic (5.15.0-73.80) …
Processing triggers for linux-image-5.15.0-73-generic (5.15.0-73.80) …

  • dkms: running auto installation service for kernel 5.15.0-73-generic
    update-initramfs: Generating /boot/initrd.img-5.15.0-73-generic
    Sourcing file /etc/default/grub' Sourcing file /etc/default/grub.d/50_linuxmint.cfg’
    Sourcing file `/etc/default/grub.d/init-select.cfg’
    Generating grub configuration file …
    using custom appearance settings
    Found background image: /home/jkwetmiller/Pictures/Chloe/100_1355(1280).jpg
    /etc/grub.d/bin/grubcfg_proxy: error while loading shared libraries: cannot open shared object file: No such file or directory
    cat: write error: Broken pipe
    run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
    dpkg: error processing package linux-image-5.15.0-73-generic (–configure):
    installed linux-image-5.15.0-73-generic package post-installation script subprocess returned error exit status 1
    Errors were encountered while processing: