Macbook possibilities

Hello everyone,
I want to get a laptop that I can wipe completely and make linux. I’m looking at a 2018 Macbook Air, good choice? It has the T2 security chip. Is there a year or model of the MacBook line that would anyone would recommend (or has real world experience with?)

Thanks

I loaded multiple distros on my Macbook Air 2012 before settling on Zorin. It is running just fine but being older some of the other distros seemed slow or clunkier than I expected. I also have a Macbook Pro 2012. I had the same experience with it and now run Zorin on it. I barely use the Pro mostly since the Air form factor is so much nicer. Just my personal experience

1 Like

Hey @Fire!
The T2 chip may prove a bit troublesome, but I think there are custom kernels for it. I personally haven’t wiped my 2019 MacBook Pro - as I still need it for some apps I utilize for my company. However, it can boot into Linux once you disable some security aspects inside the CMD+R firmware area.

I’ve personally had success with Linux with Macs from 2009 to 2016 and I personally have a 2014 MacBook Air that runs - currently - Ubuntu Studio 21.10. I’ve also used it successfully with Zorin 16 Pro. The only thing that doesn’t work out of the box is the camera, but there is a topic here to make it work. Search for facetimehd and you’ll spot it. :slight_smile:

Or, if you want, I can offer you an additional method for the camera, via DKMS (Dynamic Kernel Module System), which compiles the camera driver automaticaly every time you have a Kernel update. :slight_smile:

3 Likes

I have a ~’09 MBP. Tried to install Ubuntu. It now boots to purple screen and freezes.

Should I try a different distro or do I need some kind of new boot loader?

Hey @SPL and welcome to the forums!
A lot of MacBook Pros prefer the Manjaro edition. You might want to give that one a shot.
If you still encounter an issue, then you should consider installing the rEFInd boot-loader. However, this means that you may need to re-install macOS in order to do it. A good set of instructions are included in the link below:

I hope this helps!

1 Like

Update for everyone including @vasileios
I bought a MacBook Pro on eBay, received it yesterday.
I tried a usb with Ubuntu install but it wouldn’t take.
I tried Linux Mint but it wouldn’t take.
This morning I re-read a @vasileios post that said MacBook Pros seem to like Manjaro.
BOOM!
Manjaro is running on the MacBook Pro (PRE T2 Security Chip) on its own partition (dual boot for now). Once I have it running without a hitch for a few months I will feel confident enough to re-install with an entire wipe of the drive (no macOS). Apple’s greatest fear, people leaving their ecosystem for Linux, hence the T2 chip and whatever they come up with next.

1 Like

Congratulations on your success @Fire!
Regarding the T2 Macs, there was a custom-kernel ISO out there, but I’ve lost track of it as I haven’t been able to find the time to test an installation on my T2 MBPro.
Again, bravo!

I am going to lay out some thoughts to help me understand things.

I am dual booting.
One partition macOS so I can run a program I need for work.
The second partition is Linux where I spend the majority of my time.

When I have to use macOS I have WiFi and Siri settings disabled.
My home router WiFi password has been changed and the mac
has ever had this new password.

Now, from listening to Rob Braxman, I understand BLE technology
a little. Apple knows where all its devices are around the world through
the ‘skynet’ of bluetooth items all talking to each other. If the device
has a battery, and is turned off, the BLE is still sending and receiving
messages to/from bluetooth devices around it. I am fairly certain
Apple can see bluetooth devices all around that are ‘not’ Apple devices
as well, and can watch them as they move about an urban city.

Rural areas are spread out - less BT devices near each other to create
the ‘skynet’, so these areas are less susceptible to tracking.

As far as I can tell my location can be tracked if I have the MacBook with
me, but at least it is not listening with Siri (unless the device turns on, boots
in macOS, and enables WiFi and Siri. Which is not out of the question).

I think the only way to be free of ‘tracking’ would be to remove the
bluetooth hardware from whichever device I carry with me.

To be free of big tech ‘listening’ would be to wipe the macOS off the
device completely. I’ll think about it for a few days but I might just do
that - erase macOS completely. I think I can get rid of the ‘listening’ bit
of spyware.

Hey @Fire!
Your assessment is correct. The same has been true for phones for quite some time. I believe they have implemented it for MacBooks as well. Granted, my first MacBook was in 2007, when the battery was still removable. It took me a long time to get a new one (last Summer), where I started noticing what you mention above. Naturally, I found out about the BT mesh network a month later. :laughing:

So, yes, there are three ways to completely stop the tracking on a MacBook or any Mac device.

  1. Remove the BT
  2. Remove the battery
  3. Remove the macOS (solves everything)

Currently, I still use a couple of MacBook Pros for my production work, due to some of the available software. The only reason I don’t do everything in Linux, yet, is that my time is - unfortunately - in short supply. However, with BigTech doubling down on censorship, I am seeing myself shifting my work elements to Linux more and more. As soon as I gather enough money, I am eyeing a System76 beast which I will turn into my daily production driver. Especially since I’m studying how some of the Mac plugins I’m using can be transferred there. :slight_smile:

1 Like

Hello,
I’m trying Zorin 16 out on my MacBook Pro 2017 and I really like it.
When I try to install I am getting hung up at the screen ‘Updates and other software’ when I click ‘next’.
My shasum 256 checked out, so my ISO is not the problem.
I’ve flashed the ISO onto four different brand flash drives, so thats not the problem.
I’ve disconnected my ethernet, and told the install not to download updates. Still hangs at that same place (Updates and other software).
I am so impressed with Zorin that I paid for Zorin Pro (and to get help with installation).
Zorin support and I are trying to figure out the issue today with emails.
I thought I’d post my linux daily update here, maybe someone has a solution.

Lastly, when I quit out of the Zorin install I see these errors flash on my screen:

(AE_ALREADY_EXISTS) (20210331/psparse-529)

[ 0.114441] ACPI Error: AE_ALREADY_EXISTS, SSDT 0xffff9DAD811C6800 Table is already loaded (20210331/tbdata-520)

[ 0.114448] ACPI Error: Aborting method _PR.CPU1.APPT due to previous error (AE_ALREADY_EXISTS) (20210331/psparse-529)

[ 0.114453] ACPI Error: Aborting method _PR.CPU1.GCAP due to previous error (AE_ALREADY_EXISTS) (20210331/psparse-529)

[ 0.114457] ACPI Error: Aborting method _PR.CPU1._PDC due to previous error (AE_ALREADY_EXISTS) (20210331/psparse-529)

[ 0.1146021] ACPI BIOS Error (bug): Could not resolve symbol [\SB.OSCP], AE_NOT_FOUND (20210331/psparse-330)

[ 0.114614] ACPI Error: Aborting method _PR.CPU2._GCAP due to previous error (AE_NOT_FOUND) (20210331/psparse-529)

[ 0.114618] ACPI Error: Aborting method _PR.CPU2._PDC due to previous error (AE_NOT_FOUND) (20210331/psparse-529)

[ 0.114763] ACPI BIOS Error (bug): Could not resolve symbol [\SB.OSCP], AE_NOT_FOUND (20210331/psargs-330)

[ 0.114775] ACPI Error: Aborting method _PR.CPU3.GCAP due to previous error (AE _NOT _FOUND) (20210331/psparse-529)

[ 0.114779] ACPI Error: Aborting method _PR.CPU3._PDC due to previous error (AE_NOT _FOUND) (20210331/psparse-529)

[ 0.189844] DMAR: Failed to find handle for ACPI object _SB.PCI0.UA00

[ 0.189849] DMAR: Failed to find handle for ACPI object _SB.PCI0.UA01

[ 0.189851] DMAR: Failed to find handle for ACPI object _SB.PCI0.UA02

Hey @Fire!
I haven’t personally installed Zorin on a MacBook older than 2014 and the second older I have is a 2019 model with the T2 chip. I haven’t installed Linux on it, as I need its setup for my company - at least for the moment.

The messages I’m seeing are all ACPI related, which means they have to do with automated power functions (suspend, possibly automated screen brightness, etc.). Have you been able to install Zorin?

Hi @vasileios
I found Zorin 15.3 on the their website and downloaded that. It installed (full install) but its not as nice IMO as 16.1 or Manjaro. So after a bit of testing it I went back and installed Manjaro over it. About mid afternoon today Zorin got back to me via email. They thought I had a T2 chip. With a long and descriptive reply (with screenshots) I laid out my systems, T1 Security evidence, my research, and I told them that I installed Manjaro on not only one MacBook Pro, but two (wifes) model 14,2 of 2017.

What I figure is that the Manjaro team figured out how to do it so the Zorin team will figure it out too. Until then I will stick with Manjaro.

There are three small issues with Manjaro/MacBook. Speakers, broadcom Wifi, and suspend. I will live with these things until I figure them out.
Wifi: a twenty dollar usb-c Wifi fixed that.
Speakers: bluetooth works fine for bluetooth speakers/headphones
Head phones work fine with a usb-c input.
Suspend- I just shut down or lock the screen (disabled suspend for now)

Hey @Fire!
Apologies for my delayed response. I had a lot of paperwork to catch up with. The time of the year!

It is true that Manjaro works nicely on Macs. I found out that OpenSUSE Tumbleweed does too. I’m on a MacBook Air, currently, running it. However, it’s a bit harder on the setup and maintenance than Manjaro.

The reason that Manjaro works well, is that it outright ignores the security hardware implemented by Big Tech. Therefore, their setups completely bypass them. That’s why it works so well. Shortly after the distro came out, I remember installing it on two MacBooks and a desktop and I joined their forums. At some point, there was a discussion about Secure Boot, and the distro’s programmers just hacked it blind - to prove that it was anything but secure.

Zorin, on the other hand, tries to be easier for the new user - so, they try to “comply” with the security hardware set forth by Big Tech. The problem with that approach is that there is a signature file required for the Kernel to boot, as well as for the modules attached. That file is called SHIM. You can consider that similar to the PGP and SHA keys, which describe the exact nature of a file, byte for byte. Therefore, if you install any additional modules (for drivers) that are not in the officially signed repositories, then you’ll encounter issues - as the SHIM is not configured to include them.

Per your Mac WiFi (and even the camera), virtually no distro supports it out of the box. There is a little process to get them to work, but it’s very doable. All that needs to be done is detect the hardware, via the command:

lspci | grep Network

And then go to the process of compiling and install the module, if it’s not present as a package. In Manjaro, this is usually available via the AUR (Arch User Repository), but it requires a specific execution to be installed.

As for the suspend, it can be tricky at times. It works with OpenSUSE, but Ubuntu-based distros have a bit of trouble. I haven’t tested Manjaro with it.

1 Like

@vasileios very interesting!
Manjaro is running everything I need to satisfy me. I’m off to the races. Thanks for the information. I’m keeping all my Manjaro notes (like what you just posted) all in a folder on my desktop for later tinkering. Thank you.

1 Like

You are very welcome @Fire! Enjoy! :smiley:

Good Monday @vasileios
I’m looking for an answer that is hiding at the moment. I am trying to get my MacBook Pro to dual boot with High Sierra and Mint LMDE. I’ve had this laptop with dual boot before and now when I try to install along side of the Mac OS the live usb, whatever version I try, doesn’t see the Mac OS. At partition time during setup it says “no operating system detected” and wants to use the entire disk.
Just a little side note:
This laptop was a part of a school’s Apple enrollment when it was new. When I bought it if I tried to install a Mac system it would display a message that the system would be installed by the ISD and there were no other options. It would take Linux with no problem. Even multi boot. It’s taken me 8 months to get the ISD to remove it from their Apple enrollment. Last week they finally removed it and I installed Yosemite then High Sierra. It runs ok for an old Mac. It’s i7 with 16G RAM and 500G SSD.
I would really like to put MX on it and it seems to recognize the Mac OS but I have not been successful at installing. I’m like a bull in a china closet when it comes to partitioning. After years of partitioning in Windows and Mac, I seem to have some mental block on Linux.

Quick update:
I find that Linux doesn’t recognize AFP. I’m not sure how true that is but….
After installing Yosemite I opened the disk utility and created a new partition with half of the ssd with fat32. Then plugged in several live usb sticks starting with MX21. I couldn’t get it to boot with that. I ended up with Mint 21. It booted and gave me a GUI to work from. During the installation it wanted to use the entire disk however it didn’t specify which disk it was. So I selected “something else” and formatted the fat32 partition with ext4, set the root then installed successfully. Finally, it took rEFInd to get both systems to choose from on boot. After booting to Mac I upgraded to High Sierra. Now when it boots in Mac it boots to the recovery drive. And I’m stuck there for now. Back to it tomorrow. :penguin: