Lost+found permission denied

I am trying to use ‘deja dup backups’ and I ran into something curious.

My set up:
I have a primary drive 500GB with Ubuntu.
I have a secondary storage drive 1TB that I formatted with ms-doss fat.
(sidenote: should I format the secondary drive some other way?)

I ran ‘deja dup’, I selected ‘home folder’ and added the secondary drive.
I selected an external drive for the destination of the backup.
When the backup process finished ‘deja du’ said I have a problem.
Here are screenshots:

Searching the internet did not help me.
Thank you for any insight.

I fixed my problem by rebooting, moving a few folders, then starting a new back up with ‘Deja Dup Backups’. For whatever reason my ‘lost+found’ warning disappeared.

My backups are running smoothly now.

Congratulations on a job well done. Isn’t it funny how often a reboot clears things up? I do not know why most of us hate to take that step in troubleshooting, when, in fact, it should be one of the first - unless booting is the issue - lol. Cheers!