Linux Mint no longer boots after update

System report said an update needed my attention. I ran the update then rebooted. It got as far as the Dell logo and went to a black screen. It had been running perfectly up to this point. Any help is appreciated.

Did the black screen display for over a minute?
Did it show anything in the top left corner?
Also, what model is your Dell?

Good morning, Dennis,
The Dell logo comes up immediately, then after a short while there is a blinking white curser in the top left screen, then after 20 or so seconds the mint logo appears for about 2 seconds, then it flashes linux mint una in the upper left and goes black. The laptop is a Dell E6350 Latitude. I gave it to my grandson several weeks ago and it was working like a charm until yesterday.
I honestly thought it was running Mint 21 Vanessa, but I must have been mistaken. Again, any help is appreciated. Trevor, my grandson, had STEAM successfully running on it, if that makes a difference.
Thanks for your consideration.-Pam

When rebooting after the update did you use the reboot option or “hold the power key until it reboots”.
(For future reference, from a black screen try CTRL + ALT + DEL simultaneously before the power key. (Holding down the power key is for emergencies only as a last resort.))

Reboot and after the Dell logo disappears when the mint logo appears tap the ESC key. That should show you a whole ton of lines scrolling up the screen. It may scroll fast but try to look for errors or warnings, usually in red. It may be too quick to read and if so try a couple times to see if you can get any indication of the problem. Sometimes you can tap the ESC key just a few seconds after the ‘Dell’ logo disappears.

If the above doesn’t work or doesn’t show errors then after a minute or so of the completely black screen hold down CTRL + ALT and try tapping the F1 key. If nothing changes hold CTRL + ALT and tap F2 or F3 or F4 … to F8.
If any of the F keys get you to a ‘login screen’ or a black screen with a log in prompt in the upper left corner then we may be able to work with that. We have other options also so post back with results.

Sorry for the long wait, I tried all of the tricks you offered. There are no errors when I use the ESC key and when I did the Ctrl+Alt F1 this screen came up.

No errors during the information scrolling up the screen is good.
The screen in your picture is a tty login screen and that is good also. On that screen type your username and hit ENTER. It will then ask for a password. Be careful here when typing your password because you will not be able to see what you are typing and it will not look like anything is happening but that is OK. After typing your password hit ENTER and you will see something like this

[username@computer_name ~] $

If you get something similar that means that you are now logged in to your computer as your regular user.
Now you can try typing


then hit ENTER.
Hopefully that will start up your GUI (Graphical User Interface) and you will be at your normal desktop environment. Hopefully that works, let me know and we will try to get your computer acting the way it used to.

Yes, it worked, but now there is something else wrong.

That looks like some sort of tutorial for learning about Ubuntu. Notice the checkbox in the bottom right of the window. You can un-check that and it will not show up again.
I am not sure what happened during/after your update but try doing the things you normally would do on this computer and see how it goes. Post back with further info or questions.
Also, in a terminal window type
uname -a
and post the results.

Everything so far looks good to me. I see you still have the ‘Welcome’ screen on your Desktop. you can close that window anytime you want unless it is the Desktop background image. If it is a window and you don’t want to see it again you can un-check the checkbox in the bottom right corner before closing the window.
Have you rebooted yet? There is a chance that it may go to the black screen on reboot so please remember what you had to do to get to the Desktop.
Post back with any issues or questions.

I managed to get to the driver manager and change it to the original, now it works like a charm. Thank you.

1 Like