Liblsan0 broken dependency--unable to update packages/Mint

I have installed Linux Mint but am unable to get past updating/installing language packages, new Linux Mint version, etc.
I have gone to Synaptic Package Manager to fix the broken package which is “liblsan0” but to no avail. The package does not become repaired.
Please advise of next step?

Hey @zpepelepu!
Try to open up a terminal and type in the following command:

sudo apt install -f

And see if that helps.

vasileios–Unexpectedly had to boot to windows. When the process booted to Mint, I signed in and received the attached message:

After clicking “okay” on the message, the screen goes blank and nothing happens. Nor can I get a response except only to press the power switch to shut down.
Not sure what’s going on. I’m wondering will I have to re-install Linux, assuming it can be done for this dual-boot setup?

Hey @zpepelepu!
This has occured to another user before, so it’s not unheard of. What you’ll need to do is the following:

When your boot menu (Grub) appears, select “Advanced Options” for your Linux Mint. It will take you to another submenu. Select the Failsafe or Fallback (usually the second option). The system will boot and present you with a window of options. Select to activate the Network and then drop down to Root Terminal (should be the last option). Once in terminal, execute:

apt install --reinstall cinnamon

Then type in:


And see if that helps. :slight_smile:

Vasileios, did per your instructions more than once and also tried fix broken install.
Am attaching screenshots.

Hey @zpepelepu,
In this scenario, it needs (as stated in the feedback you got) an additional fixing, as there are missing dependencies. apt install -f fixes broken updates that failed to complete. Therefore, the command here should be:

apt --fix-broken install

You’ll be able to do so via the fallback/recovery mode, just as you entered.
Once that is done, then you can retry the apt install --reinstall cinnamon

I also see that - for some strange reason - the cinnamon control center is missing. If it is not installed automatically via the cinnamon reinstallation, try:

apt install cinnamon-control-center

vasileios–I did as you specified and also included apt-get update / apt --fix-missing update but resulting comments remain “E: Unable to fetch some archives or E: Unmet dependencies.”
Should I prepare a USB stick for a new install at this point?

This appears to be a case of version mismatching - probably caused by some library updates that didn’t come with the system (?). There is a solution to fix it (like finding and removing the problematic apps and then reinstalling them so that they get the correct dependency versions), but it may be time consuming. Reinstallation will definitely be faster. It’s up to you. :slight_smile:

Sounds like a reinstallation is my plan.
Given it’s a dual boot setup, what specific procedures should I do?
Many thanks.

1 Like

I would recommend going into Windows Disk Manager and deleting the Linux partitions. Then, resize the main Windows one to cover the entire drive. Then you can re-install and allow Linux to install alongside Windows. That would be the easiest method.

Sorry to bother you but I have tried Disk Management UI, Windows Powershell and Command Run without success. The first 2 options do not allow Administrator to delete the volumes and I cannot get the Linux volumes to show in the third…
Any workarounds? This adventure is getting a little hairy.

vasileios–disregard the above as I was able to use command prompt to delete the volume.
I’ll create a usb stick of the latest Mint version. Not sure what happened to cause these problems so we’ll see how it goes.

1 Like

Just an FYI–I installed 20.3 and had similar issues as before where some updates would install but others not/broken packages.
Finally figured out that for whatever reason very few focal servers would be connectable. When I found one that was stable, was able to complete updates. Well on my way to customizing software.
Can you recommend resources that would help guide me to set up VPN for Mint?