Lenovo Thinkcentre

I bought this very very cheap “refurbished” Lenovo to play around with while learning. Be gentle, I’m still new to this stuff.
The Problem: Using Ventoy bootable USB with a few distros on it. I’ve tried all of them at this point. Same outcome each time. I get “error 1962: No Operating System Found. Press any key to repeat boot sequence.” This is with BIOS, Startup, Boot Mode set to UEFI. Virtually same outcome with Boot Mode set to Auto or Legacy. I get more dialog with the error but always the same error.
If the solution is to drop kick this thing, right now I’d be more than happy to do it. Just kidding…not!

Originally this Lenovo came to me with Windows 10. I originally attempted dual boot (educational) but had the same error. Never could fix it so I did another install attempt with a complete format. Same error. So far I have tried Ubuntu, Kubuntu, Manjaro, Mint and just finished ArchLinux (once again educational following a guide).

Any advise would be appreciated, thanks for looking.

First, have you verified that your USB was written? Simply plug it in to another machine and check that there are contents on the drive, if all is well insert the USB drive into you Lenovo.

When you do a install on a Lenovo they suggest shutting down completely. Win 8, 10 and 11 don’t really “shutdown”… i suspect this is part of their “fast boot” and “spy capabilities”.

To achieve this you will need to hold the power button for at least 7 seconds. Upon boot you will either hit “F12” repeatedly, holding down or speed clicking wont help, directly after power on or some other defined F# key(search your model on Lenovo support to access bios) to interrupt start up and enter bios.

In the BIOS you will need to disable fast boot, secure boot and I personally set mine to Legacy and UEFI so I didn’t have to play a guessing game. I personally disabled fingerprint and cleared the fingerprint data as well. Follow instructions at the bottom to navigate, make changes and exit and save which will reboot.

Now on this reboot your Lenovo splash screen should also say something like “hit Enter to interrupt normal startup” or something to that effect(my new to me T460 uses Enter). This should provide you with a boot menu. Select USB HDD and go!

Hope this helps.

Thanks for the reply. Entering boot options on mine is “Enter” during start up then F1 to enter BIOS. I have played with all the startup options, boot mode I currently have set to “Auto”. The ISOs on the USB are solid. I have installed to my old computer many times over playing around with different distros.

I also acquired a Dell computer the same day the Lenovo was delivered. My employer was heading to the garbage with the Dell, I said I’ll take it for you. It runs and installs from the same USB. The Dell boots up and runs perfectly other than it sounds like a bird is being strangled in there. It will get max RAM and a new SSD soon I think.

Well no OS installed says to me it’s not “seeing” your USBand going straight to empty hdd…

Thanks for trying to give me some guidance.

That’s what this forum is for. I would love to help you get this solved, what model Lenovo are you working on?

2012 Thinkcentre M91P
BIOS Revision 9HKT53AUS
Boot Block 9H53A

Take a gander at this thread, it’s on the Mint forum but the errors the same.

Personally I would not use Envoy and multiple OS, 1 OS/image on the USB at a time. The old adage, less is more.

1 Like

Thanks for the link. I’m still working on it as time allows.
It is a well documented problem with Lenovo. Firmware, it’s looking for specific wording to run the EFI boot. I have found a couple solutions that I am working with, I’ll post here to conclude if/when I have success

1 Like

I had the same issue with a Thinkcentre M83. To fix it, I upgraded to the newest BIOS, and then enabled “CSM”. The older BIOS version did not have an option to enable CSM. I found it easiest to update the BIOS while in Windows 10, using the Operating System Version. You can download the 9hjy58usa.txt file from the Lenovo page for instructions on how to do this.

1 Like

Thank you for that, sorry I just now saw this. It’s a little busy lately. Unfortunately in my situation it wasn’t that easy. I did however update the BIOS earlier on in the process thinking it might be of some help. The machine I have is older AND was built for corporate use. I haven’t found concrete evidence that it makes this BIOS different but it’s a suspicion. There are a lot of useful BIOS options either not selectable or altogether hidden. I did find a solution and will post that in reply to the topic.

1 Like

The fix! The machine has finally accepted it’s Linux future. I found after many rewording searches some interesting things about Lenovo. When the machine comes to life it looks for “Windows Boot Manager” to boot, if it doesn’t see that, no good, going to sleep with an error for no operating system. The funny bit, it’s not been programmed to look for a file, it literally is looking for the phrase “Windows Boot Manager”. I used the link that I’ll share for the best info I found on how to correct for this, along with using Arch Wiki for specific arguments for efibootmgr so the nonsense in the link I’ll share made a little more sense to me.
Basic was to run efibootmgr -v to verify no windows boot manager label and then to make a renamed copy of grub and give it the Windows Boot Manager label. Set grub to boot first, the dummy windows label to boot second.
https://forums.lenovo.com/t5/ThinkStation-Workstations/UEFI-Mode-installation-of-Linux-distributions-on-Thinkstation/td-p/1018555

Thanks for digging around and trying to help! It’s doubtful but maybe someone will benefit from this one day.

1 Like