Laptop non-functional. No access via F2/F12

I’ve been given a laptop that won’t boot.

The SDD works fine when placed into a different machine.

I tried both F2 and F12 at startup, to see if I could boot to a USB with Mint installed. Nothing.

In each case, it looks as if the boot sequence sorta started, but then completely stalled. The screen didn’t go blank; there was just nothing going on.

Any suggestions on how I can get the laptop to work?


@nwarren I am sorry to hear of your issues. I am having an issue with an older HP laptop that does not want to recognize my USB anymore for installing a new distro. My first questions would be - which distro are you using now and what is the make and model of the laptop? This will help the amazing folks here at (@vasileios) and many others to jump in with some suggestions. Cheers!!

Hi @BigDaveAZ.

Specs: Mint, Dell e6420
Gratefully, this is an extra, donated laptop. My day-to-day laptop is quite happily whizzing along, thanks to Linux/Mint and this community! :smile:

I look forward to your posting how you resolved your HP/USB issue.


Just pitching in something to try, have you tried plugging in an external monitor and see if you get any more info on that screen instead of the laptop screen. Sometimes the laptop screens fail and you can never tell unless you use an alternate one.

It sounds like the BIOS is able to present you with options and is not the component that stalls, do I have that correct?


1 Like

Hi Michael @mva. Thanks, I’ll retry, using an external monitor.

The failure starts immediately as the BIOS begins to load. No options. Just a message that it’s “starting”, then the BIOS program itself stalls.

Could this be a “GRUB” thing?

It sounds like a BIOS issue to me right now but we can validate this theory. Do you have a working Linux USB install image handy? If this laptop will boot to the live USB Linux session then its probably not a BIOS issue.

Nope. I tried booting to USB. No go. That would’ve been easy, huh.

HOWEVER, if this is a GRUB issue, then I get full credit for creating it. :slight_smile:

I was learning about GRUB, made an edit to it, saved it, worked with the laptop, then the problem occurred at a subsequent startup.

My first guess is it’s GRUB.

Regardless of how I may have messed up, the question NOW is what do I do?

If the problem is with GRUB, can it be repaired/reinstalled when the laptop won’t boot? Is it possible to daisy-chain that laptop to a functioning laptop and access its GRUB? ….

If you are suggesting the install media is corrupted, that may be the case. A working USB will work no matter what is on the hard drive because a live USB boot never touches the hard drive at all.

Can you verify if the USB boots on another PC?

If so then your BIOS may be corrupted or something else like the motherboard is damaged. If not then create a new Linux boot USB or even try another USB stick. I have had many that have failed over time.

Right. The USB with Mint installed, boots to another laptop just fine. The 6420 boot sequence doesn’t progress for enough to read the USB. Or the SSD.

It’s acting as though the problem occurs BEFORE the USB or SSD is accessed.

It sure sounds like the BIOS is corrupted or is a motherboard issue. The only other thing I might try is to make sure the RAM memory is seated correctly in the motherboard, as that could cause premature boot ups. Though typically the BIOS would pick up this problem immediately and show an alert message.

Hey @nwarren!
I just dropped by to lend a hand. Thank you @BigDaveAZ for the tag!
Like @mva said, I am suspecting it’s a BIOS issue. This would involve having to open that dude of a laptop and reset the CMOS. Each computer has a different way of doing this. Some function by removing the battery. Others, by removing or switching a cable. Some, by holding down a button. Old desktops needed a jumper switch.

Look up your model online and add the “reset CMOS” search term next to it.

I hope this is the issue. Other than that, it could be hardware wear and tear.

Here’s what I did:

  • removed the CMOS battery,
  • checked that its charge was good,
  • held the power button for >12 seconds to dissipate any charge remaining in the laptop,
  • then replaced everything.
  • Pressed F2 when I powered up the laptop, and this is where the boot process stalled:

preparing stall

It’s been like that for a few minutes now, with no further progress.

I chose not to remove all the pieces-parts in order to access the system board and those 2 reset pins. They’re seriously buried under a lot of metal and screws.

Soooo, I guess the laptop is now history, huh.

Thanks @vasileios, @mva, and @BigDaveAZ for weighing in. Your ideas helped me confirm that it’s time to retire this machine for parts.

All best,

1 Like

@nwarren anytime. Now you can remove all those screws and such that are burying the jumpers and maybe try - after all, once you have made the decision it is only good for parts - what is the harm? Cheers!!


Hey, @nwarren!
You are most welcome! At least now you have confirmation that the old guy needs to retire by a fishing lake. :smiley:
Well, not in the bottom of it!

Speaking of old systems, I’m writing from a 2008 laptop running LMDE 5. It’s speed is pretty decent with Cinamon, believe it or not, but I’ll see how it acts under another, lighter desktop environment.

1 Like